summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSonic-Y3k2015-08-16 11:53:11 +0200
committerSonic-Y3k2015-08-16 11:53:11 +0200
commit27a21eabdaf68f5a3a2560e8473a51b3e1f803b9 (patch)
treef5e3f9def70f06017425c35297ac01269b6135c0
downloadaur-27a21eabdaf68f5a3a2560e8473a51b3e1f803b9.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47ee901272b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = m4baker-git
+ pkgdesc = Bake full-featured m4b-audiobooks
+ pkgver = 0.1.92.r23.gf282d42
+ pkgrel = 1
+ url = https://github.com/crabmanX/m4baker
+ arch = any
+ license = unknown
+ depends = python2
+ depends = qt4>=4.5
+ depends = python2-pyqt4>=4.6
+ depends = faac>=1.26
+ depends = sox>=14.3
+ depends = libmp4v2>=1.9
+ conflicts = m4baker
+ replaces = m4baker
+ source = m4baker::git+https://github.com/Sonic-Y3k/m4baker.git
+ sha256sums = SKIP
+
+pkgname = m4baker-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6d929669255
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Sonic-Y3k <sonic.y3k@googlemail.com>
+# Contributor: crabmanX
+pkgname='m4baker-git'
+pkgver=0.1.92.r23.gf282d42
+pkgrel=1
+pkgdesc="Bake full-featured m4b-audiobooks"
+arch=('any')
+url="https://github.com/crabmanX/m4baker"
+license='unknown'
+depends=('python2' 'qt4>=4.5' 'python2-pyqt4>=4.6' 'faac>=1.26' 'sox>=14.3' 'libmp4v2>=1.9')
+makedepends=()
+replaces=('m4baker')
+conflicts=('m4baker')
+source=('m4baker::git+https://github.com/Sonic-Y3k/m4baker.git')
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "${srcdir}/m4baker"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/m4baker"
+ python2 setup.py build
+}
+
+package(){
+ cd "${srcdir}/m4baker"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}