summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-04-24 14:24:54 +0000
committerDaniel Bermond2020-04-24 14:24:54 +0000
commit0b7f098e4c1228c0c61ad2051a322a48947cc56e (patch)
tree2338f6d0fe97bbcb58fb014748955cf2807ae3e1
parentb33ae95d51fabfc84d728f8d89727152f7cebc36 (diff)
downloadaur-0b7f098e4c1228c0c61ad2051a322a48947cc56e.tar.gz
Updated to version 20200423
-rw-r--r--.SRCINFO10
-rw-r--r--001-m64p-remove-build-jobs-limitation.patch12
-rw-r--r--002-m64p-enable-optimizations.patch22
-rw-r--r--PKGBUILD35
4 files changed, 39 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd726c21a32c..8d972e50b08c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = m64p
pkgdesc = Mupen64Plus with custom plugins and Qt5 GUI
- pkgver = 20200409
- pkgrel = 3
+ pkgver = 20200423
+ pkgrel = 1
url = https://m64p.github.io/
arch = x86_64
license = GPL3
@@ -24,7 +24,7 @@ pkgbase = m64p
conflicts = mupen64plus
conflicts = mupen64plus-gui
conflicts = mupenplus-video-gliden64
- source = git+https://github.com/loganmc10/m64p.git#tag=Apr92020
+ source = git+https://github.com/loganmc10/m64p.git#tag=April232020
source = git+https://github.com/m64p/mupen64plus-gui.git
source = git+https://github.com/m64p/mupen64plus-audio-sdl2.git
source = git+https://github.com/mupen64plus/mupen64plus-rsp-hle.git
@@ -43,8 +43,8 @@ pkgbase = m64p
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = d2984da34d482d6e0b25c460e67d64d0ce1a3bf5eda19f00f0245b819bf6b31c
- sha256sums = 6408930ec638866a2b0c38c6e856b7740dad992941ec462bee95a13a9507fe56
+ sha256sums = 6871b495ace8a9005d93ce3e9103a15111a67793812dd5158072c981c4c3a5a8
+ sha256sums = a999739626fc3e9d0102b65014c436bf4e9039587ccac174334672f3925f4495
sha256sums = b884fc86180346226eb7e8bf8560d2b789318e810c9e26b6adbe7d8d047188df
pkgname = m64p
diff --git a/001-m64p-remove-build-jobs-limitation.patch b/001-m64p-remove-build-jobs-limitation.patch
index cee5b9d42bad..c1c7c831fa2b 100644
--- a/001-m64p-remove-build-jobs-limitation.patch
+++ b/001-m64p-remove-build-jobs-limitation.patch
@@ -1,12 +1,12 @@
diff -Naurp a/build.sh b/build.sh
---- a/build.sh 2020-04-11 12:27:02.000000000 +0000
-+++ b/build.sh 2020-04-11 12:35:19.871637694 +0000
-@@ -19,22 +19,22 @@ mkdir $install_dir
+--- a/build.sh 2020-04-24 14:06:44.000000000 +0000
++++ b/build.sh 2020-04-24 14:10:40.693877444 +0000
+@@ -19,22 +19,22 @@ mkdir -p $install_dir
base_dir=$PWD
cd $base_dir/mupen64plus-core/projects/unix
--make -j4 all
-+make all
+-make OSD=0 NO_ASM=1 -j4 all
++make OSD=0 NO_ASM=1 all
cp -P $base_dir/mupen64plus-core/projects/unix/*$suffix* $install_dir
cp $base_dir/mupen64plus-core/data/* $install_dir
@@ -45,7 +45,7 @@ diff -Naurp a/build.sh b/build.sh
cp $base_dir/mupen64plus-gui/build/release/mupen64plus-gui.exe $install_dir
else
@@ -62,7 +62,7 @@ cd $base_dir/GLideN64/src/GLideNUI
- mkdir build
+ mkdir -p build
cd build
qmake ../GLideNUI.pro
-make -j4
diff --git a/002-m64p-enable-optimizations.patch b/002-m64p-enable-optimizations.patch
index c56c9677d6f3..19bfd75673a9 100644
--- a/002-m64p-enable-optimizations.patch
+++ b/002-m64p-enable-optimizations.patch
@@ -1,16 +1,16 @@
diff -Naurp a/build.sh b/build.sh
---- a/build.sh 2020-04-11 12:38:19.000000000 +0000
-+++ b/build.sh 2020-04-11 12:38:31.845571199 +0000
-@@ -12,8 +12,6 @@ else
- suffix=".so"
- fi
-
--export NO_ASM=1
--
- install_dir=$PWD/mupen64plus
- mkdir $install_dir
+--- a/build.sh 2020-04-24 14:10:40.000000000 +0000
++++ b/build.sh 2020-04-24 14:13:14.231642044 +0000
+@@ -19,7 +19,7 @@ mkdir -p $install_dir
base_dir=$PWD
-@@ -66,9 +64,9 @@ make
+
+ cd $base_dir/mupen64plus-core/projects/unix
+-make OSD=0 NO_ASM=1 all
++make all
+ cp -P $base_dir/mupen64plus-core/projects/unix/*$suffix* $install_dir
+ cp $base_dir/mupen64plus-core/data/* $install_dir
+
+@@ -66,9 +66,9 @@ make
cd $base_dir/GLideN64/projects/cmake
if [[ $UNAME == *"MINGW"* ]]; then
diff --git a/PKGBUILD b/PKGBUILD
index 82b20e874791..68fd08cec125 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=m64p
-pkgver=20200409
-pkgrel=3
+pkgver=20200423
+pkgrel=1
pkgdesc='Mupen64Plus with custom plugins and Qt5 GUI'
arch=('x86_64')
url='https://m64p.github.io/'
@@ -12,7 +12,7 @@ depends=('freetype2' 'glu' 'hidapi' 'libpng' 'libsamplerate' 'minizip'
makedepends=('git' 'cmake' 'nasm')
provides=('mupen64plus' 'mupen64plus-gui' 'mupenplus-video-gliden64')
conflicts=('mupen64plus' 'mupen64plus-gui' 'mupenplus-video-gliden64')
-source=('git+https://github.com/loganmc10/m64p.git#tag=Apr92020'
+source=("git+https://github.com/loganmc10/m64p.git#tag=$(LC_ALL='C' date -d "$pkgver" +%B%d%Y)"
'git+https://github.com/m64p/mupen64plus-gui.git'
'git+https://github.com/m64p/mupen64plus-audio-sdl2.git'
'git+https://github.com/mupen64plus/mupen64plus-rsp-hle.git'
@@ -31,23 +31,22 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'd2984da34d482d6e0b25c460e67d64d0ce1a3bf5eda19f00f0245b819bf6b31c'
- '6408930ec638866a2b0c38c6e856b7740dad992941ec462bee95a13a9507fe56'
+ '6871b495ace8a9005d93ce3e9103a15111a67793812dd5158072c981c4c3a5a8'
+ 'a999739626fc3e9d0102b65014c436bf4e9039587ccac174334672f3925f4495'
'b884fc86180346226eb7e8bf8560d2b789318e810c9e26b6adbe7d8d047188df')
prepare() {
- cd m64p
- git submodule init
- git config --local submodule.mupen64plus-core.url "${srcdir}/mupen64plus-core-loganmc10"
- git config --local submodule.GLideN64.url "${srcdir}/GLideN64-loganmc10"
- git config --local submodule.mupen64plus-gui.url "${srcdir}/mupen64plus-gui"
- git config --local submodule.mupen64plus-audio-sdl2.url "${srcdir}/mupen64plus-audio-sdl2"
- git config --local submodule.mupen64plus-rsp-hle.url "${srcdir}/mupen64plus-rsp-hle"
- git config --local submodule.mupen64plus-input-qt.url "${srcdir}/mupen64plus-input-qt"
- git config --local submodule.mupen64plus-input-raphnetraw.url "${srcdir}/mupen64plus-input-raphnetraw-loganmc10"
- git submodule update
- patch -Np1 -i "${srcdir}/001-m64p-remove-build-jobs-limitation.patch"
- patch -Np1 -i "${srcdir}/002-m64p-enable-optimizations.patch"
+ git -C m64p submodule init
+ git -C m64p config --local submodule.mupen64plus-core.url "${srcdir}/mupen64plus-core-loganmc10"
+ git -C m64p config --local submodule.GLideN64.url "${srcdir}/GLideN64-loganmc10"
+ git -C m64p config --local submodule.mupen64plus-gui.url "${srcdir}/mupen64plus-gui"
+ git -C m64p config --local submodule.mupen64plus-audio-sdl2.url "${srcdir}/mupen64plus-audio-sdl2"
+ git -C m64p config --local submodule.mupen64plus-rsp-hle.url "${srcdir}/mupen64plus-rsp-hle"
+ git -C m64p config --local submodule.mupen64plus-input-qt.url "${srcdir}/mupen64plus-input-qt"
+ git -C m64p config --local submodule.mupen64plus-input-raphnetraw.url "${srcdir}/mupen64plus-input-raphnetraw-loganmc10"
+ git -C m64p submodule update
+ patch -d m64p -Np1 -i "${srcdir}/001-m64p-remove-build-jobs-limitation.patch"
+ patch -d m64p -Np1 -i "${srcdir}/002-m64p-enable-optimizations.patch"
}
build() {
@@ -68,7 +67,7 @@ package() {
make -C "m64p/mupen64plus-${_component}/projects/unix" DESTDIR="$pkgdir" PREFIX='/usr' LDCONFIG='true' install
done
local _sover
- _sover="$(find m64p/mupen64plus-core/projects/unix -type f -name 'libmupen64plus.so.*.*' | sed 's/^.*\.so\.//')"
+ _sover="$(find "${pkgdir}/usr/lib" -type f -name 'libmupen64plus.so.*.*.*' | sed 's/^.*\.so\.//')"
ln -s "libmupen64plus.so.${_sover}" "${pkgdir}/usr/lib/libmupen64plus.so"
# other plugins