summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-11-03 02:03:59 +0000
committerDaniel Bermond2020-11-03 02:03:59 +0000
commit229fb26b76eac348561fe0e6761bb52d463498d5 (patch)
tree47fd0ab860c5cc39dd448f2a20d37e76ed184ebb
parent5c0ac432c12f796d56b9b5551bd8fd23b7514ca5 (diff)
downloadaur-229fb26b76eac348561fe0e6761bb52d463498d5.tar.gz
Update to version 20201101
-rw-r--r--.SRCINFO13
-rw-r--r--010-m64p-remove-build-jobs-limitation.patch9
-rw-r--r--020-m64p-enable-optimizations.patch2
-rw-r--r--030-m64p-fix-paths.patch (renamed from 030-m64p-fix-default-config-paths.patch)11
-rw-r--r--PKGBUILD21
5 files changed, 30 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 367f9075c0cb..00fcc4267d46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = m64p
pkgdesc = Mupen64Plus with custom plugins and Qt5 GUI
- pkgver = 20201029
+ pkgver = 20201101
pkgrel = 1
url = https://m64p.github.io/
arch = x86_64
@@ -8,6 +8,7 @@ pkgbase = m64p
makedepends = git
makedepends = cmake
makedepends = nasm
+ makedepends = python
makedepends = zip
makedepends = icoutils
depends = freetype2
@@ -28,16 +29,16 @@ pkgbase = m64p
conflicts = mupen64plus-gui
conflicts = mupen64plus-video-gliden64
conflicts = mupen64plus
- source = git+https://github.com/loganmc10/m64p.git#commit=277f5752e1589c7060cfe30eddb34ca21eb84dce
+ source = git+https://github.com/loganmc10/m64p.git#commit=aa3d849a2705bc62b9cb08e236a4819ae81c54b8
source = 010-m64p-remove-build-jobs-limitation.patch
source = 020-m64p-enable-optimizations.patch
- source = 030-m64p-fix-default-config-paths.patch
+ source = 030-m64p-fix-paths.patch
source = 040-m64p-add-pie.patch
source = m64p.desktop
sha256sums = SKIP
- sha256sums = b1b73a03aa63d855c930b01695a842528a17b15cb1f72aab04c539cd10874db9
- sha256sums = 516620afe7deafa114dbada63330f32adafbc92cac0bfc46db10fcd31805da6e
- sha256sums = feb20cb2a812a13858cce2674965c6db6b61b2712f7069bea9b38266bed3f25b
+ sha256sums = 4c483f9bf3230171c433d7f8310881babbd02416ce16079e85fd0ef254442d57
+ sha256sums = a35c7370d4545356cfcc9b10ad84250685510744911fde8910ecd224da046711
+ sha256sums = fe5d5e200f7c2fa5146b56346bd57d95c440e36569608ab0738700b0f57935cc
sha256sums = 0075fe9463f3c629066c5dd4f6407f11ff413b0f76fcd15ac61905f210c42e02
sha256sums = 8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808
diff --git a/010-m64p-remove-build-jobs-limitation.patch b/010-m64p-remove-build-jobs-limitation.patch
index defd6b4f117b..077ddb15ace7 100644
--- a/010-m64p-remove-build-jobs-limitation.patch
+++ b/010-m64p-remove-build-jobs-limitation.patch
@@ -45,12 +45,3 @@
if [[ $UNAME == *"MINGW"* ]]; then
cp $base_dir/mupen64plus-gui/build/release/mupen64plus-gui.exe $install_dir
elif [[ $UNAME == *"Darwin"* ]]; then
-@@ -85,7 +85,7 @@ if [[ $UNAME == *"MINGW"* ]]; then
- else
- cmake -DMUPENPLUSAPI_GLIDENUI=On -DNOHQ=On -DVEC4_OPT=On -DCRC_OPT=On -DMUPENPLUSAPI=On ../../src/
- fi
--make -j4
-+make
-
- if [[ $UNAME == *"MINGW"* ]]; then
- cp mupen64plus-video-GLideN64$suffix $install_dir
diff --git a/020-m64p-enable-optimizations.patch b/020-m64p-enable-optimizations.patch
index 37bd4b5b3f7b..15933d5797b7 100644
--- a/020-m64p-enable-optimizations.patch
+++ b/020-m64p-enable-optimizations.patch
@@ -19,5 +19,5 @@
- cmake -DMUPENPLUSAPI_GLIDENUI=On -DNOHQ=On -DVEC4_OPT=On -DCRC_OPT=On -DMUPENPLUSAPI=On ../../src/
+ cmake -DMUPENPLUSAPI_GLIDENUI=On -DVEC4_OPT=On -DCRC_OPT=On -DMUPENPLUSAPI=On ../../src/
fi
- make
+ cmake --build .
diff --git a/030-m64p-fix-default-config-paths.patch b/030-m64p-fix-paths.patch
index 42099dfdc85b..697c7bf1db3b 100644
--- a/030-m64p-fix-default-config-paths.patch
+++ b/030-m64p-fix-paths.patch
@@ -8,7 +8,7 @@
#include "settingsdialog.h"
#include "plugindialog.h"
#include "mainwindow.h"
-@@ -405,11 +406,11 @@ MainWindow::MainWindow(QWidget *parent) :
+@@ -407,11 +408,11 @@ MainWindow::MainWindow(QWidget *parent) :
updatePIF(ui);
if (!settings->contains("coreLibPath"))
@@ -23,3 +23,12 @@
updatePlugins();
+@@ -507,7 +508,7 @@ void MainWindow::setupLLE()
+
+ void MainWindow::setupDiscord()
+ {
+- QLibrary *discordLib = new QLibrary((QDir(QCoreApplication::applicationDirPath()).filePath("discord_game_sdk")), this);
++ QLibrary *discordLib = new QLibrary("/usr/lib/discord_game_sdk", this);
+
+ memset(&discord_app, 0, sizeof(discord_app));
+
diff --git a/PKGBUILD b/PKGBUILD
index a53f76bedaf2..8345d4b6ca40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=m64p
-pkgver=20201029
+pkgver=20201101
pkgrel=1
pkgdesc='Mupen64Plus with custom plugins and Qt5 GUI'
arch=('x86_64')
@@ -10,20 +10,20 @@ license=('GPL3')
depends=('freetype2' 'hidapi' 'libgl' 'libpng' 'libsamplerate' 'minizip'
'qt5-base' 'qt5-websockets' 'sdl2' 'sdl2_net' 'zlib' 'hicolor-icon-theme')
optdepends=('p7zip: for 7z/zip support')
-makedepends=('git' 'cmake' 'nasm' 'zip' 'icoutils')
+makedepends=('git' 'cmake' 'nasm' 'python' 'zip' 'icoutils')
provides=('mupen64plus-gui' 'mupen64plus-video-gliden64')
conflicts=('mupen64plus-gui' 'mupen64plus-video-gliden64' 'mupen64plus')
-_commit=277f5752e1589c7060cfe30eddb34ca21eb84dce
+_commit=aa3d849a2705bc62b9cb08e236a4819ae81c54b8
source=("git+https://github.com/loganmc10/m64p.git#commit=${_commit}"
'010-m64p-remove-build-jobs-limitation.patch'
'020-m64p-enable-optimizations.patch'
- '030-m64p-fix-default-config-paths.patch'
+ '030-m64p-fix-paths.patch'
'040-m64p-add-pie.patch'
'm64p.desktop')
sha256sums=('SKIP'
- 'b1b73a03aa63d855c930b01695a842528a17b15cb1f72aab04c539cd10874db9'
- '516620afe7deafa114dbada63330f32adafbc92cac0bfc46db10fcd31805da6e'
- 'feb20cb2a812a13858cce2674965c6db6b61b2712f7069bea9b38266bed3f25b'
+ '4c483f9bf3230171c433d7f8310881babbd02416ce16079e85fd0ef254442d57'
+ 'a35c7370d4545356cfcc9b10ad84250685510744911fde8910ecd224da046711'
+ 'fe5d5e200f7c2fa5146b56346bd57d95c440e36569608ab0738700b0f57935cc'
'0075fe9463f3c629066c5dd4f6407f11ff413b0f76fcd15ac61905f210c42e02'
'8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808')
@@ -31,7 +31,7 @@ prepare() {
icotool -x m64p/mupen64plus-gui/mupen64plus.ico -o m64p/mupen64plus-gui
patch -d m64p -Np1 -i "${srcdir}/010-m64p-remove-build-jobs-limitation.patch"
patch -d m64p -Np1 -i "${srcdir}/020-m64p-enable-optimizations.patch"
- patch -d m64p -Np1 -i "${srcdir}/030-m64p-fix-default-config-paths.patch"
+ patch -d m64p -Np1 -i "${srcdir}/030-m64p-fix-paths.patch"
patch -d m64p -Np1 -i "${srcdir}/040-m64p-add-pie.patch"
}
@@ -62,8 +62,11 @@ package() {
_sover="$(find "${pkgdir}/usr/lib" -type f -name 'libmupen64plus.so.*.*.*' | sed 's/^.*\.so\.//')"
ln -s "libmupen64plus.so.${_sover}" "${pkgdir}/usr/lib/libmupen64plus.so"
- # other plugins
+ # other plugins and components
+ install -D -m644 m64p/mupen64plus/libdiscord_game_sdk.so -t "${pkgdir}/usr/lib"
install -D -m644 m64p/mupen64plus/mupen64plus-input-qt.so -t "${pkgdir}/usr/lib/mupen64plus"
+ install -D -m644 m64p/mupen64plus/mupen64plus-rsp-parallel.so -t "${pkgdir}/usr/lib/mupen64plus"
+ install -D -m644 m64p/mupen64plus/mupen64plus-video-angrylion-plus.so -t "${pkgdir}/usr/lib/mupen64plus"
install -D -m644 m64p/mupen64plus/mupen64plus-video-GLideN64.so -t "${pkgdir}/usr/lib/mupen64plus"
install -D -m644 m64p/mupen64plus/GLideN64.custom.ini -t "${pkgdir}/usr/share/mupen64plus"
}