summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-10-29 18:25:40 +0000
committerDaniel Bermond2020-10-29 18:25:40 +0000
commit5c0ac432c12f796d56b9b5551bd8fd23b7514ca5 (patch)
tree82d4f6f9d48cb0584ab7d7f76744c9f387e21ee8
parent8fb68cf0c9371ec4e738ccbf562dc9d43401f3c0 (diff)
downloadaur-5c0ac432c12f796d56b9b5551bd8fd23b7514ca5.tar.gz
Update to version 20201029
-rw-r--r--.SRCINFO12
-rw-r--r--010-m64p-remove-build-jobs-limitation.patch10
-rw-r--r--020-m64p-enable-optimizations.patch4
-rw-r--r--030-m64p-fix-default-config-paths.patch2
-rw-r--r--040-m64p-add-pie.patch2
-rw-r--r--PKGBUILD12
6 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5894c4677e9..367f9075c0cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = m64p
pkgdesc = Mupen64Plus with custom plugins and Qt5 GUI
- pkgver = 20201027
+ pkgver = 20201029
pkgrel = 1
url = https://m64p.github.io/
arch = x86_64
@@ -28,17 +28,17 @@ pkgbase = m64p
conflicts = mupen64plus-gui
conflicts = mupen64plus-video-gliden64
conflicts = mupen64plus
- source = git+https://github.com/loganmc10/m64p.git#commit=1367455caf8423c03785254df60cf294144bc47c
+ source = git+https://github.com/loganmc10/m64p.git#commit=277f5752e1589c7060cfe30eddb34ca21eb84dce
source = 010-m64p-remove-build-jobs-limitation.patch
source = 020-m64p-enable-optimizations.patch
source = 030-m64p-fix-default-config-paths.patch
source = 040-m64p-add-pie.patch
source = m64p.desktop
sha256sums = SKIP
- sha256sums = 28c95005fbfa3b30bcee412070c5fc13f74a2b6f52526a9ad733778de3aaec04
- sha256sums = d3834a29ccf06be9ad1c0a3039efb4ed69d81f61e814d1578a6bd19474aa11c3
- sha256sums = 5f2e645cf807e42b41da98576e16562289b5abb2b933b0ea27c2aa48e8d177e2
- sha256sums = 132130e28c303647d61e3c52420d14c0c8f04115b1b0937e67bcd07d078a19f4
+ sha256sums = b1b73a03aa63d855c930b01695a842528a17b15cb1f72aab04c539cd10874db9
+ sha256sums = 516620afe7deafa114dbada63330f32adafbc92cac0bfc46db10fcd31805da6e
+ sha256sums = feb20cb2a812a13858cce2674965c6db6b61b2712f7069bea9b38266bed3f25b
+ sha256sums = 0075fe9463f3c629066c5dd4f6407f11ff413b0f76fcd15ac61905f210c42e02
sha256sums = 8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808
pkgname = m64p
diff --git a/010-m64p-remove-build-jobs-limitation.patch b/010-m64p-remove-build-jobs-limitation.patch
index c449a259b76a..defd6b4f117b 100644
--- a/010-m64p-remove-build-jobs-limitation.patch
+++ b/010-m64p-remove-build-jobs-limitation.patch
@@ -1,6 +1,6 @@
--- a/build.sh
+++ b/build.sh
-@@ -25,22 +25,22 @@ mkdir -p $install_dir
+@@ -24,22 +24,22 @@ mkdir -p $install_dir
base_dir=$PWD
cd $base_dir/mupen64plus-core/projects/unix
@@ -27,7 +27,7 @@
if [[ $UNAME == *"MINGW"* ]]; then
cp $base_dir/mupen64plus-input-qt/build/release/mupen64plus-input-qt.dll $install_dir
else
-@@ -48,7 +48,7 @@ else
+@@ -47,7 +47,7 @@ else
fi
cd $base_dir/mupen64plus-audio-sdl2/projects/unix
@@ -36,7 +36,7 @@
cp $base_dir/mupen64plus-audio-sdl2/projects/unix/*$suffix $install_dir
cd $base_dir
-@@ -67,7 +67,7 @@ fi
+@@ -66,7 +66,7 @@ fi
mkdir -p $base_dir/mupen64plus-gui/build
cd $base_dir/mupen64plus-gui/build
qmake ../mupen64plus-gui.pro
@@ -44,8 +44,8 @@
+make
if [[ $UNAME == *"MINGW"* ]]; then
cp $base_dir/mupen64plus-gui/build/release/mupen64plus-gui.exe $install_dir
- else
-@@ -83,7 +83,7 @@ if [[ $UNAME == *"MINGW"* ]]; then
+ elif [[ $UNAME == *"Darwin"* ]]; then
+@@ -85,7 +85,7 @@ if [[ $UNAME == *"MINGW"* ]]; then
else
cmake -DMUPENPLUSAPI_GLIDENUI=On -DNOHQ=On -DVEC4_OPT=On -DCRC_OPT=On -DMUPENPLUSAPI=On ../../src/
fi
diff --git a/020-m64p-enable-optimizations.patch b/020-m64p-enable-optimizations.patch
index 752375810666..37bd4b5b3f7b 100644
--- a/020-m64p-enable-optimizations.patch
+++ b/020-m64p-enable-optimizations.patch
@@ -1,6 +1,6 @@
--- a/build.sh
+++ b/build.sh
-@@ -25,7 +25,7 @@ mkdir -p $install_dir
+@@ -24,7 +24,7 @@ mkdir -p $install_dir
base_dir=$PWD
cd $base_dir/mupen64plus-core/projects/unix
@@ -9,7 +9,7 @@
cp -P $base_dir/mupen64plus-core/projects/unix/*$suffix* $install_dir
cp $base_dir/mupen64plus-core/data/* $install_dir
-@@ -79,9 +79,9 @@ cd $base_dir/GLideN64/src
+@@ -81,9 +81,9 @@ cd $base_dir/GLideN64/src
cd $base_dir/GLideN64/projects/cmake
if [[ $UNAME == *"MINGW"* ]]; then
diff --git a/030-m64p-fix-default-config-paths.patch b/030-m64p-fix-default-config-paths.patch
index bb9dc93ffd00..42099dfdc85b 100644
--- a/030-m64p-fix-default-config-paths.patch
+++ b/030-m64p-fix-default-config-paths.patch
@@ -8,7 +8,7 @@
#include "settingsdialog.h"
#include "plugindialog.h"
#include "mainwindow.h"
-@@ -407,11 +408,11 @@ MainWindow::MainWindow(QWidget *parent) :
+@@ -405,11 +406,11 @@ MainWindow::MainWindow(QWidget *parent) :
updatePIF(ui);
if (!settings->contains("coreLibPath"))
diff --git a/040-m64p-add-pie.patch b/040-m64p-add-pie.patch
index f26a70263bbb..248668307798 100644
--- a/040-m64p-add-pie.patch
+++ b/040-m64p-add-pie.patch
@@ -1,6 +1,6 @@
--- a/mupen64plus-gui/mupen64plus-gui.pro
+++ b/mupen64plus-gui/mupen64plus-gui.pro
-@@ -93,8 +93,6 @@ FORMS += mainwindow.ui
+@@ -90,8 +90,6 @@ FORMS += mainwindow.ui
QMAKE_INCDIR += api interface
diff --git a/PKGBUILD b/PKGBUILD
index 690daaf918fe..a53f76bedaf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=m64p
-pkgver=20201027
+pkgver=20201029
pkgrel=1
pkgdesc='Mupen64Plus with custom plugins and Qt5 GUI'
arch=('x86_64')
@@ -13,7 +13,7 @@ optdepends=('p7zip: for 7z/zip support')
makedepends=('git' 'cmake' 'nasm' 'zip' 'icoutils')
provides=('mupen64plus-gui' 'mupen64plus-video-gliden64')
conflicts=('mupen64plus-gui' 'mupen64plus-video-gliden64' 'mupen64plus')
-_commit=1367455caf8423c03785254df60cf294144bc47c
+_commit=277f5752e1589c7060cfe30eddb34ca21eb84dce
source=("git+https://github.com/loganmc10/m64p.git#commit=${_commit}"
'010-m64p-remove-build-jobs-limitation.patch'
'020-m64p-enable-optimizations.patch'
@@ -21,10 +21,10 @@ source=("git+https://github.com/loganmc10/m64p.git#commit=${_commit}"
'040-m64p-add-pie.patch'
'm64p.desktop')
sha256sums=('SKIP'
- '28c95005fbfa3b30bcee412070c5fc13f74a2b6f52526a9ad733778de3aaec04'
- 'd3834a29ccf06be9ad1c0a3039efb4ed69d81f61e814d1578a6bd19474aa11c3'
- '5f2e645cf807e42b41da98576e16562289b5abb2b933b0ea27c2aa48e8d177e2'
- '132130e28c303647d61e3c52420d14c0c8f04115b1b0937e67bcd07d078a19f4'
+ 'b1b73a03aa63d855c930b01695a842528a17b15cb1f72aab04c539cd10874db9'
+ '516620afe7deafa114dbada63330f32adafbc92cac0bfc46db10fcd31805da6e'
+ 'feb20cb2a812a13858cce2674965c6db6b61b2712f7069bea9b38266bed3f25b'
+ '0075fe9463f3c629066c5dd4f6407f11ff413b0f76fcd15ac61905f210c42e02'
'8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808')
prepare() {