summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-04-11 17:22:16 +0000
committerDaniel Bermond2020-04-11 17:24:17 +0000
commitb33ae95d51fabfc84d728f8d89727152f7cebc36 (patch)
tree97afbf72ec4a7770c3e43f38e4a0b3f14e9fdad8
parent9edd091d23634c30144f8d1d28556fc5ad871f1c (diff)
downloadaur-b33ae95d51fabfc84d728f8d89727152f7cebc36.tar.gz
Various changes
- speed up the build process by removing the build jobs limitation - enable assembly optimizations on mupen64plus components - enable HQ textures on GLideN64 - add mupen64plus include files for the core library - change url
-rw-r--r--.SRCINFO9
-rw-r--r--001-m64p-remove-build-jobs-limitation.patch64
-rw-r--r--002-m64p-enable-optimizations.patch24
-rw-r--r--PKGBUILD43
4 files changed, 116 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6fd0b8a7763..fd726c21a32c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = m64p
pkgdesc = Mupen64Plus with custom plugins and Qt5 GUI
pkgver = 20200409
- pkgrel = 2
- url = https://github.com/m64p/mupen64plus-gui/
+ pkgrel = 3
+ url = https://m64p.github.io/
arch = x86_64
license = GPL3
makedepends = git
makedepends = cmake
+ makedepends = nasm
depends = freetype2
depends = glu
depends = hidapi
@@ -31,6 +32,8 @@ pkgbase = m64p
source = GLideN64-loganmc10::git+https://github.com/loganmc10/GLideN64.git
source = mupen64plus-core-loganmc10::git+https://github.com/loganmc10/mupen64plus-core.git
source = mupen64plus-input-raphnetraw-loganmc10::git+https://github.com/loganmc10/mupen64plus-input-raphnetraw.git
+ source = 001-m64p-remove-build-jobs-limitation.patch
+ source = 002-m64p-enable-optimizations.patch
source = m64p.desktop
sha256sums = SKIP
sha256sums = SKIP
@@ -40,6 +43,8 @@ pkgbase = m64p
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = d2984da34d482d6e0b25c460e67d64d0ce1a3bf5eda19f00f0245b819bf6b31c
+ sha256sums = 6408930ec638866a2b0c38c6e856b7740dad992941ec462bee95a13a9507fe56
sha256sums = b884fc86180346226eb7e8bf8560d2b789318e810c9e26b6adbe7d8d047188df
pkgname = m64p
diff --git a/001-m64p-remove-build-jobs-limitation.patch b/001-m64p-remove-build-jobs-limitation.patch
new file mode 100644
index 000000000000..cee5b9d42bad
--- /dev/null
+++ b/001-m64p-remove-build-jobs-limitation.patch
@@ -0,0 +1,64 @@
+diff -Naurp a/build.sh b/build.sh
+--- a/build.sh 2020-04-11 12:27:02.000000000 +0000
++++ b/build.sh 2020-04-11 12:35:19.871637694 +0000
+@@ -19,22 +19,22 @@ mkdir $install_dir
+ base_dir=$PWD
+
+ cd $base_dir/mupen64plus-core/projects/unix
+-make -j4 all
++make all
+ cp -P $base_dir/mupen64plus-core/projects/unix/*$suffix* $install_dir
+ cp $base_dir/mupen64plus-core/data/* $install_dir
+
+ cd $base_dir/mupen64plus-rsp-hle/projects/unix
+-make -j4 all
++make all
+ cp $base_dir/mupen64plus-rsp-hle/projects/unix/*$suffix $install_dir
+
+ cd $base_dir/mupen64plus-input-raphnetraw/projects/unix
+-make -j4 all
++make all
+ cp $base_dir/mupen64plus-input-raphnetraw/projects/unix/*$suffix $install_dir
+
+ mkdir -p $base_dir/mupen64plus-input-qt/build
+ cd $base_dir/mupen64plus-input-qt/build
+ qmake ../mupen64plus-input-qt.pro
+-make -j4
++make
+ if [[ $UNAME == *"MINGW"* ]]; then
+ cp $base_dir/mupen64plus-input-qt/build/release/mupen64plus-input-qt.dll $install_dir
+ else
+@@ -42,13 +42,13 @@ else
+ fi
+
+ cd $base_dir/mupen64plus-audio-sdl2/projects/unix
+-make -j4 all
++make all
+ cp $base_dir/mupen64plus-audio-sdl2/projects/unix/*$suffix $install_dir
+
+ mkdir -p $base_dir/mupen64plus-gui/build
+ cd $base_dir/mupen64plus-gui/build
+ qmake ../mupen64plus-gui.pro
+-make -j4
++make
+ if [[ $UNAME == *"MINGW"* ]]; then
+ cp $base_dir/mupen64plus-gui/build/release/mupen64plus-gui.exe $install_dir
+ else
+@@ -62,7 +62,7 @@ cd $base_dir/GLideN64/src/GLideNUI
+ mkdir build
+ cd build
+ qmake ../GLideNUI.pro
+-make -j4
++make
+
+ cd $base_dir/GLideN64/projects/cmake
+ if [[ $UNAME == *"MINGW"* ]]; then
+@@ -70,7 +70,7 @@ if [[ $UNAME == *"MINGW"* ]]; then
+ else
+ cmake -DNOHQ=On -DVEC4_OPT=On -DCRC_OPT=On -DMUPENPLUSAPI=On ../../src/
+ fi
+-make -j4
++make
+
+ if [[ $UNAME == *"MINGW"* ]]; then
+ cp mupen64plus-video-GLideN64$suffix $install_dir
diff --git a/002-m64p-enable-optimizations.patch b/002-m64p-enable-optimizations.patch
new file mode 100644
index 000000000000..c56c9677d6f3
--- /dev/null
+++ b/002-m64p-enable-optimizations.patch
@@ -0,0 +1,24 @@
+diff -Naurp a/build.sh b/build.sh
+--- a/build.sh 2020-04-11 12:38:19.000000000 +0000
++++ b/build.sh 2020-04-11 12:38:31.845571199 +0000
+@@ -12,8 +12,6 @@ else
+ suffix=".so"
+ fi
+
+-export NO_ASM=1
+-
+ install_dir=$PWD/mupen64plus
+ mkdir $install_dir
+ base_dir=$PWD
+@@ -66,9 +64,9 @@ make
+
+ cd $base_dir/GLideN64/projects/cmake
+ if [[ $UNAME == *"MINGW"* ]]; then
+- cmake -G "MSYS Makefiles" -DNOHQ=On -DVEC4_OPT=On -DCRC_OPT=On -DMUPENPLUSAPI=On ../../src/
++ cmake -G "MSYS Makefiles" -DMUPENPLUSAPI=On ../../src/
+ else
+- cmake -DNOHQ=On -DVEC4_OPT=On -DCRC_OPT=On -DMUPENPLUSAPI=On ../../src/
++ cmake -DMUPENPLUSAPI=On ../../src/
+ fi
+ make
+
diff --git a/PKGBUILD b/PKGBUILD
index c422c2b11bcf..82b20e874791 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=m64p
pkgver=20200409
-pkgrel=2
+pkgrel=3
pkgdesc='Mupen64Plus with custom plugins and Qt5 GUI'
arch=('x86_64')
-url='https://github.com/m64p/mupen64plus-gui/'
+url='https://m64p.github.io/'
license=('GPL3')
depends=('freetype2' 'glu' 'hidapi' 'libpng' 'libsamplerate' 'minizip'
'p7zip' 'qt5-base' 'sdl2' 'zlib')
-makedepends=('git' 'cmake')
+makedepends=('git' 'cmake' 'nasm')
provides=('mupen64plus' 'mupen64plus-gui' 'mupenplus-video-gliden64')
conflicts=('mupen64plus' 'mupen64plus-gui' 'mupenplus-video-gliden64')
source=('git+https://github.com/loganmc10/m64p.git#tag=Apr92020'
@@ -20,6 +20,8 @@ source=('git+https://github.com/loganmc10/m64p.git#tag=Apr92020'
'GLideN64-loganmc10'::'git+https://github.com/loganmc10/GLideN64.git'
'mupen64plus-core-loganmc10'::'git+https://github.com/loganmc10/mupen64plus-core.git'
'mupen64plus-input-raphnetraw-loganmc10'::'git+https://github.com/loganmc10/mupen64plus-input-raphnetraw.git'
+ '001-m64p-remove-build-jobs-limitation.patch'
+ '002-m64p-enable-optimizations.patch'
'm64p.desktop')
sha256sums=('SKIP'
'SKIP'
@@ -29,6 +31,8 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'd2984da34d482d6e0b25c460e67d64d0ce1a3bf5eda19f00f0245b819bf6b31c'
+ '6408930ec638866a2b0c38c6e856b7740dad992941ec462bee95a13a9507fe56'
'b884fc86180346226eb7e8bf8560d2b789318e810c9e26b6adbe7d8d047188df')
prepare() {
@@ -42,6 +46,8 @@ prepare() {
git config --local submodule.mupen64plus-input-qt.url "${srcdir}/mupen64plus-input-qt"
git config --local submodule.mupen64plus-input-raphnetraw.url "${srcdir}/mupen64plus-input-raphnetraw-loganmc10"
git submodule update
+ patch -Np1 -i "${srcdir}/001-m64p-remove-build-jobs-limitation.patch"
+ patch -Np1 -i "${srcdir}/002-m64p-enable-optimizations.patch"
}
build() {
@@ -52,28 +58,21 @@ build() {
package() {
# mupen64plus-gui
install -D -m755 m64p/mupen64plus/mupen64plus-gui -t "${pkgdir}/usr/bin"
+ install -D -m644 m64p.desktop -t "${pkgdir}/usr/share/applications"
+ install -D -m644 mupen64plus-gui/mupen64plus.ico "${pkgdir}/usr/share/pixmaps/m64p.ico"
- # mupen64plus-core
+ # mupen64plus components
+ local _component
+ for _component in core audio-sdl2 input-raphnetraw rsp-hle
+ do
+ make -C "m64p/mupen64plus-${_component}/projects/unix" DESTDIR="$pkgdir" PREFIX='/usr' LDCONFIG='true' install
+ done
local _sover
- _sover="$(find m64p/mupen64plus -type f -name 'libmupen64plus.so.*.*' | sed 's/^.*\.so\.//')"
- mkdir -p "${pkgdir}/usr/lib"
- cp -a m64p/mupen64plus/libmupen64plus.so* "${pkgdir}/usr/lib"
+ _sover="$(find m64p/mupen64plus-core/projects/unix -type f -name 'libmupen64plus.so.*.*' | sed 's/^.*\.so\.//')"
ln -s "libmupen64plus.so.${_sover}" "${pkgdir}/usr/lib/libmupen64plus.so"
- # plugins
- install -D -m644 m64p/mupen64plus/mupen64plus-audio-sdl2.so -t "${pkgdir}/usr/lib/mupen64plus"
- install -D -m644 m64p/mupen64plus/mupen64plus-rsp-hle.so -t "${pkgdir}/usr/lib/mupen64plus"
- install -D -m644 m64p/mupen64plus/mupen64plus-input-qt.so -t "${pkgdir}/usr/lib/mupen64plus"
- install -D -m644 m64p/mupen64plus/mupen64plus-input-raphnetraw.so -t "${pkgdir}/usr/lib/mupen64plus"
- install -D -m644 m64p/mupen64plus/mupen64plus-video-GLideN64.so -t "${pkgdir}/usr/lib/mupen64plus"
-
- # config
- install -D -m644 m64p/mupen64plus/font.ttf -t "${pkgdir}/usr/share/mupen64plus"
+ # other plugins
+ install -D -m644 m64p/mupen64plus/mupen64plus-input-qt.so -t "${pkgdir}/usr/lib/mupen64plus"
+ install -D -m644 m64p/mupen64plus/mupen64plus-video-GLideN64.so -t "${pkgdir}/usr/lib/mupen64plus"
install -D -m644 m64p/mupen64plus/GLideN64.custom.ini -t "${pkgdir}/usr/share/mupen64plus"
- install -D -m644 m64p/mupen64plus/mupen64plus.ini -t "${pkgdir}/usr/share/mupen64plus"
- install -D -m644 m64p/mupen64plus/mupencheat.txt -t "${pkgdir}/usr/share/mupen64plus"
-
- # desktop and icon
- install -D -m644 m64p.desktop -t "${pkgdir}/usr/share/applications"
- install -D -m644 mupen64plus-gui/mupen64plus.ico "${pkgdir}/usr/share/pixmaps/m64p.ico"
}