summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-08-09 22:29:47 -0300
committerDaniel Bermond2022-08-09 22:29:47 -0300
commitbea61c7e8d6f0fe12774d0e7887fea8289f0b61d (patch)
tree6f756422251ad388c9f120753119e4e53216571b
parentdf3947bd498f043166d8f9b0a7b20f441d7a1096 (diff)
downloadaur-bea61c7e8d6f0fe12774d0e7887fea8289f0b61d.tar.gz
Update to version 20220808
-rw-r--r--.SRCINFO24
-rw-r--r--010-m64p-remove-build-jobs-limitation.patch4
-rw-r--r--020-m64p-change-optimizations.patch26
-rw-r--r--020-m64p-remove-bundled-discord-and-vosk.patch (renamed from 030-m64p-remove-bundled-discord-and-vosk.patch)0
-rw-r--r--030-m64p-fix-paths.patch (renamed from 050-m64p-fix-paths.patch)0
-rw-r--r--040-m64p-add-pie.patch (renamed from 060-m64p-add-pie.patch)0
-rw-r--r--040-m64p-fix-qmake.patch20
-rw-r--r--PKGBUILD33
8 files changed, 22 insertions, 85 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 832898d76a9a..6941b232b421 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,48 +1,38 @@
pkgbase = m64p
pkgdesc = Mupen64Plus with custom plugins and Qt6 GUI
- pkgver = 20220722
+ pkgver = 20220808
pkgrel = 1
url = https://m64p.github.io/
arch = x86_64
license = GPL3
makedepends = git
makedepends = cmake
- makedepends = nasm
- makedepends = python
makedepends = zip
makedepends = icoutils
makedepends = vosk-api
- depends = freetype2
- depends = hidapi
- depends = libgl
+ depends = discord-game-sdk
depends = libpng
- depends = libsamplerate
depends = qt6-base
depends = qt6-websockets
depends = sdl2
depends = sdl2_net
depends = vulkan-icd-loader
depends = zlib
- depends = discord-game-sdk
depends = hicolor-icon-theme
optdepends = p7zip: for 7z/zip and VRU support
optdepends = vosk-api: for VRU support (voice recognition unit)
provides = mupen64plus-gui
conflicts = mupen64plus-gui
conflicts = mupen64plus
- source = git+https://github.com/loganmc10/m64p.git#tag=v2022.07.12
+ source = git+https://github.com/m64p/m64p.git#tag=v2022.08.6
source = 010-m64p-remove-build-jobs-limitation.patch
- source = 020-m64p-change-optimizations.patch
- source = 030-m64p-remove-bundled-discord-and-vosk.patch
- source = 040-m64p-fix-qmake.patch
- source = 050-m64p-fix-paths.patch
- source = 060-m64p-add-pie.patch
+ source = 020-m64p-remove-bundled-discord-and-vosk.patch
+ source = 030-m64p-fix-paths.patch
+ source = 040-m64p-add-pie.patch
source = m64p.desktop
sha256sums = SKIP
- sha256sums = 038d8f811dd4632e87d4775f050dfaf0aea836c6ed4002b8ae1390b857e4e039
- sha256sums = 740b571b0cb26413c2f655c0063ad589569bb352a0ca8858c691ec81905157b5
+ sha256sums = 53fa6d4b5449e5c06a384a12a4a2b38af510269e466db2d53ec7eb7b49d78bd3
sha256sums = e9da860ae7adcdd0a1cc0155c232f81ca8399e9e855bd71fb51269edb708b1cc
- sha256sums = 4212cff6311f12ea2af5479a162a183d489dbb4107955c621a4440276a46cb76
sha256sums = a483f645b0a2036485e90c3aeef2e1aa61724e4fbd1cd9a1f807a5aea47c595e
sha256sums = a33a66612343035929eee5d6eb2acb342cc0c5a18a8e113aef83b28fb0f156c7
sha256sums = 8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808
diff --git a/010-m64p-remove-build-jobs-limitation.patch b/010-m64p-remove-build-jobs-limitation.patch
index b834cd73d797..4c3c1878513c 100644
--- a/010-m64p-remove-build-jobs-limitation.patch
+++ b/010-m64p-remove-build-jobs-limitation.patch
@@ -16,7 +16,7 @@
mkdir -p $base_dir/mupen64plus-input-qt/build
cd $base_dir/mupen64plus-input-qt/build
- qmake ../mupen64plus-input-qt.pro
+ qmake6 ../mupen64plus-input-qt.pro
-make -j4
+make
if [[ $UNAME == *"MINGW"* ]]; then
@@ -34,7 +34,7 @@
@@ -64,7 +64,7 @@ fi
mkdir -p $base_dir/mupen64plus-gui/build
cd $base_dir/mupen64plus-gui/build
- qmake ../mupen64plus-gui.pro
+ qmake6 ../mupen64plus-gui.pro
-make -j4
+make
if [[ $UNAME == *"MINGW"* ]]; then
diff --git a/020-m64p-change-optimizations.patch b/020-m64p-change-optimizations.patch
deleted file mode 100644
index de9ea1124820..000000000000
--- a/020-m64p-change-optimizations.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- a/build.sh
-+++ b/build.sh
-@@ -77,9 +77,9 @@ fi
- mkdir -p $base_dir/parallel-rsp/build
- cd $base_dir/parallel-rsp/build
- if [[ $UNAME == *"MINGW"* ]]; then
-- cmake -G "MSYS Makefiles" -DCMAKE_BUILD_TYPE=Release ..
-+ cmake -G "MSYS Makefiles" -DCMAKE_BUILD_TYPE=None ..
- else
-- cmake -DCMAKE_BUILD_TYPE=Release ..
-+ cmake -DCMAKE_BUILD_TYPE=None ..
- fi
- VERBOSE=1 cmake --build .
- cp mupen64plus-rsp-parallel.* $install_dir
-@@ -87,9 +87,9 @@ cp mupen64plus-rsp-parallel.* $install_dir
- mkdir -p $base_dir/parallel-rdp-standalone/build
- cd $base_dir/parallel-rdp-standalone/build
- if [[ $UNAME == *"MINGW"* ]]; then
-- cmake -G "MSYS Makefiles" -DCMAKE_BUILD_TYPE=Release ..
-+ cmake -G "MSYS Makefiles" -DCMAKE_BUILD_TYPE=None ..
- else
-- cmake -DCMAKE_BUILD_TYPE=Release ..
-+ cmake -DCMAKE_BUILD_TYPE=None ..
- fi
- VERBOSE=1 cmake --build .
- cp mupen64plus-video-parallel.* $install_dir
diff --git a/030-m64p-remove-bundled-discord-and-vosk.patch b/020-m64p-remove-bundled-discord-and-vosk.patch
index 4ac10d1f5b9c..4ac10d1f5b9c 100644
--- a/030-m64p-remove-bundled-discord-and-vosk.patch
+++ b/020-m64p-remove-bundled-discord-and-vosk.patch
diff --git a/050-m64p-fix-paths.patch b/030-m64p-fix-paths.patch
index f49aad1e20a9..f49aad1e20a9 100644
--- a/050-m64p-fix-paths.patch
+++ b/030-m64p-fix-paths.patch
diff --git a/060-m64p-add-pie.patch b/040-m64p-add-pie.patch
index 0e201c4271ed..0e201c4271ed 100644
--- a/060-m64p-add-pie.patch
+++ b/040-m64p-add-pie.patch
diff --git a/040-m64p-fix-qmake.patch b/040-m64p-fix-qmake.patch
deleted file mode 100644
index 05a0e36f51bc..000000000000
--- a/040-m64p-fix-qmake.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/build.sh
-+++ b/build.sh
-@@ -36,7 +36,7 @@ cp $base_dir/mupen64plus-input-raphnetraw/projects/unix/*$suffix $install_dir
-
- mkdir -p $base_dir/mupen64plus-input-qt/build
- cd $base_dir/mupen64plus-input-qt/build
--qmake ../mupen64plus-input-qt.pro
-+qmake6 ../mupen64plus-input-qt.pro
- make
- if [[ $UNAME == *"MINGW"* ]]; then
- cp $base_dir/mupen64plus-input-qt/build/release/mupen64plus-input-qt.dll $install_dir
-@@ -63,7 +63,7 @@ fi
-
- mkdir -p $base_dir/mupen64plus-gui/build
- cd $base_dir/mupen64plus-gui/build
--qmake ../mupen64plus-gui.pro
-+qmake6 ../mupen64plus-gui.pro
- make
- if [[ $UNAME == *"MINGW"* ]]; then
- cp $base_dir/mupen64plus-gui/build/release/mupen64plus-gui.exe $install_dir
diff --git a/PKGBUILD b/PKGBUILD
index 485bf4e2e2f7..f6ec0e06d69b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,30 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=m64p
-pkgver=20220722
+pkgver=20220808
pkgrel=1
-_tag=v2022.07.12
+_tag=v2022.08.6
pkgdesc='Mupen64Plus with custom plugins and Qt6 GUI'
arch=('x86_64')
url='https://m64p.github.io/'
license=('GPL3')
-depends=('freetype2' 'hidapi' 'libgl' 'libpng' 'libsamplerate' 'qt6-base'
- 'qt6-websockets' 'sdl2' 'sdl2_net' 'vulkan-icd-loader' 'zlib'
- 'discord-game-sdk' 'hicolor-icon-theme')
+depends=('discord-game-sdk' 'libpng' 'qt6-base' 'qt6-websockets' 'sdl2'
+ 'sdl2_net' 'vulkan-icd-loader' 'zlib' 'hicolor-icon-theme')
optdepends=('p7zip: for 7z/zip and VRU support'
'vosk-api: for VRU support (voice recognition unit)')
-makedepends=('git' 'cmake' 'nasm' 'python' 'zip' 'icoutils' 'vosk-api')
+makedepends=('git' 'cmake' 'zip' 'icoutils' 'vosk-api')
provides=('mupen64plus-gui')
conflicts=('mupen64plus-gui' 'mupen64plus')
#_tag="v$(sed -E 's/^([0-9]{4})([0-9]{2})([0-9])([0-9])/\1.\2.\4/' <<< "$pkgver")"
-source=("git+https://github.com/loganmc10/m64p.git#tag=${_tag}"
+source=("git+https://github.com/m64p/m64p.git#tag=${_tag}"
'010-m64p-remove-build-jobs-limitation.patch'
- '020-m64p-change-optimizations.patch'
- '030-m64p-remove-bundled-discord-and-vosk.patch'
- '040-m64p-fix-qmake.patch'
- '050-m64p-fix-paths.patch'
- '060-m64p-add-pie.patch'
+ '020-m64p-remove-bundled-discord-and-vosk.patch'
+ '030-m64p-fix-paths.patch'
+ '040-m64p-add-pie.patch'
'm64p.desktop')
sha256sums=('SKIP'
- '038d8f811dd4632e87d4775f050dfaf0aea836c6ed4002b8ae1390b857e4e039'
- '740b571b0cb26413c2f655c0063ad589569bb352a0ca8858c691ec81905157b5'
+ '53fa6d4b5449e5c06a384a12a4a2b38af510269e466db2d53ec7eb7b49d78bd3'
'e9da860ae7adcdd0a1cc0155c232f81ca8399e9e855bd71fb51269edb708b1cc'
- '4212cff6311f12ea2af5479a162a183d489dbb4107955c621a4440276a46cb76'
'a483f645b0a2036485e90c3aeef2e1aa61724e4fbd1cd9a1f807a5aea47c595e'
'a33a66612343035929eee5d6eb2acb342cc0c5a18a8e113aef83b28fb0f156c7'
'8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808')
@@ -37,11 +32,9 @@ sha256sums=('SKIP'
prepare() {
icotool -x m64p/mupen64plus-gui/mupen64plus.ico -o m64p/mupen64plus-gui
patch -d m64p -Np1 -i "${srcdir}/010-m64p-remove-build-jobs-limitation.patch"
- patch -d m64p -Np1 -i "${srcdir}/020-m64p-change-optimizations.patch"
- patch -d m64p -Np1 -i "${srcdir}/030-m64p-remove-bundled-discord-and-vosk.patch"
- patch -d m64p -Np1 -i "${srcdir}/040-m64p-fix-qmake.patch"
- patch -d m64p -Np1 -i "${srcdir}/050-m64p-fix-paths.patch"
- patch -d m64p -Np1 -i "${srcdir}/060-m64p-add-pie.patch"
+ patch -d m64p -Np1 -i "${srcdir}/020-m64p-remove-bundled-discord-and-vosk.patch"
+ patch -d m64p -Np1 -i "${srcdir}/030-m64p-fix-paths.patch"
+ patch -d m64p -Np1 -i "${srcdir}/040-m64p-add-pie.patch"
rm -rf m64p/mupen64plus-{gui/discord,input-qt/vosk}
}