summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-07-21 13:21:21 -0300
committerDaniel Bermond2022-07-21 13:21:21 -0300
commit0455d4bffb193fb90dc40507308064548814a925 (patch)
tree05328420ff19d160cfd89d21455c0edae3537cb4
parent5f48dbc6f9bc92f8481ab2c3f8c70e25f35df11e (diff)
downloadaur-0455d4bffb193fb90dc40507308064548814a925.tar.gz
Match latest upstream changes
-rw-r--r--.SRCINFO6
-rw-r--r--020-m64p-change-optimizations.patch9
-rw-r--r--050-m64p-fix-paths.patch12
-rw-r--r--PKGBUILD8
4 files changed, 13 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe855b579661..2fbe7a8d0cdb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = m64p-git
pkgdesc = Mupen64Plus with custom plugins and Qt6 GUI (git version)
- pkgver = 20220706.r0.g6d24363
+ pkgver = 20220720.r6.gcfcbd24
pkgrel = 1
url = https://m64p.github.io/
arch = x86_64
@@ -44,10 +44,10 @@ pkgbase = m64p-git
source = m64p.desktop
sha256sums = SKIP
sha256sums = 038d8f811dd4632e87d4775f050dfaf0aea836c6ed4002b8ae1390b857e4e039
- sha256sums = cc19027b19c0b516280e5e939115483ded9c7f03b1ff5f91e589e0d6bae9f735
+ sha256sums = 740b571b0cb26413c2f655c0063ad589569bb352a0ca8858c691ec81905157b5
sha256sums = e9da860ae7adcdd0a1cc0155c232f81ca8399e9e855bd71fb51269edb708b1cc
sha256sums = 4212cff6311f12ea2af5479a162a183d489dbb4107955c621a4440276a46cb76
- sha256sums = 9768f722425649d4125be53da1a9a5fe1206419fee751ba74d7a06fd04c7c57e
+ sha256sums = a483f645b0a2036485e90c3aeef2e1aa61724e4fbd1cd9a1f807a5aea47c595e
sha256sums = a33a66612343035929eee5d6eb2acb342cc0c5a18a8e113aef83b28fb0f156c7
sha256sums = 8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808
diff --git a/020-m64p-change-optimizations.patch b/020-m64p-change-optimizations.patch
index db1144bb77e4..de9ea1124820 100644
--- a/020-m64p-change-optimizations.patch
+++ b/020-m64p-change-optimizations.patch
@@ -1,14 +1,5 @@
--- a/build.sh
+++ b/build.sh
-@@ -26,7 +26,7 @@ base_dir=$PWD
- export OPTFLAGS="-O3 -flto -march=x86-64-v3"
-
- cd $base_dir/mupen64plus-core/projects/unix
--make NETPLAY=1 NO_ASM=1 OSD=0 V=1 all
-+make NETPLAY=1 OSD=0 V=1 all
- cp -P $base_dir/mupen64plus-core/projects/unix/*$suffix* $install_dir
- cp $base_dir/mupen64plus-core/data/* $install_dir
-
@@ -77,9 +77,9 @@ fi
mkdir -p $base_dir/parallel-rsp/build
cd $base_dir/parallel-rsp/build
diff --git a/050-m64p-fix-paths.patch b/050-m64p-fix-paths.patch
index 4e3bccb56cbc..f49aad1e20a9 100644
--- a/050-m64p-fix-paths.patch
+++ b/050-m64p-fix-paths.patch
@@ -1,6 +1,6 @@
--- a/mupen64plus-gui/mainwindow.cpp
+++ b/mupen64plus-gui/mainwindow.cpp
-@@ -4,6 +4,7 @@
+@@ -3,6 +3,7 @@
#include <QCloseEvent>
#include <QActionGroup>
#include <QDesktopServices>
@@ -8,7 +8,7 @@
#include "settingsdialog.h"
#include "plugindialog.h"
#include "mainwindow.h"
-@@ -46,7 +47,7 @@ void MainWindow::updatePlugins()
+@@ -45,7 +46,7 @@ void MainWindow::updatePlugins()
#ifdef PLUGIN_DIR_PATH
QString pluginPath = PLUGIN_DIR_PATH;
#else
@@ -17,7 +17,7 @@
#endif
QDir PluginDir(pluginPath);
PluginDir.setFilter(QDir::Files);
-@@ -372,7 +373,7 @@ MainWindow::MainWindow(QWidget *parent) :
+@@ -371,7 +372,7 @@ MainWindow::MainWindow(QWidget *parent) :
updatePIF(ui);
if (!settings->contains("configDirPath"))
@@ -26,7 +26,7 @@
#ifdef CONFIG_DIR_PATH
settings->setValue("configDirPath", CONFIG_DIR_PATH);
-@@ -432,7 +433,7 @@ void MainWindow::updateApp()
+@@ -433,7 +434,7 @@ void MainWindow::updateApp()
void MainWindow::setupDiscord()
{
@@ -35,7 +35,7 @@
memset(&discord_app, 0, sizeof(discord_app));
-@@ -951,7 +952,7 @@ void MainWindow::loadCoreLib()
+@@ -960,7 +961,7 @@ void MainWindow::loadCoreLib()
#ifdef CORE_LIBRARY_PATH
QString corePath = CORE_LIBRARY_PATH;
#else
@@ -44,7 +44,7 @@
#endif
m64p_error res = osal_dynlib_open(&coreLib, QDir(corePath).filePath(OSAL_DEFAULT_DYNLIB_FILENAME).toUtf8().constData());
-@@ -1043,7 +1044,7 @@ void MainWindow::loadPlugins()
+@@ -1053,7 +1054,7 @@ void MainWindow::loadPlugins()
#ifdef PLUGIN_DIR_PATH
QString pluginPath = PLUGIN_DIR_PATH;
#else
diff --git a/PKGBUILD b/PKGBUILD
index 21365877f4a8..45ff3b184fd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=m64p-git
-pkgver=20220706.r0.g6d24363
+pkgver=20220720.r6.gcfcbd24
pkgrel=1
pkgdesc='Mupen64Plus with custom plugins and Qt6 GUI (git version)'
arch=('x86_64')
@@ -25,10 +25,10 @@ source=('git+https://github.com/loganmc10/m64p.git'
'm64p.desktop')
sha256sums=('SKIP'
'038d8f811dd4632e87d4775f050dfaf0aea836c6ed4002b8ae1390b857e4e039'
- 'cc19027b19c0b516280e5e939115483ded9c7f03b1ff5f91e589e0d6bae9f735'
+ '740b571b0cb26413c2f655c0063ad589569bb352a0ca8858c691ec81905157b5'
'e9da860ae7adcdd0a1cc0155c232f81ca8399e9e855bd71fb51269edb708b1cc'
'4212cff6311f12ea2af5479a162a183d489dbb4107955c621a4440276a46cb76'
- '9768f722425649d4125be53da1a9a5fe1206419fee751ba74d7a06fd04c7c57e'
+ 'a483f645b0a2036485e90c3aeef2e1aa61724e4fbd1cd9a1f807a5aea47c595e'
'a33a66612343035929eee5d6eb2acb342cc0c5a18a8e113aef83b28fb0f156c7'
'8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808')
@@ -73,7 +73,7 @@ package() {
local _sover
for _component in core audio-sdl2 input-raphnetraw
do
- make -C "m64p/mupen64plus-${_component}/projects/unix" DESTDIR="$pkgdir" PREFIX='/usr' LDCONFIG='true' NEW_DYNAREC='0' NETPLAY='1' OSD='0' install
+ make -C "m64p/mupen64plus-${_component}/projects/unix" DESTDIR="$pkgdir" PREFIX='/usr' LDCONFIG='true' NO_ASM='1' NETPLAY='1' OSD='0' install
done
_sover="$(find "${pkgdir}/usr/lib" -type f -name 'libmupen64plus.so.*.*.*' | sed 's/^.*\.so\.//')"
ln -s "libmupen64plus.so.${_sover}" "${pkgdir}/usr/lib/libmupen64plus.so"