summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-05-29 13:12:57 +0000
committerDaniel Bermond2020-05-29 13:12:57 +0000
commit354993660a29826e4b62776a896c9563d5cd9da0 (patch)
tree1d864b2a0649efeced81a2346348058cbe757fde
parentd328fe7503ef35c492937ed1f4684a6faed50a84 (diff)
downloadaur-354993660a29826e4b62776a896c9563d5cd9da0.tar.gz
Improve icons installation
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD19
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef3eb85d62e3..41d08eaf315f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = m64p-git
pkgdesc = Mupen64Plus with custom plugins and Qt5 GUI (git version)
- pkgver = r139.gb5cbdf8
+ pkgver = r140.g19fd445
pkgrel = 1
url = https://m64p.github.io/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 03c31035e9a7..5c0e9b19e3a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=m64p-git
-pkgver=r139.gb5cbdf8
+pkgver=r140.g19fd445
pkgrel=1
pkgdesc='Mupen64Plus with custom plugins and Qt5 GUI (git version)'
arch=('x86_64')
@@ -46,6 +46,7 @@ prepare() {
git -C m64p config --local submodule.mupen64plus-input-qt.url "${srcdir}/mupen64plus-input-qt"
git -C m64p config --local submodule.mupen64plus-input-raphnetraw.url "${srcdir}/mupen64plus-input-raphnetraw-loganmc10"
git -C m64p submodule update
+ icotool -x mupen64plus-gui/mupen64plus.ico
patch -d m64p -Np1 -i "${srcdir}/010-m64p-git-remove-build-jobs-limitation.patch"
patch -d m64p -Np1 -i "${srcdir}/020-m64p-git-enable-optimizations.patch"
}
@@ -61,29 +62,23 @@ build() {
package() {
# mupen64plus-gui
- install -D -m755 m64p/mupen64plus/mupen64plus-gui -t "${pkgdir}/usr/bin"
- install -D -m644 m64p.desktop -t "${pkgdir}/usr/share/applications"
- icotool -x mupen64plus-gui/mupen64plus.ico
- local _count='1'
- local _depth
local _file
local _res
+ install -D -m755 m64p/mupen64plus/mupen64plus-gui -t "${pkgdir}/usr/bin"
+ install -D -m644 m64p.desktop -t "${pkgdir}/usr/share/applications"
while read -r -d '' _file
do
- _depth="$(printf '%s' "$_file" | sed 's/\.png$//;s/^.*x//' )"
_res="$(printf '%s' "$_file" | sed 's/\.png$//;s/^.*_//;s/x.*$//')"
- install -D -m644 "mupen64plus_${_count}_${_res}x${_res}x${_depth}.png" \
- "${pkgdir}/usr/share/icons/hicolor/${_res}x${_res}/apps/mupen64plus.png"
- _count="$((_count + 1))"
- done < <(find -maxdepth 1 -type f -name 'mupen64plus_*_*x*x*.png' -print0 | sort -z)
+ install -D -m644 "$_file" "${pkgdir}/usr/share/icons/hicolor/${_res}x${_res}/apps/mupen64plus.png"
+ done < <(find -maxdepth 1 -type f -name 'mupen64plus_*_*x*x*.png' -print0)
# mupen64plus components
local _component
+ local _sover
for _component in core audio-sdl2 input-raphnetraw rsp-hle
do
make -C "m64p/mupen64plus-${_component}/projects/unix" DESTDIR="$pkgdir" PREFIX='/usr' LDCONFIG='true' install
done
- local _sover
_sover="$(find "${pkgdir}/usr/lib" -type f -name 'libmupen64plus.so.*.*.*' | sed 's/^.*\.so\.//')"
ln -s "libmupen64plus.so.${_sover}" "${pkgdir}/usr/lib/libmupen64plus.so"