summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-04-03 20:49:56 -0300
committerDaniel Bermond2022-04-03 20:49:56 -0300
commit498e4e078b83a7dc2a04f83559fadaeb7a815f06 (patch)
treec3c37f0551f7c6a18e7d5c0d2bb3e0139f453bd8
parenta8285d76d089407c2d858404ff5747329dba2b0d (diff)
downloadaur-498e4e078b83a7dc2a04f83559fadaeb7a815f06.tar.gz
Match latest upstream changes
-rw-r--r--.SRCINFO6
-rw-r--r--010-m64p-remove-build-jobs-limitation.patch10
-rw-r--r--020-m64p-change-optimizations.patch20
-rw-r--r--PKGBUILD6
4 files changed, 29 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 605dd4385ac8..8bb9c6bd05c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = m64p-git
pkgdesc = Mupen64Plus with custom plugins and Qt5 GUI (git version)
- pkgver = 20220314.r1.gfeb3995
+ pkgver = 20220403.r1.g9d6e4b1
pkgrel = 1
url = https://m64p.github.io/
arch = x86_64
@@ -39,8 +39,8 @@ pkgbase = m64p-git
source = 040-m64p-add-pie.patch
source = m64p.desktop
sha256sums = SKIP
- sha256sums = b8882d2b3cce965bd03b100fc53419ff43d8934c364136bbe63473fca0692fec
- sha256sums = bd2964654f5c346af76a5408adc76d34bf490435c4400cfa1d2340f0ad598dcd
+ sha256sums = f6ae0125845fd8fc70efeae83fc54d6d4c0787f8215d274c84f259564ec36211
+ sha256sums = 464c58311f26e8ec23ed418c2b2d331743552b87e156bc7cd284add8debbd0d1
sha256sums = b8cd918c56b1435c448067e4202c36e5c3cf3fb0ff43ac4cdc590719677b5da5
sha256sums = 5c604da87c9deb3582b43efa724589080a7070a108ab0c0d00e115cb35eb4b13
sha256sums = 8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808
diff --git a/010-m64p-remove-build-jobs-limitation.patch b/010-m64p-remove-build-jobs-limitation.patch
index 3ed70dc3e0dd..8ab8893ad438 100644
--- a/010-m64p-remove-build-jobs-limitation.patch
+++ b/010-m64p-remove-build-jobs-limitation.patch
@@ -1,11 +1,11 @@
--- a/build.sh
+++ b/build.sh
-@@ -26,18 +26,18 @@ mkdir -p $install_dir
+@@ -24,18 +24,18 @@ mkdir -p $install_dir
base_dir=$PWD
cd $base_dir/mupen64plus-core/projects/unix
--make NETPLAY=1 OSD=0 -j4 all
-+make NETPLAY=1 OSD=0 all
+-make NETPLAY=1 NO_ASM=1 OSD=0 -j4 all
++make NETPLAY=1 NO_ASM=1 OSD=0 all
cp -P $base_dir/mupen64plus-core/projects/unix/*$suffix* $install_dir
cp $base_dir/mupen64plus-core/data/* $install_dir
@@ -22,7 +22,7 @@
if [[ $UNAME == *"MINGW"* ]]; then
cp $base_dir/mupen64plus-input-qt/build/release/mupen64plus-input-qt.dll $install_dir
else
-@@ -45,7 +45,7 @@ else
+@@ -43,7 +43,7 @@ else
fi
cd $base_dir/mupen64plus-audio-sdl2/projects/unix
@@ -31,7 +31,7 @@
cp $base_dir/mupen64plus-audio-sdl2/projects/unix/*$suffix $install_dir
cd $base_dir
-@@ -64,7 +64,7 @@ fi
+@@ -62,7 +62,7 @@ fi
mkdir -p $base_dir/mupen64plus-gui/build
cd $base_dir/mupen64plus-gui/build
qmake ../mupen64plus-gui.pro
diff --git a/020-m64p-change-optimizations.patch b/020-m64p-change-optimizations.patch
index c383e3a2214f..9ed2e60e3697 100644
--- a/020-m64p-change-optimizations.patch
+++ b/020-m64p-change-optimizations.patch
@@ -1,6 +1,22 @@
--- a/build.sh
+++ b/build.sh
-@@ -77,9 +77,9 @@ fi
+@@ -19,12 +19,14 @@ else
+ suffix=".so"
+ fi
+
++export NEW_DYNAREC=1
++
+ install_dir=$PWD/mupen64plus
+ mkdir -p $install_dir
+ base_dir=$PWD
+
+ cd $base_dir/mupen64plus-core/projects/unix
+-make NETPLAY=1 NO_ASM=1 OSD=0 all
++make NETPLAY=1 OSD=0 all
+ cp -P $base_dir/mupen64plus-core/projects/unix/*$suffix* $install_dir
+ cp $base_dir/mupen64plus-core/data/* $install_dir
+
+@@ -75,9 +77,9 @@ fi
mkdir -p $base_dir/parallel-rsp/build
cd $base_dir/parallel-rsp/build
if [[ $UNAME == *"MINGW"* ]]; then
@@ -12,7 +28,7 @@
fi
cmake --build .
cp mupen64plus-rsp-parallel.* $install_dir
-@@ -87,9 +87,9 @@ cp mupen64plus-rsp-parallel.* $install_dir
+@@ -85,9 +87,9 @@ cp mupen64plus-rsp-parallel.* $install_dir
mkdir -p $base_dir/parallel-rdp-standalone/build
cd $base_dir/parallel-rdp-standalone/build
if [[ $UNAME == *"MINGW"* ]]; then
diff --git a/PKGBUILD b/PKGBUILD
index fe53bf22814c..1a3dc70e5181 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=m64p-git
-pkgver=20220314.r1.gfeb3995
+pkgver=20220403.r1.g9d6e4b1
pkgrel=1
pkgdesc='Mupen64Plus with custom plugins and Qt5 GUI (git version)'
arch=('x86_64')
@@ -21,8 +21,8 @@ source=('git+https://github.com/loganmc10/m64p.git'
'040-m64p-add-pie.patch'
'm64p.desktop')
sha256sums=('SKIP'
- 'b8882d2b3cce965bd03b100fc53419ff43d8934c364136bbe63473fca0692fec'
- 'bd2964654f5c346af76a5408adc76d34bf490435c4400cfa1d2340f0ad598dcd'
+ 'f6ae0125845fd8fc70efeae83fc54d6d4c0787f8215d274c84f259564ec36211'
+ '464c58311f26e8ec23ed418c2b2d331743552b87e156bc7cd284add8debbd0d1'
'b8cd918c56b1435c448067e4202c36e5c3cf3fb0ff43ac4cdc590719677b5da5'
'5c604da87c9deb3582b43efa724589080a7070a108ab0c0d00e115cb35eb4b13'
'8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808')