summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-07-05 16:03:08 -0300
committerDaniel Bermond2022-07-05 16:03:08 -0300
commit4db3a627189fe9fd2988025cfbdc043b45983b3b (patch)
tree8ecd40c19341a3dd40dd50900c4f3d8217f8bb02
parent731fd26e9b99efd11527013e9b64bb3ebcbc883d (diff)
downloadaur-4db3a627189fe9fd2988025cfbdc043b45983b3b.tar.gz
Match latest upstream changes
-rw-r--r--.SRCINFO18
-rw-r--r--030-m64p-remove-bundled-discord-and-vosk.patch4
-rw-r--r--040-m64p-fix-qmake.patch20
-rw-r--r--050-m64p-fix-paths.patch (renamed from 040-m64p-fix-paths.patch)18
-rw-r--r--060-m64p-add-pie.patch (renamed from 050-m64p-add-pie.patch)2
-rw-r--r--PKGBUILD25
6 files changed, 57 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72fbad2c4e1b..71303ab33c95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = m64p-git
pkgdesc = Mupen64Plus with custom plugins and Qt5 GUI (git version)
- pkgver = 20220630.r4.gbb8f6e6
+ pkgver = 20220704.r6.gd338364
pkgrel = 1
url = https://m64p.github.io/
arch = x86_64
@@ -17,8 +17,8 @@ pkgbase = m64p-git
depends = libgl
depends = libpng
depends = libsamplerate
- depends = qt5-base
- depends = qt5-websockets
+ depends = qt6-base
+ depends = qt6-websockets
depends = sdl2
depends = sdl2_net
depends = vulkan-icd-loader
@@ -38,15 +38,17 @@ pkgbase = m64p-git
source = 010-m64p-remove-build-jobs-limitation.patch
source = 020-m64p-change-optimizations.patch
source = 030-m64p-remove-bundled-discord-and-vosk.patch
- source = 040-m64p-fix-paths.patch
- source = 050-m64p-add-pie.patch
+ source = 040-m64p-fix-qmake.patch
+ source = 050-m64p-fix-paths.patch
+ source = 060-m64p-add-pie.patch
source = m64p.desktop
sha256sums = SKIP
sha256sums = 038d8f811dd4632e87d4775f050dfaf0aea836c6ed4002b8ae1390b857e4e039
sha256sums = cc19027b19c0b516280e5e939115483ded9c7f03b1ff5f91e589e0d6bae9f735
- sha256sums = b6fd822625dea4209d996a345a17e637c7a08e622ada99f87861bb5b5996061d
- sha256sums = 11f7a3caa150a716a12ab0d70a98089d7502d7a716f41e9bc419469fe4e1957a
- sha256sums = bfc34f267e0ee0f4ce2f65aaf5433060c6d542afbb54e24511187a95cf6f1f73
+ sha256sums = e9da860ae7adcdd0a1cc0155c232f81ca8399e9e855bd71fb51269edb708b1cc
+ sha256sums = 4212cff6311f12ea2af5479a162a183d489dbb4107955c621a4440276a46cb76
+ sha256sums = 1a03b73ff9b447c717d59115a33e63ad49c0256eb9992ef541b4a3c5e31765c5
+ sha256sums = a33a66612343035929eee5d6eb2acb342cc0c5a18a8e113aef83b28fb0f156c7
sha256sums = 8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808
pkgname = m64p-git
diff --git a/030-m64p-remove-bundled-discord-and-vosk.patch b/030-m64p-remove-bundled-discord-and-vosk.patch
index 762daa3e9d32..4ac10d1f5b9c 100644
--- a/030-m64p-remove-bundled-discord-and-vosk.patch
+++ b/030-m64p-remove-bundled-discord-and-vosk.patch
@@ -1,6 +1,6 @@
--- a/build.sh
+++ b/build.sh
-@@ -159,8 +159,6 @@ else
+@@ -144,8 +144,6 @@ else
else
my_os=linux64
fi
@@ -11,7 +11,7 @@
if [[ "$1" != "nozip" ]]; then
--- a/mupen64plus-gui/mupen64plus-gui.pro
+++ b/mupen64plus-gui/mupen64plus-gui.pro
-@@ -98,8 +98,7 @@ HEADERS += mainwindow.h \
+@@ -90,8 +90,7 @@ HEADERS += mainwindow.h \
netplay/createroom.h \
netplay/joinroom.h \
netplay/waitroom.h \
diff --git a/040-m64p-fix-qmake.patch b/040-m64p-fix-qmake.patch
new file mode 100644
index 000000000000..05a0e36f51bc
--- /dev/null
+++ b/040-m64p-fix-qmake.patch
@@ -0,0 +1,20 @@
+--- a/build.sh
++++ b/build.sh
+@@ -36,7 +36,7 @@ cp $base_dir/mupen64plus-input-raphnetraw/projects/unix/*$suffix $install_dir
+
+ mkdir -p $base_dir/mupen64plus-input-qt/build
+ cd $base_dir/mupen64plus-input-qt/build
+-qmake ../mupen64plus-input-qt.pro
++qmake6 ../mupen64plus-input-qt.pro
+ make
+ if [[ $UNAME == *"MINGW"* ]]; then
+ cp $base_dir/mupen64plus-input-qt/build/release/mupen64plus-input-qt.dll $install_dir
+@@ -63,7 +63,7 @@ fi
+
+ mkdir -p $base_dir/mupen64plus-gui/build
+ cd $base_dir/mupen64plus-gui/build
+-qmake ../mupen64plus-gui.pro
++qmake6 ../mupen64plus-gui.pro
+ make
+ if [[ $UNAME == *"MINGW"* ]]; then
+ cp $base_dir/mupen64plus-gui/build/release/mupen64plus-gui.exe $install_dir
diff --git a/040-m64p-fix-paths.patch b/050-m64p-fix-paths.patch
index e521a6076815..225be809741a 100644
--- a/040-m64p-fix-paths.patch
+++ b/050-m64p-fix-paths.patch
@@ -8,7 +8,7 @@
#include "settingsdialog.h"
#include "plugindialog.h"
#include "mainwindow.h"
-@@ -44,7 +45,7 @@ void MainWindow::updatePlugins()
+@@ -46,7 +47,7 @@ void MainWindow::updatePlugins()
#ifdef PLUGIN_DIR_PATH
QString pluginPath = PLUGIN_DIR_PATH;
#else
@@ -17,7 +17,7 @@
#endif
QDir PluginDir(pluginPath);
PluginDir.setFilter(QDir::Files);
-@@ -374,7 +375,7 @@ MainWindow::MainWindow(QWidget *parent) :
+@@ -375,7 +376,7 @@ MainWindow::MainWindow(QWidget *parent) :
updatePIF(ui);
if (!settings->contains("configDirPath"))
@@ -26,7 +26,7 @@
#ifdef CONFIG_DIR_PATH
settings->setValue("configDirPath", CONFIG_DIR_PATH);
-@@ -434,7 +435,7 @@ void MainWindow::updateApp()
+@@ -435,7 +436,7 @@ void MainWindow::updateApp()
void MainWindow::setupDiscord()
{
@@ -35,7 +35,7 @@
memset(&discord_app, 0, sizeof(discord_app));
-@@ -1019,7 +1020,7 @@ void MainWindow::loadCoreLib()
+@@ -954,7 +955,7 @@ void MainWindow::loadCoreLib()
#ifdef CORE_LIBRARY_PATH
QString corePath = CORE_LIBRARY_PATH;
#else
@@ -44,7 +44,7 @@
#endif
m64p_error res = osal_dynlib_open(&coreLib, QDir(corePath).filePath(OSAL_DEFAULT_DYNLIB_FILENAME).toUtf8().constData());
-@@ -1109,7 +1110,7 @@ void MainWindow::loadPlugins()
+@@ -1046,7 +1047,7 @@ void MainWindow::loadPlugins()
#ifdef PLUGIN_DIR_PATH
QString pluginPath = PLUGIN_DIR_PATH;
#else
@@ -61,7 +61,7 @@
-#include "discord/discord_game_sdk.h"
+#include <discord_game_sdk.h>
- #include "oglwindow.h"
+ #include "vkwindow.h"
#include "workerthread.h"
#include "logviewer.h"
--- a/mupen64plus-gui/settingsdialog.cpp
@@ -79,13 +79,13 @@
+++ b/mupen64plus-gui/workerthread.h
@@ -6,7 +6,7 @@
#include <QString>
- #include <QSurfaceFormat>
+ #include <QVulkanInstance>
#include "common.h"
-#include "discord/discord_game_sdk.h"
+#include <discord_game_sdk.h>
class WorkerThread
- #ifndef SINGLE_THREAD
+ : public QThread
--- a/mupen64plus-input-qt/main.cpp
+++ b/mupen64plus-input-qt/main.cpp
@@ -27,7 +27,7 @@
@@ -97,7 +97,7 @@
#include "osal/osal_dynamiclib.h"
#include "vruwords.h"
#include "funcs.h"
-@@ -731,7 +731,7 @@ static int setupVosk()
+@@ -726,7 +726,7 @@ static int setupVosk()
{
if (voskLib)
return 0;
diff --git a/050-m64p-add-pie.patch b/060-m64p-add-pie.patch
index 77797c41fb90..0e201c4271ed 100644
--- a/050-m64p-add-pie.patch
+++ b/060-m64p-add-pie.patch
@@ -1,6 +1,6 @@
--- a/mupen64plus-gui/mupen64plus-gui.pro
+++ b/mupen64plus-gui/mupen64plus-gui.pro
-@@ -104,7 +104,6 @@ FORMS += mainwindow.ui
+@@ -96,7 +96,6 @@ FORMS += mainwindow.ui
QMAKE_INCDIR += api interface
diff --git a/PKGBUILD b/PKGBUILD
index e9bbcbcc005c..d48a906f56e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=m64p-git
-pkgver=20220630.r4.gbb8f6e6
+pkgver=20220704.r6.gd338364
pkgrel=1
pkgdesc='Mupen64Plus with custom plugins and Qt5 GUI (git version)'
arch=('x86_64')
url='https://m64p.github.io/'
license=('GPL3')
-depends=('freetype2' 'hidapi' 'libgl' 'libpng' 'libsamplerate' 'qt5-base'
- 'qt5-websockets' 'sdl2' 'sdl2_net' 'vulkan-icd-loader' 'zlib'
+depends=('freetype2' 'hidapi' 'libgl' 'libpng' 'libsamplerate' 'qt6-base'
+ 'qt6-websockets' 'sdl2' 'sdl2_net' 'vulkan-icd-loader' 'zlib'
'discord-game-sdk' 'hicolor-icon-theme')
optdepends=('p7zip: for 7z/zip and VRU support'
'vosk-api: for VRU support (voice recognition unit)')
@@ -19,15 +19,17 @@ source=('git+https://github.com/loganmc10/m64p.git'
'010-m64p-remove-build-jobs-limitation.patch'
'020-m64p-change-optimizations.patch'
'030-m64p-remove-bundled-discord-and-vosk.patch'
- '040-m64p-fix-paths.patch'
- '050-m64p-add-pie.patch'
+ '040-m64p-fix-qmake.patch'
+ '050-m64p-fix-paths.patch'
+ '060-m64p-add-pie.patch'
'm64p.desktop')
sha256sums=('SKIP'
'038d8f811dd4632e87d4775f050dfaf0aea836c6ed4002b8ae1390b857e4e039'
'cc19027b19c0b516280e5e939115483ded9c7f03b1ff5f91e589e0d6bae9f735'
- 'b6fd822625dea4209d996a345a17e637c7a08e622ada99f87861bb5b5996061d'
- '11f7a3caa150a716a12ab0d70a98089d7502d7a716f41e9bc419469fe4e1957a'
- 'bfc34f267e0ee0f4ce2f65aaf5433060c6d542afbb54e24511187a95cf6f1f73'
+ 'e9da860ae7adcdd0a1cc0155c232f81ca8399e9e855bd71fb51269edb708b1cc'
+ '4212cff6311f12ea2af5479a162a183d489dbb4107955c621a4440276a46cb76'
+ '1a03b73ff9b447c717d59115a33e63ad49c0256eb9992ef541b4a3c5e31765c5'
+ 'a33a66612343035929eee5d6eb2acb342cc0c5a18a8e113aef83b28fb0f156c7'
'8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808')
prepare() {
@@ -35,8 +37,9 @@ prepare() {
patch -d m64p -Np1 -i "${srcdir}/010-m64p-remove-build-jobs-limitation.patch"
patch -d m64p -Np1 -i "${srcdir}/020-m64p-change-optimizations.patch"
patch -d m64p -Np1 -i "${srcdir}/030-m64p-remove-bundled-discord-and-vosk.patch"
- patch -d m64p -Np1 -i "${srcdir}/040-m64p-fix-paths.patch"
- patch -d m64p -Np1 -i "${srcdir}/050-m64p-add-pie.patch"
+ patch -d m64p -Np1 -i "${srcdir}/040-m64p-fix-qmake.patch"
+ patch -d m64p -Np1 -i "${srcdir}/050-m64p-fix-paths.patch"
+ patch -d m64p -Np1 -i "${srcdir}/060-m64p-add-pie.patch"
rm -rf m64p/mupen64plus-{gui/discord,input-qt/vosk}
}
@@ -49,6 +52,8 @@ pkgver() {
}
build() {
+ export CFLAGS+=' -Wno-unused-function -Wno-unused-variable'
+
cd m64p
./build.sh
}