summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-04-11 17:17:24 +0000
committerDaniel Bermond2020-04-11 17:17:24 +0000
commit5675d5a3f8b49dbda223b1703d1ad9735d13137b (patch)
tree672303181deb8df5ee10c0003721aaa35d87af7f
parent3a06b9171e12d6f8fa0a0a3dbcf88d1066609213 (diff)
downloadaur-5675d5a3f8b49dbda223b1703d1ad9735d13137b.tar.gz
Various changes
- speed up the build process by removing the build jobs limitation - enable assembly optimizations on mupen64plus components - enable HQ textures on GLideN64 - add mupen64plus include files for the core library - change url - update provides/conflicts
-rw-r--r--.SRCINFO11
-rw-r--r--001-m64p-git-remove-build-jobs-limitation.patch64
-rw-r--r--002-m64p-git-enable-optimizations.patch24
-rw-r--r--PKGBUILD47
4 files changed, 120 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4fefeb873c4..547c5f9e805c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = m64p-git
pkgdesc = Mupen64Plus with custom plugins and Qt5 GUI (git version)
- pkgver = r92.g2de5fe3
+ pkgver = r94.g8d7153e
pkgrel = 1
- url = https://github.com/m64p/mupen64plus-gui/
+ url = https://m64p.github.io/
arch = x86_64
license = GPL3
makedepends = git
makedepends = cmake
+ makedepends = nasm
depends = freetype2
depends = glu
depends = hidapi
@@ -17,9 +18,11 @@ pkgbase = m64p-git
depends = qt5-base
depends = sdl2
depends = zlib
+ provides = m64p
provides = mupen64plus
provides = mupen64plus-gui
provides = mupenplus-video-gliden64
+ conflicts = m64p
conflicts = mupen64plus
conflicts = mupen64plus-gui
conflicts = mupenplus-video-gliden64
@@ -31,6 +34,8 @@ pkgbase = m64p-git
source = GLideN64-loganmc10::git+https://github.com/loganmc10/GLideN64.git
source = mupen64plus-core-loganmc10::git+https://github.com/loganmc10/mupen64plus-core.git
source = mupen64plus-input-raphnetraw-loganmc10::git+https://github.com/loganmc10/mupen64plus-input-raphnetraw.git
+ source = 001-m64p-git-remove-build-jobs-limitation.patch
+ source = 002-m64p-git-enable-optimizations.patch
source = m64p.desktop
sha256sums = SKIP
sha256sums = SKIP
@@ -40,6 +45,8 @@ pkgbase = m64p-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = c7b80c7be0e07e44b260e1ce89e31628d64ddee622ea842b85f6eb0aeff4168a
+ sha256sums = b27e808d97b37bd1a98c9c8482a938f5da6b19c26c58db792f0e79b27a7d84c7
sha256sums = b884fc86180346226eb7e8bf8560d2b789318e810c9e26b6adbe7d8d047188df
pkgname = m64p-git
diff --git a/001-m64p-git-remove-build-jobs-limitation.patch b/001-m64p-git-remove-build-jobs-limitation.patch
new file mode 100644
index 000000000000..9c805f7d8c6a
--- /dev/null
+++ b/001-m64p-git-remove-build-jobs-limitation.patch
@@ -0,0 +1,64 @@
+diff -Naurp a/build.sh b/build.sh
+--- a/build.sh 2020-04-11 12:39:46.000000000 +0000
++++ b/build.sh 2020-04-11 12:40:10.817528173 +0000
+@@ -21,22 +21,22 @@ mkdir -p $install_dir
+ base_dir=$PWD
+
+ cd $base_dir/mupen64plus-core/projects/unix
+-make -j4 all
++make all
+ cp -P $base_dir/mupen64plus-core/projects/unix/*$suffix* $install_dir
+ cp $base_dir/mupen64plus-core/data/* $install_dir
+
+ cd $base_dir/mupen64plus-rsp-hle/projects/unix
+-make -j4 all
++make all
+ cp $base_dir/mupen64plus-rsp-hle/projects/unix/*$suffix $install_dir
+
+ cd $base_dir/mupen64plus-input-raphnetraw/projects/unix
+-make -j4 all
++make all
+ cp $base_dir/mupen64plus-input-raphnetraw/projects/unix/*$suffix $install_dir
+
+ mkdir -p $base_dir/mupen64plus-input-qt/build
+ cd $base_dir/mupen64plus-input-qt/build
+ qmake ../mupen64plus-input-qt.pro
+-make -j4
++make
+ if [[ $UNAME == *"MINGW"* ]]; then
+ cp $base_dir/mupen64plus-input-qt/build/release/mupen64plus-input-qt.dll $install_dir
+ else
+@@ -44,13 +44,13 @@ else
+ fi
+
+ cd $base_dir/mupen64plus-audio-sdl2/projects/unix
+-make -j4 all
++make all
+ cp $base_dir/mupen64plus-audio-sdl2/projects/unix/*$suffix $install_dir
+
+ mkdir -p $base_dir/mupen64plus-gui/build
+ cd $base_dir/mupen64plus-gui/build
+ qmake ../mupen64plus-gui.pro
+-make -j4
++make
+ if [[ $UNAME == *"MINGW"* ]]; then
+ cp $base_dir/mupen64plus-gui/build/release/mupen64plus-gui.exe $install_dir
+ else
+@@ -64,7 +64,7 @@ cd $base_dir/GLideN64/src/GLideNUI
+ mkdir -p build
+ cd build
+ qmake ../GLideNUI.pro
+-make -j4
++make
+
+ cd $base_dir/GLideN64/projects/cmake
+ if [[ $UNAME == *"MINGW"* ]]; then
+@@ -72,7 +72,7 @@ if [[ $UNAME == *"MINGW"* ]]; then
+ else
+ cmake -DNOHQ=On -DVEC4_OPT=On -DCRC_OPT=On -DMUPENPLUSAPI=On ../../src/
+ fi
+-make -j4
++make
+
+ if [[ $UNAME == *"MINGW"* ]]; then
+ cp mupen64plus-video-GLideN64$suffix $install_dir
diff --git a/002-m64p-git-enable-optimizations.patch b/002-m64p-git-enable-optimizations.patch
new file mode 100644
index 000000000000..8a90140fd836
--- /dev/null
+++ b/002-m64p-git-enable-optimizations.patch
@@ -0,0 +1,24 @@
+diff -Naurp a/build.sh b/build.sh
+--- a/build.sh 2020-04-11 12:40:10.000000000 +0000
++++ b/build.sh 2020-04-11 12:40:51.273637405 +0000
+@@ -14,8 +14,6 @@ else
+ suffix=".so"
+ fi
+
+-export NO_ASM=1
+-
+ install_dir=$PWD/mupen64plus
+ mkdir -p $install_dir
+ base_dir=$PWD
+@@ -68,9 +66,9 @@ make
+
+ cd $base_dir/GLideN64/projects/cmake
+ if [[ $UNAME == *"MINGW"* ]]; then
+- cmake -G "MSYS Makefiles" -DNOHQ=On -DVEC4_OPT=On -DCRC_OPT=On -DMUPENPLUSAPI=On ../../src/
++ cmake -G "MSYS Makefiles" -DMUPENPLUSAPI=On ../../src/
+ else
+- cmake -DNOHQ=On -DVEC4_OPT=On -DCRC_OPT=On -DMUPENPLUSAPI=On ../../src/
++ cmake -DMUPENPLUSAPI=On ../../src/
+ fi
+ make
+
diff --git a/PKGBUILD b/PKGBUILD
index 25f6f40556d2..93a2cda855c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=m64p-git
-pkgver=r92.g2de5fe3
+pkgver=r94.g8d7153e
pkgrel=1
pkgdesc='Mupen64Plus with custom plugins and Qt5 GUI (git version)'
arch=('x86_64')
-url='https://github.com/m64p/mupen64plus-gui/'
+url='https://m64p.github.io/'
license=('GPL3')
depends=('freetype2' 'glu' 'hidapi' 'libpng' 'libsamplerate' 'minizip'
'p7zip' 'qt5-base' 'sdl2' 'zlib')
-makedepends=('git' 'cmake')
-provides=('mupen64plus' 'mupen64plus-gui' 'mupenplus-video-gliden64')
-conflicts=('mupen64plus' 'mupen64plus-gui' 'mupenplus-video-gliden64')
+makedepends=('git' 'cmake' 'nasm')
+provides=('m64p' 'mupen64plus' 'mupen64plus-gui' 'mupenplus-video-gliden64')
+conflicts=('m64p' 'mupen64plus' 'mupen64plus-gui' 'mupenplus-video-gliden64')
source=('git+https://github.com/loganmc10/m64p.git'
'git+https://github.com/m64p/mupen64plus-gui.git'
'git+https://github.com/m64p/mupen64plus-audio-sdl2.git'
@@ -20,6 +20,8 @@ source=('git+https://github.com/loganmc10/m64p.git'
'GLideN64-loganmc10'::'git+https://github.com/loganmc10/GLideN64.git'
'mupen64plus-core-loganmc10'::'git+https://github.com/loganmc10/mupen64plus-core.git'
'mupen64plus-input-raphnetraw-loganmc10'::'git+https://github.com/loganmc10/mupen64plus-input-raphnetraw.git'
+ '001-m64p-git-remove-build-jobs-limitation.patch'
+ '002-m64p-git-enable-optimizations.patch'
'm64p.desktop')
sha256sums=('SKIP'
'SKIP'
@@ -29,6 +31,8 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'c7b80c7be0e07e44b260e1ce89e31628d64ddee622ea842b85f6eb0aeff4168a'
+ 'b27e808d97b37bd1a98c9c8482a938f5da6b19c26c58db792f0e79b27a7d84c7'
'b884fc86180346226eb7e8bf8560d2b789318e810c9e26b6adbe7d8d047188df')
prepare() {
@@ -42,6 +46,8 @@ prepare() {
git config --local submodule.mupen64plus-input-qt.url "${srcdir}/mupen64plus-input-qt"
git config --local submodule.mupen64plus-input-raphnetraw.url "${srcdir}/mupen64plus-input-raphnetraw-loganmc10"
git submodule update
+ patch -Np1 -i "${srcdir}/001-m64p-git-remove-build-jobs-limitation.patch"
+ patch -Np1 -i "${srcdir}/002-m64p-git-enable-optimizations.patch"
}
pkgver() {
@@ -56,28 +62,21 @@ build() {
package() {
# mupen64plus-gui
install -D -m755 m64p/mupen64plus/mupen64plus-gui -t "${pkgdir}/usr/bin"
+ install -D -m644 m64p.desktop -t "${pkgdir}/usr/share/applications"
+ install -D -m644 mupen64plus-gui/mupen64plus.ico "${pkgdir}/usr/share/pixmaps/m64p.ico"
- # mupen64plus-core
+ # mupen64plus components
+ local _component
+ for _component in core audio-sdl2 input-raphnetraw rsp-hle
+ do
+ make -C "m64p/mupen64plus-${_component}/projects/unix" DESTDIR="$pkgdir" PREFIX='/usr' LDCONFIG='true' install
+ done
local _sover
- _sover="$(find m64p/mupen64plus -type f -name 'libmupen64plus.so.*.*' | sed 's/^.*\.so\.//')"
- mkdir -p "${pkgdir}/usr/lib"
- cp -a m64p/mupen64plus/libmupen64plus.so* "${pkgdir}/usr/lib"
+ _sover="$(find m64p/mupen64plus-core/projects/unix -type f -name 'libmupen64plus.so.*.*' | sed 's/^.*\.so\.//')"
ln -s "libmupen64plus.so.${_sover}" "${pkgdir}/usr/lib/libmupen64plus.so"
- # plugins
- install -D -m644 m64p/mupen64plus/mupen64plus-audio-sdl2.so -t "${pkgdir}/usr/lib/mupen64plus"
- install -D -m644 m64p/mupen64plus/mupen64plus-rsp-hle.so -t "${pkgdir}/usr/lib/mupen64plus"
- install -D -m644 m64p/mupen64plus/mupen64plus-input-qt.so -t "${pkgdir}/usr/lib/mupen64plus"
- install -D -m644 m64p/mupen64plus/mupen64plus-input-raphnetraw.so -t "${pkgdir}/usr/lib/mupen64plus"
- install -D -m644 m64p/mupen64plus/mupen64plus-video-GLideN64.so -t "${pkgdir}/usr/lib/mupen64plus"
-
- # config
- install -D -m644 m64p/mupen64plus/font.ttf -t "${pkgdir}/usr/share/mupen64plus"
+ # other plugins
+ install -D -m644 m64p/mupen64plus/mupen64plus-input-qt.so -t "${pkgdir}/usr/lib/mupen64plus"
+ install -D -m644 m64p/mupen64plus/mupen64plus-video-GLideN64.so -t "${pkgdir}/usr/lib/mupen64plus"
install -D -m644 m64p/mupen64plus/GLideN64.custom.ini -t "${pkgdir}/usr/share/mupen64plus"
- install -D -m644 m64p/mupen64plus/mupen64plus.ini -t "${pkgdir}/usr/share/mupen64plus"
- install -D -m644 m64p/mupen64plus/mupencheat.txt -t "${pkgdir}/usr/share/mupen64plus"
-
- # desktop and icon
- install -D -m644 m64p.desktop -t "${pkgdir}/usr/share/applications"
- install -D -m644 mupen64plus-gui/mupen64plus.ico "${pkgdir}/usr/share/pixmaps/m64p.ico"
}