summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2022-07-02 21:38:30 -0300
committerDaniel Bermond2022-07-02 21:38:30 -0300
commit731fd26e9b99efd11527013e9b64bb3ebcbc883d (patch)
tree2964aef5196957b1054b9a4acfebfe980d8c39ac
parent20e990d5a4248c7a19bfae4ea4a4bddc6e47a602 (diff)
downloadaur-731fd26e9b99efd11527013e9b64bb3ebcbc883d.tar.gz
Match latest upstream changes
-rw-r--r--.SRCINFO10
-rw-r--r--010-m64p-remove-build-jobs-limitation.patch20
-rw-r--r--020-m64p-change-optimizations.patch16
-rw-r--r--030-m64p-remove-bundled-discord-and-vosk.patch4
-rw-r--r--050-m64p-add-pie.patch7
-rw-r--r--PKGBUILD10
6 files changed, 33 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96cc47511c04..72fbad2c4e1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = m64p-git
pkgdesc = Mupen64Plus with custom plugins and Qt5 GUI (git version)
- pkgver = 20220403.r2.gf6e621b
+ pkgver = 20220630.r4.gbb8f6e6
pkgrel = 1
url = https://m64p.github.io/
arch = x86_64
@@ -42,11 +42,11 @@ pkgbase = m64p-git
source = 050-m64p-add-pie.patch
source = m64p.desktop
sha256sums = SKIP
- sha256sums = f6ae0125845fd8fc70efeae83fc54d6d4c0787f8215d274c84f259564ec36211
- sha256sums = 1981ca0e45bd77faa0651336487be1899250b0d1f3c4191b84daa22ebc119918
- sha256sums = a32345c9013b2a6d8b08fd7aadb899643b95a7c4cee71cddbed1ae4fb7c8764b
+ sha256sums = 038d8f811dd4632e87d4775f050dfaf0aea836c6ed4002b8ae1390b857e4e039
+ sha256sums = cc19027b19c0b516280e5e939115483ded9c7f03b1ff5f91e589e0d6bae9f735
+ sha256sums = b6fd822625dea4209d996a345a17e637c7a08e622ada99f87861bb5b5996061d
sha256sums = 11f7a3caa150a716a12ab0d70a98089d7502d7a716f41e9bc419469fe4e1957a
- sha256sums = 9d72588b07ef5e86c4730f9384b5d3622e38ccab0f99d7fa419870e7d19c264b
+ sha256sums = bfc34f267e0ee0f4ce2f65aaf5433060c6d542afbb54e24511187a95cf6f1f73
sha256sums = 8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808
pkgname = m64p-git
diff --git a/010-m64p-remove-build-jobs-limitation.patch b/010-m64p-remove-build-jobs-limitation.patch
index 8ab8893ad438..b834cd73d797 100644
--- a/010-m64p-remove-build-jobs-limitation.patch
+++ b/010-m64p-remove-build-jobs-limitation.patch
@@ -1,17 +1,17 @@
--- a/build.sh
+++ b/build.sh
-@@ -24,18 +24,18 @@ mkdir -p $install_dir
- base_dir=$PWD
+@@ -26,18 +26,18 @@ base_dir=$PWD
+ export OPTFLAGS="-O3 -flto -march=x86-64-v3"
cd $base_dir/mupen64plus-core/projects/unix
--make NETPLAY=1 NO_ASM=1 OSD=0 -j4 all
-+make NETPLAY=1 NO_ASM=1 OSD=0 all
+-make NETPLAY=1 NO_ASM=1 OSD=0 V=1 -j4 all
++make NETPLAY=1 NO_ASM=1 OSD=0 V=1 all
cp -P $base_dir/mupen64plus-core/projects/unix/*$suffix* $install_dir
cp $base_dir/mupen64plus-core/data/* $install_dir
cd $base_dir/mupen64plus-input-raphnetraw/projects/unix
--make -j4 all
-+make all
+-make V=1 -j4 all
++make V=1 all
cp $base_dir/mupen64plus-input-raphnetraw/projects/unix/*$suffix $install_dir
mkdir -p $base_dir/mupen64plus-input-qt/build
@@ -22,16 +22,16 @@
if [[ $UNAME == *"MINGW"* ]]; then
cp $base_dir/mupen64plus-input-qt/build/release/mupen64plus-input-qt.dll $install_dir
else
-@@ -43,7 +43,7 @@ else
+@@ -45,7 +45,7 @@ else
fi
cd $base_dir/mupen64plus-audio-sdl2/projects/unix
--make -j4 all
-+make all
+-make V=1 -j4 all
++make V=1 all
cp $base_dir/mupen64plus-audio-sdl2/projects/unix/*$suffix $install_dir
cd $base_dir
-@@ -62,7 +62,7 @@ fi
+@@ -64,7 +64,7 @@ fi
mkdir -p $base_dir/mupen64plus-gui/build
cd $base_dir/mupen64plus-gui/build
qmake ../mupen64plus-gui.pro
diff --git a/020-m64p-change-optimizations.patch b/020-m64p-change-optimizations.patch
index e1482efa4831..db1144bb77e4 100644
--- a/020-m64p-change-optimizations.patch
+++ b/020-m64p-change-optimizations.patch
@@ -1,15 +1,15 @@
--- a/build.sh
+++ b/build.sh
-@@ -24,7 +24,7 @@ mkdir -p $install_dir
- base_dir=$PWD
+@@ -26,7 +26,7 @@ base_dir=$PWD
+ export OPTFLAGS="-O3 -flto -march=x86-64-v3"
cd $base_dir/mupen64plus-core/projects/unix
--make NETPLAY=1 NO_ASM=1 OSD=0 all
-+make NETPLAY=1 OSD=0 all
+-make NETPLAY=1 NO_ASM=1 OSD=0 V=1 all
++make NETPLAY=1 OSD=0 V=1 all
cp -P $base_dir/mupen64plus-core/projects/unix/*$suffix* $install_dir
cp $base_dir/mupen64plus-core/data/* $install_dir
-@@ -75,9 +75,9 @@ fi
+@@ -77,9 +77,9 @@ fi
mkdir -p $base_dir/parallel-rsp/build
cd $base_dir/parallel-rsp/build
if [[ $UNAME == *"MINGW"* ]]; then
@@ -19,9 +19,9 @@
- cmake -DCMAKE_BUILD_TYPE=Release ..
+ cmake -DCMAKE_BUILD_TYPE=None ..
fi
- cmake --build .
+ VERBOSE=1 cmake --build .
cp mupen64plus-rsp-parallel.* $install_dir
-@@ -85,9 +85,9 @@ cp mupen64plus-rsp-parallel.* $install_dir
+@@ -87,9 +87,9 @@ cp mupen64plus-rsp-parallel.* $install_dir
mkdir -p $base_dir/parallel-rdp-standalone/build
cd $base_dir/parallel-rdp-standalone/build
if [[ $UNAME == *"MINGW"* ]]; then
@@ -31,5 +31,5 @@
- cmake -DCMAKE_BUILD_TYPE=Release ..
+ cmake -DCMAKE_BUILD_TYPE=None ..
fi
- cmake --build .
+ VERBOSE=1 cmake --build .
cp mupen64plus-video-parallel.* $install_dir
diff --git a/030-m64p-remove-bundled-discord-and-vosk.patch b/030-m64p-remove-bundled-discord-and-vosk.patch
index 793b42d094eb..762daa3e9d32 100644
--- a/030-m64p-remove-bundled-discord-and-vosk.patch
+++ b/030-m64p-remove-bundled-discord-and-vosk.patch
@@ -1,6 +1,6 @@
--- a/build.sh
+++ b/build.sh
-@@ -157,8 +157,6 @@ else
+@@ -159,8 +159,6 @@ else
else
my_os=linux64
fi
@@ -11,7 +11,7 @@
if [[ "$1" != "nozip" ]]; then
--- a/mupen64plus-gui/mupen64plus-gui.pro
+++ b/mupen64plus-gui/mupen64plus-gui.pro
-@@ -92,8 +92,7 @@ HEADERS += mainwindow.h \
+@@ -98,8 +98,7 @@ HEADERS += mainwindow.h \
netplay/createroom.h \
netplay/joinroom.h \
netplay/waitroom.h \
diff --git a/050-m64p-add-pie.patch b/050-m64p-add-pie.patch
index 4b23960094d9..77797c41fb90 100644
--- a/050-m64p-add-pie.patch
+++ b/050-m64p-add-pie.patch
@@ -1,11 +1,10 @@
--- a/mupen64plus-gui/mupen64plus-gui.pro
+++ b/mupen64plus-gui/mupen64plus-gui.pro
-@@ -98,8 +98,6 @@ FORMS += mainwindow.ui
+@@ -104,7 +104,6 @@ FORMS += mainwindow.ui
QMAKE_INCDIR += api interface
-QMAKE_LFLAGS += -no-pie
--
- CONFIG += optimize_full
- QMAKE_PROJECT_DEPTH = 0
+ QMAKE_CXXFLAGS_RELEASE -= -O2
+ QMAKE_CXXFLAGS_RELEASE += -O3 -march=x86-64-v3
diff --git a/PKGBUILD b/PKGBUILD
index b01110a2ce0a..e9bbcbcc005c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=m64p-git
-pkgver=20220403.r2.gf6e621b
+pkgver=20220630.r4.gbb8f6e6
pkgrel=1
pkgdesc='Mupen64Plus with custom plugins and Qt5 GUI (git version)'
arch=('x86_64')
@@ -23,11 +23,11 @@ source=('git+https://github.com/loganmc10/m64p.git'
'050-m64p-add-pie.patch'
'm64p.desktop')
sha256sums=('SKIP'
- 'f6ae0125845fd8fc70efeae83fc54d6d4c0787f8215d274c84f259564ec36211'
- '1981ca0e45bd77faa0651336487be1899250b0d1f3c4191b84daa22ebc119918'
- 'a32345c9013b2a6d8b08fd7aadb899643b95a7c4cee71cddbed1ae4fb7c8764b'
+ '038d8f811dd4632e87d4775f050dfaf0aea836c6ed4002b8ae1390b857e4e039'
+ 'cc19027b19c0b516280e5e939115483ded9c7f03b1ff5f91e589e0d6bae9f735'
+ 'b6fd822625dea4209d996a345a17e637c7a08e622ada99f87861bb5b5996061d'
'11f7a3caa150a716a12ab0d70a98089d7502d7a716f41e9bc419469fe4e1957a'
- '9d72588b07ef5e86c4730f9384b5d3622e38ccab0f99d7fa419870e7d19c264b'
+ 'bfc34f267e0ee0f4ce2f65aaf5433060c6d542afbb54e24511187a95cf6f1f73'
'8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808')
prepare() {