summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-12-05 14:31:54 -0300
committerDaniel Bermond2021-12-05 14:31:54 -0300
commit7b6a02e324995436cfb06d8faf62ce023aeaabdf (patch)
tree9b62ea7364434f78ba82738a4cf8f2a7046c6197
parent930f9c7e84e08237f380f748ebe463c4b1651cf5 (diff)
downloadaur-7b6a02e324995436cfb06d8faf62ce023aeaabdf.tar.gz
Fix paths of core library and plugins
-rw-r--r--.SRCINFO4
-rw-r--r--030-m64p-fix-paths.patch42
-rw-r--r--PKGBUILD4
3 files changed, 44 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80c4b35e0ed0..4e7d679d7d32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = m64p-git
pkgdesc = Mupen64Plus with custom plugins and Qt5 GUI (git version)
- pkgver = 20211122.r4.gdb0e652
+ pkgver = 20211203.r1.gfa29bc1
pkgrel = 1
url = https://m64p.github.io/
arch = x86_64
@@ -41,7 +41,7 @@ pkgbase = m64p-git
sha256sums = SKIP
sha256sums = b8882d2b3cce965bd03b100fc53419ff43d8934c364136bbe63473fca0692fec
sha256sums = bd2964654f5c346af76a5408adc76d34bf490435c4400cfa1d2340f0ad598dcd
- sha256sums = afb952edd1f1766ae23433e9101b6aed5283c0ebe7f1723749ae464e65490bc4
+ sha256sums = 782576ad8ff7c33f2d4dffb367509cd3590acdd357a17c432889a9f6f8b3d7a0
sha256sums = 5c604da87c9deb3582b43efa724589080a7070a108ab0c0d00e115cb35eb4b13
sha256sums = 8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808
diff --git a/030-m64p-fix-paths.patch b/030-m64p-fix-paths.patch
index b6ce57c65d24..0c12de258283 100644
--- a/030-m64p-fix-paths.patch
+++ b/030-m64p-fix-paths.patch
@@ -8,12 +8,21 @@
#include "settingsdialog.h"
#include "plugindialog.h"
#include "mainwindow.h"
+@@ -44,7 +45,7 @@ void MainWindow::updatePlugins()
+ #ifdef PLUGIN_DIR_PATH
+ QString pluginPath = PLUGIN_DIR_PATH;
+ #else
+- QString pluginPath = QCoreApplication::applicationDirPath();
++ QString pluginPath = QStringLiteral(u"/usr/lib/mupen64plus");
+ #endif
+ QDir PluginDir(pluginPath);
+ PluginDir.setFilter(QDir::Files);
@@ -370,7 +371,7 @@ MainWindow::MainWindow(QWidget *parent) :
updatePIF(ui);
if (!settings->contains("configDirPath"))
- settings->setValue("configDirPath", "$CONFIG_PATH$");
-+ settings->setValue("configDirPath", QStandardPaths::writableLocation(QStandardPaths::ConfigLocation) + "/mupen64plus");
++ settings->setValue("configDirPath", QStandardPaths::writableLocation(QStandardPaths::ConfigLocation) + QStringLiteral(u"/mupen64plus"));
#ifdef CONFIG_DIR_PATH
settings->setValue("configDirPath", CONFIG_DIR_PATH);
@@ -22,7 +31,36 @@
void MainWindow::setupDiscord()
{
- QLibrary *discordLib = new QLibrary((QDir(QCoreApplication::applicationDirPath()).filePath("discord_game_sdk")), this);
-+ QLibrary *discordLib = new QLibrary("/usr/lib/discord_game_sdk", this);
++ QLibrary *discordLib = new QLibrary(QStringLiteral(u"/usr/lib/discord_game_sdk"), this);
memset(&discord_app, 0, sizeof(discord_app));
+@@ -1015,7 +1016,7 @@ void MainWindow::loadCoreLib()
+ #ifdef CORE_LIBRARY_PATH
+ QString corePath = CORE_LIBRARY_PATH;
+ #else
+- QString corePath = QCoreApplication::applicationDirPath();
++ QString corePath = QStringLiteral(u"/usr/lib");
+ #endif
+ m64p_error res = osal_dynlib_open(&coreLib, QDir(corePath).filePath(OSAL_DEFAULT_DYNLIB_FILENAME).toUtf8().constData());
+
+@@ -1105,7 +1106,7 @@ void MainWindow::loadPlugins()
+ #ifdef PLUGIN_DIR_PATH
+ QString pluginPath = PLUGIN_DIR_PATH;
+ #else
+- QString pluginPath = QCoreApplication::applicationDirPath();
++ QString pluginPath = QStringLiteral(u"/usr/lib/mupen64plus");
+ #endif
+ QString file_path;
+ QString plugin_path;
+--- a/mupen64plus-gui/settingsdialog.cpp
++++ b/mupen64plus-gui/settingsdialog.cpp
+@@ -58,7 +58,7 @@ void SettingsDialog::initStuff()
+ #ifdef PLUGIN_DIR_PATH
+ QString pluginPath = PLUGIN_DIR_PATH;
+ #else
+- QString pluginPath = QCoreApplication::applicationDirPath();
++ QString pluginPath = QStringLiteral(u"/usr/lib/mupen64plus");
+ #endif
+ QDir PluginDir(pluginPath);
+ QStringList Filter;
diff --git a/PKGBUILD b/PKGBUILD
index e96210d3ef88..7618a3cc9659 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=m64p-git
-pkgver=20211122.r4.gdb0e652
+pkgver=20211203.r1.gfa29bc1
pkgrel=1
pkgdesc='Mupen64Plus with custom plugins and Qt5 GUI (git version)'
arch=('x86_64')
@@ -23,7 +23,7 @@ source=('git+https://github.com/loganmc10/m64p.git'
sha256sums=('SKIP'
'b8882d2b3cce965bd03b100fc53419ff43d8934c364136bbe63473fca0692fec'
'bd2964654f5c346af76a5408adc76d34bf490435c4400cfa1d2340f0ad598dcd'
- 'afb952edd1f1766ae23433e9101b6aed5283c0ebe7f1723749ae464e65490bc4'
+ '782576ad8ff7c33f2d4dffb367509cd3590acdd357a17c432889a9f6f8b3d7a0'
'5c604da87c9deb3582b43efa724589080a7070a108ab0c0d00e115cb35eb4b13'
'8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808')