summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-04-24 14:25:27 +0000
committerDaniel Bermond2020-04-24 14:25:27 +0000
commit8af764e2f87e2bfa5f742c17473c93a6d04d314c (patch)
tree0633059be1ba0291966acce456da0c56380026ab
parent5675d5a3f8b49dbda223b1703d1ad9735d13137b (diff)
downloadaur-8af764e2f87e2bfa5f742c17473c93a6d04d314c.tar.gz
Match latest upstream changes
-rw-r--r--.SRCINFO6
-rw-r--r--001-m64p-git-remove-build-jobs-limitation.patch16
-rw-r--r--002-m64p-git-enable-optimizations.patch22
-rw-r--r--PKGBUILD31
4 files changed, 37 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 547c5f9e805c..616736cd46e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = m64p-git
pkgdesc = Mupen64Plus with custom plugins and Qt5 GUI (git version)
- pkgver = r94.g8d7153e
+ pkgver = r104.g2938cb5
pkgrel = 1
url = https://m64p.github.io/
arch = x86_64
@@ -45,8 +45,8 @@ pkgbase = m64p-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = c7b80c7be0e07e44b260e1ce89e31628d64ddee622ea842b85f6eb0aeff4168a
- sha256sums = b27e808d97b37bd1a98c9c8482a938f5da6b19c26c58db792f0e79b27a7d84c7
+ sha256sums = 6871b495ace8a9005d93ce3e9103a15111a67793812dd5158072c981c4c3a5a8
+ sha256sums = a999739626fc3e9d0102b65014c436bf4e9039587ccac174334672f3925f4495
sha256sums = b884fc86180346226eb7e8bf8560d2b789318e810c9e26b6adbe7d8d047188df
pkgname = m64p-git
diff --git a/001-m64p-git-remove-build-jobs-limitation.patch b/001-m64p-git-remove-build-jobs-limitation.patch
index 9c805f7d8c6a..c1c7c831fa2b 100644
--- a/001-m64p-git-remove-build-jobs-limitation.patch
+++ b/001-m64p-git-remove-build-jobs-limitation.patch
@@ -1,12 +1,12 @@
diff -Naurp a/build.sh b/build.sh
---- a/build.sh 2020-04-11 12:39:46.000000000 +0000
-+++ b/build.sh 2020-04-11 12:40:10.817528173 +0000
-@@ -21,22 +21,22 @@ mkdir -p $install_dir
+--- a/build.sh 2020-04-24 14:06:44.000000000 +0000
++++ b/build.sh 2020-04-24 14:10:40.693877444 +0000
+@@ -19,22 +19,22 @@ mkdir -p $install_dir
base_dir=$PWD
cd $base_dir/mupen64plus-core/projects/unix
--make -j4 all
-+make all
+-make OSD=0 NO_ASM=1 -j4 all
++make OSD=0 NO_ASM=1 all
cp -P $base_dir/mupen64plus-core/projects/unix/*$suffix* $install_dir
cp $base_dir/mupen64plus-core/data/* $install_dir
@@ -28,7 +28,7 @@ diff -Naurp a/build.sh b/build.sh
if [[ $UNAME == *"MINGW"* ]]; then
cp $base_dir/mupen64plus-input-qt/build/release/mupen64plus-input-qt.dll $install_dir
else
-@@ -44,13 +44,13 @@ else
+@@ -42,13 +42,13 @@ else
fi
cd $base_dir/mupen64plus-audio-sdl2/projects/unix
@@ -44,7 +44,7 @@ diff -Naurp a/build.sh b/build.sh
if [[ $UNAME == *"MINGW"* ]]; then
cp $base_dir/mupen64plus-gui/build/release/mupen64plus-gui.exe $install_dir
else
-@@ -64,7 +64,7 @@ cd $base_dir/GLideN64/src/GLideNUI
+@@ -62,7 +62,7 @@ cd $base_dir/GLideN64/src/GLideNUI
mkdir -p build
cd build
qmake ../GLideNUI.pro
@@ -53,7 +53,7 @@ diff -Naurp a/build.sh b/build.sh
cd $base_dir/GLideN64/projects/cmake
if [[ $UNAME == *"MINGW"* ]]; then
-@@ -72,7 +72,7 @@ if [[ $UNAME == *"MINGW"* ]]; then
+@@ -70,7 +70,7 @@ if [[ $UNAME == *"MINGW"* ]]; then
else
cmake -DNOHQ=On -DVEC4_OPT=On -DCRC_OPT=On -DMUPENPLUSAPI=On ../../src/
fi
diff --git a/002-m64p-git-enable-optimizations.patch b/002-m64p-git-enable-optimizations.patch
index 8a90140fd836..19bfd75673a9 100644
--- a/002-m64p-git-enable-optimizations.patch
+++ b/002-m64p-git-enable-optimizations.patch
@@ -1,16 +1,16 @@
diff -Naurp a/build.sh b/build.sh
---- a/build.sh 2020-04-11 12:40:10.000000000 +0000
-+++ b/build.sh 2020-04-11 12:40:51.273637405 +0000
-@@ -14,8 +14,6 @@ else
- suffix=".so"
- fi
-
--export NO_ASM=1
--
- install_dir=$PWD/mupen64plus
- mkdir -p $install_dir
+--- a/build.sh 2020-04-24 14:10:40.000000000 +0000
++++ b/build.sh 2020-04-24 14:13:14.231642044 +0000
+@@ -19,7 +19,7 @@ mkdir -p $install_dir
base_dir=$PWD
-@@ -68,9 +66,9 @@ make
+
+ cd $base_dir/mupen64plus-core/projects/unix
+-make OSD=0 NO_ASM=1 all
++make all
+ cp -P $base_dir/mupen64plus-core/projects/unix/*$suffix* $install_dir
+ cp $base_dir/mupen64plus-core/data/* $install_dir
+
+@@ -66,9 +66,9 @@ make
cd $base_dir/GLideN64/projects/cmake
if [[ $UNAME == *"MINGW"* ]]; then
diff --git a/PKGBUILD b/PKGBUILD
index 93a2cda855c0..73e0bd9176ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=m64p-git
-pkgver=r94.g8d7153e
+pkgver=r104.g2938cb5
pkgrel=1
pkgdesc='Mupen64Plus with custom plugins and Qt5 GUI (git version)'
arch=('x86_64')
@@ -31,23 +31,22 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'c7b80c7be0e07e44b260e1ce89e31628d64ddee622ea842b85f6eb0aeff4168a'
- 'b27e808d97b37bd1a98c9c8482a938f5da6b19c26c58db792f0e79b27a7d84c7'
+ '6871b495ace8a9005d93ce3e9103a15111a67793812dd5158072c981c4c3a5a8'
+ 'a999739626fc3e9d0102b65014c436bf4e9039587ccac174334672f3925f4495'
'b884fc86180346226eb7e8bf8560d2b789318e810c9e26b6adbe7d8d047188df')
prepare() {
- cd m64p
- git submodule init
- git config --local submodule.mupen64plus-core.url "${srcdir}/mupen64plus-core-loganmc10"
- git config --local submodule.GLideN64.url "${srcdir}/GLideN64-loganmc10"
- git config --local submodule.mupen64plus-gui.url "${srcdir}/mupen64plus-gui"
- git config --local submodule.mupen64plus-audio-sdl2.url "${srcdir}/mupen64plus-audio-sdl2"
- git config --local submodule.mupen64plus-rsp-hle.url "${srcdir}/mupen64plus-rsp-hle"
- git config --local submodule.mupen64plus-input-qt.url "${srcdir}/mupen64plus-input-qt"
- git config --local submodule.mupen64plus-input-raphnetraw.url "${srcdir}/mupen64plus-input-raphnetraw-loganmc10"
- git submodule update
- patch -Np1 -i "${srcdir}/001-m64p-git-remove-build-jobs-limitation.patch"
- patch -Np1 -i "${srcdir}/002-m64p-git-enable-optimizations.patch"
+ git -C m64p submodule init
+ git -C m64p config --local submodule.mupen64plus-core.url "${srcdir}/mupen64plus-core-loganmc10"
+ git -C m64p config --local submodule.GLideN64.url "${srcdir}/GLideN64-loganmc10"
+ git -C m64p config --local submodule.mupen64plus-gui.url "${srcdir}/mupen64plus-gui"
+ git -C m64p config --local submodule.mupen64plus-audio-sdl2.url "${srcdir}/mupen64plus-audio-sdl2"
+ git -C m64p config --local submodule.mupen64plus-rsp-hle.url "${srcdir}/mupen64plus-rsp-hle"
+ git -C m64p config --local submodule.mupen64plus-input-qt.url "${srcdir}/mupen64plus-input-qt"
+ git -C m64p config --local submodule.mupen64plus-input-raphnetraw.url "${srcdir}/mupen64plus-input-raphnetraw-loganmc10"
+ git -C m64p submodule update
+ patch -d m64p -Np1 -i "${srcdir}/001-m64p-git-remove-build-jobs-limitation.patch"
+ patch -d m64p -Np1 -i "${srcdir}/002-m64p-git-enable-optimizations.patch"
}
pkgver() {
@@ -72,7 +71,7 @@ package() {
make -C "m64p/mupen64plus-${_component}/projects/unix" DESTDIR="$pkgdir" PREFIX='/usr' LDCONFIG='true' install
done
local _sover
- _sover="$(find m64p/mupen64plus-core/projects/unix -type f -name 'libmupen64plus.so.*.*' | sed 's/^.*\.so\.//')"
+ _sover="$(find "${pkgdir}/usr/lib" -type f -name 'libmupen64plus.so.*.*.*' | sed 's/^.*\.so\.//')"
ln -s "libmupen64plus.so.${_sover}" "${pkgdir}/usr/lib/libmupen64plus.so"
# other plugins