summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-07-18 12:05:15 +0000
committerDaniel Bermond2021-07-18 12:05:15 +0000
commitb5fa1d3a58fad19b8fed8a7a69f726910d5d7da8 (patch)
tree50bad5d5cab0f570b243c377b34d9cd087022dcb
parentf1bf6c8590b2d4e2d5bfe23c5adef314373d838a (diff)
downloadaur-b5fa1d3a58fad19b8fed8a7a69f726910d5d7da8.tar.gz
Match latest upstream changes
-rw-r--r--.SRCINFO10
-rw-r--r--010-m64p-remove-build-jobs-limitation.patch10
-rw-r--r--020-m64p-change-optimizations.patch13
-rw-r--r--030-m64p-fix-paths.patch6
-rw-r--r--040-m64p-add-pie.patch2
-rw-r--r--PKGBUILD12
6 files changed, 22 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25fbbc836ef1..636f082f000e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = m64p-git
pkgdesc = Mupen64Plus with custom plugins and Qt5 GUI (git version)
- pkgver = 20210610.r2.g5c06fbb
+ pkgver = 20210711.r3.gdbd4a6b
pkgrel = 1
url = https://m64p.github.io/
arch = x86_64
@@ -38,10 +38,10 @@ pkgbase = m64p-git
source = 040-m64p-add-pie.patch
source = m64p.desktop
sha256sums = SKIP
- sha256sums = 18cfd173f15de588285771b6159e69a07f6735d981b7326e8be52c3acce562b0
- sha256sums = e774a0f25f951c5296a83f565384b3d788aa224537c4695e6712ae057d5a54a7
- sha256sums = 4271db8d4a4c8a39373897562cf0429f20cd95d952ab8385c1b376451ea55096
- sha256sums = 13879a08f76881c75597883c54917dbcd782ed0486050856043abaeff8ec86db
+ sha256sums = b8882d2b3cce965bd03b100fc53419ff43d8934c364136bbe63473fca0692fec
+ sha256sums = bd2964654f5c346af76a5408adc76d34bf490435c4400cfa1d2340f0ad598dcd
+ sha256sums = 53824848c8ec88e8c6dbc86682b6910ec7f80950279fdfa6809f08721b3fb592
+ sha256sums = 5c604da87c9deb3582b43efa724589080a7070a108ab0c0d00e115cb35eb4b13
sha256sums = 8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808
pkgname = m64p-git
diff --git a/010-m64p-remove-build-jobs-limitation.patch b/010-m64p-remove-build-jobs-limitation.patch
index 6bcb468856f5..3ed70dc3e0dd 100644
--- a/010-m64p-remove-build-jobs-limitation.patch
+++ b/010-m64p-remove-build-jobs-limitation.patch
@@ -1,11 +1,11 @@
--- a/build.sh
+++ b/build.sh
-@@ -24,18 +24,18 @@ mkdir -p $install_dir
+@@ -26,18 +26,18 @@ mkdir -p $install_dir
base_dir=$PWD
cd $base_dir/mupen64plus-core/projects/unix
--make NETPLAY=1 OSD=0 NO_ASM=1 -j4 all
-+make NETPLAY=1 OSD=0 NO_ASM=1 all
+-make NETPLAY=1 OSD=0 -j4 all
++make NETPLAY=1 OSD=0 all
cp -P $base_dir/mupen64plus-core/projects/unix/*$suffix* $install_dir
cp $base_dir/mupen64plus-core/data/* $install_dir
@@ -22,7 +22,7 @@
if [[ $UNAME == *"MINGW"* ]]; then
cp $base_dir/mupen64plus-input-qt/build/release/mupen64plus-input-qt.dll $install_dir
else
-@@ -43,7 +43,7 @@ else
+@@ -45,7 +45,7 @@ else
fi
cd $base_dir/mupen64plus-audio-sdl2/projects/unix
@@ -31,7 +31,7 @@
cp $base_dir/mupen64plus-audio-sdl2/projects/unix/*$suffix $install_dir
cd $base_dir
-@@ -62,7 +62,7 @@ fi
+@@ -64,7 +64,7 @@ fi
mkdir -p $base_dir/mupen64plus-gui/build
cd $base_dir/mupen64plus-gui/build
qmake ../mupen64plus-gui.pro
diff --git a/020-m64p-change-optimizations.patch b/020-m64p-change-optimizations.patch
index 4dbf4b046a46..c383e3a2214f 100644
--- a/020-m64p-change-optimizations.patch
+++ b/020-m64p-change-optimizations.patch
@@ -1,15 +1,6 @@
--- a/build.sh
+++ b/build.sh
-@@ -24,7 +24,7 @@ mkdir -p $install_dir
- base_dir=$PWD
-
- cd $base_dir/mupen64plus-core/projects/unix
--make NETPLAY=1 OSD=0 NO_ASM=1 all
-+make NETPLAY=1 OSD=0 all
- cp -P $base_dir/mupen64plus-core/projects/unix/*$suffix* $install_dir
- cp $base_dir/mupen64plus-core/data/* $install_dir
-
-@@ -75,9 +75,9 @@ fi
+@@ -77,9 +77,9 @@ fi
mkdir -p $base_dir/parallel-rsp/build
cd $base_dir/parallel-rsp/build
if [[ $UNAME == *"MINGW"* ]]; then
@@ -21,7 +12,7 @@
fi
cmake --build .
cp mupen64plus-rsp-parallel.* $install_dir
-@@ -85,9 +85,9 @@ cp mupen64plus-rsp-parallel.* $install_dir
+@@ -87,9 +87,9 @@ cp mupen64plus-rsp-parallel.* $install_dir
mkdir -p $base_dir/parallel-rdp-standalone/build
cd $base_dir/parallel-rdp-standalone/build
if [[ $UNAME == *"MINGW"* ]]; then
diff --git a/030-m64p-fix-paths.patch b/030-m64p-fix-paths.patch
index e960273c4677..1a4a392ee8c9 100644
--- a/030-m64p-fix-paths.patch
+++ b/030-m64p-fix-paths.patch
@@ -21,9 +21,9 @@
- settings->setValue("configDirPath", "$CONFIG_PATH$");
+ settings->setValue("configDirPath", QStandardPaths::writableLocation(QStandardPaths::ConfigLocation) + "/mupen64plus");
- updatePlugins();
-
-@@ -428,7 +429,7 @@ void MainWindow::updateApp()
+ #ifdef CORE_LIBRARY_PATH
+ settings->setValue("coreLibPath", CORE_LIBRARY_PATH);
+@@ -438,7 +439,7 @@ void MainWindow::updateApp()
void MainWindow::setupDiscord()
{
diff --git a/040-m64p-add-pie.patch b/040-m64p-add-pie.patch
index 0e4f7980a476..95fd43babc17 100644
--- a/040-m64p-add-pie.patch
+++ b/040-m64p-add-pie.patch
@@ -1,6 +1,6 @@
--- a/mupen64plus-gui/mupen64plus-gui.pro
+++ b/mupen64plus-gui/mupen64plus-gui.pro
-@@ -97,8 +97,6 @@ FORMS += mainwindow.ui
+@@ -99,8 +99,6 @@ FORMS += mainwindow.ui
QMAKE_INCDIR += api interface
diff --git a/PKGBUILD b/PKGBUILD
index c8d18cc578cd..fbd64b0eebf0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=m64p-git
-pkgver=20210610.r2.g5c06fbb
+pkgver=20210711.r3.gdbd4a6b
pkgrel=1
pkgdesc='Mupen64Plus with custom plugins and Qt5 GUI (git version)'
arch=('x86_64')
@@ -20,10 +20,10 @@ source=('git+https://github.com/loganmc10/m64p.git'
'040-m64p-add-pie.patch'
'm64p.desktop')
sha256sums=('SKIP'
- '18cfd173f15de588285771b6159e69a07f6735d981b7326e8be52c3acce562b0'
- 'e774a0f25f951c5296a83f565384b3d788aa224537c4695e6712ae057d5a54a7'
- '4271db8d4a4c8a39373897562cf0429f20cd95d952ab8385c1b376451ea55096'
- '13879a08f76881c75597883c54917dbcd782ed0486050856043abaeff8ec86db'
+ 'b8882d2b3cce965bd03b100fc53419ff43d8934c364136bbe63473fca0692fec'
+ 'bd2964654f5c346af76a5408adc76d34bf490435c4400cfa1d2340f0ad598dcd'
+ '53824848c8ec88e8c6dbc86682b6910ec7f80950279fdfa6809f08721b3fb592'
+ '5c604da87c9deb3582b43efa724589080a7070a108ab0c0d00e115cb35eb4b13'
'8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808')
prepare() {
@@ -64,7 +64,7 @@ package() {
local _sover
for _component in core audio-sdl2 input-raphnetraw
do
- make -C "m64p/mupen64plus-${_component}/projects/unix" DESTDIR="$pkgdir" PREFIX='/usr' LDCONFIG='true' OSD='0' install
+ make -C "m64p/mupen64plus-${_component}/projects/unix" DESTDIR="$pkgdir" PREFIX='/usr' LDCONFIG='true' NEW_DYNAREC='1' NETPLAY='1' OSD='0' install
done
_sover="$(find "${pkgdir}/usr/lib" -type f -name 'libmupen64plus.so.*.*.*' | sed 's/^.*\.so\.//')"
ln -s "libmupen64plus.so.${_sover}" "${pkgdir}/usr/lib/libmupen64plus.so"