summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-05-23 20:52:54 +0000
committerDaniel Bermond2020-05-23 20:52:54 +0000
commitc138378420c03c3e681dd80443413826606396e4 (patch)
tree8dc5f0ecb9eb4fe4f6f07af2a176bf1fbb433d5c
parent8a81cfe3ea444781871bbb17d5126c100dadd2c7 (diff)
downloadaur-c138378420c03c3e681dd80443413826606396e4.tar.gz
Update patches to match upstream changes
-rw-r--r--.SRCINFO9
-rw-r--r--010-m64p-git-remove-build-jobs-limitation.patch17
-rw-r--r--020-m64p-git-enable-optimizations.patch11
-rw-r--r--PKGBUILD10
4 files changed, 23 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbd72f346259..82ef84e23ea3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = m64p-git
pkgdesc = Mupen64Plus with custom plugins and Qt5 GUI (git version)
- pkgver = r116.ge3d55a6
+ pkgver = r136.ga89a751
pkgrel = 1
url = https://m64p.github.io/
arch = x86_64
@@ -24,13 +24,12 @@ pkgbase = m64p-git
depends = zlib
depends = hicolor-icon-theme
provides = m64p
- provides = mupen64plus
provides = mupen64plus-gui
provides = mupenplus-video-gliden64
conflicts = m64p
- conflicts = mupen64plus
conflicts = mupen64plus-gui
conflicts = mupenplus-video-gliden64
+ conflicts = mupen64plus
source = git+https://github.com/loganmc10/m64p.git
source = git+https://github.com/m64p/mupen64plus-gui.git
source = git+https://github.com/m64p/mupen64plus-audio-sdl2.git
@@ -50,8 +49,8 @@ pkgbase = m64p-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 6871b495ace8a9005d93ce3e9103a15111a67793812dd5158072c981c4c3a5a8
- sha256sums = a999739626fc3e9d0102b65014c436bf4e9039587ccac174334672f3925f4495
+ sha256sums = 9241207664cd3338ae38d02f30f7ae0f3e06c3593a50548d46bca6505181b5c2
+ sha256sums = bfd5ba0be1090bdf3460ff9e3794f79e88320e4417359f06380f7c48da241985
sha256sums = 8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808
pkgname = m64p-git
diff --git a/010-m64p-git-remove-build-jobs-limitation.patch b/010-m64p-git-remove-build-jobs-limitation.patch
index c1c7c831fa2b..50b99b5430bf 100644
--- a/010-m64p-git-remove-build-jobs-limitation.patch
+++ b/010-m64p-git-remove-build-jobs-limitation.patch
@@ -1,12 +1,11 @@
-diff -Naurp a/build.sh b/build.sh
---- a/build.sh 2020-04-24 14:06:44.000000000 +0000
-+++ b/build.sh 2020-04-24 14:10:40.693877444 +0000
+--- a/build.sh
++++ b/build.sh
@@ -19,22 +19,22 @@ mkdir -p $install_dir
base_dir=$PWD
cd $base_dir/mupen64plus-core/projects/unix
--make OSD=0 NO_ASM=1 -j4 all
-+make OSD=0 NO_ASM=1 all
+-make NETPLAY=1 OSD=0 NO_ASM=1 -j4 all
++make NETPLAY=1 OSD=0 NO_ASM=1 all
cp -P $base_dir/mupen64plus-core/projects/unix/*$suffix* $install_dir
cp $base_dir/mupen64plus-core/data/* $install_dir
@@ -28,7 +27,7 @@ diff -Naurp a/build.sh b/build.sh
if [[ $UNAME == *"MINGW"* ]]; then
cp $base_dir/mupen64plus-input-qt/build/release/mupen64plus-input-qt.dll $install_dir
else
-@@ -42,13 +42,13 @@ else
+@@ -42,7 +42,7 @@ else
fi
cd $base_dir/mupen64plus-audio-sdl2/projects/unix
@@ -36,6 +35,8 @@ diff -Naurp a/build.sh b/build.sh
+make all
cp $base_dir/mupen64plus-audio-sdl2/projects/unix/*$suffix $install_dir
+ cd $base_dir
+@@ -61,7 +61,7 @@ fi
mkdir -p $base_dir/mupen64plus-gui/build
cd $base_dir/mupen64plus-gui/build
qmake ../mupen64plus-gui.pro
@@ -44,7 +45,7 @@ diff -Naurp a/build.sh b/build.sh
if [[ $UNAME == *"MINGW"* ]]; then
cp $base_dir/mupen64plus-gui/build/release/mupen64plus-gui.exe $install_dir
else
-@@ -62,7 +62,7 @@ cd $base_dir/GLideN64/src/GLideNUI
+@@ -75,7 +75,7 @@ cd $base_dir/GLideN64/src/GLideNUI
mkdir -p build
cd build
qmake ../GLideNUI.pro
@@ -53,7 +54,7 @@ diff -Naurp a/build.sh b/build.sh
cd $base_dir/GLideN64/projects/cmake
if [[ $UNAME == *"MINGW"* ]]; then
-@@ -70,7 +70,7 @@ if [[ $UNAME == *"MINGW"* ]]; then
+@@ -83,7 +83,7 @@ if [[ $UNAME == *"MINGW"* ]]; then
else
cmake -DNOHQ=On -DVEC4_OPT=On -DCRC_OPT=On -DMUPENPLUSAPI=On ../../src/
fi
diff --git a/020-m64p-git-enable-optimizations.patch b/020-m64p-git-enable-optimizations.patch
index 19bfd75673a9..9069af83aff5 100644
--- a/020-m64p-git-enable-optimizations.patch
+++ b/020-m64p-git-enable-optimizations.patch
@@ -1,16 +1,15 @@
-diff -Naurp a/build.sh b/build.sh
---- a/build.sh 2020-04-24 14:10:40.000000000 +0000
-+++ b/build.sh 2020-04-24 14:13:14.231642044 +0000
+--- a/build.sh
++++ b/build.sh
@@ -19,7 +19,7 @@ mkdir -p $install_dir
base_dir=$PWD
cd $base_dir/mupen64plus-core/projects/unix
--make OSD=0 NO_ASM=1 all
-+make all
+-make NETPLAY=1 OSD=0 NO_ASM=1 all
++make NETPLAY=1 all
cp -P $base_dir/mupen64plus-core/projects/unix/*$suffix* $install_dir
cp $base_dir/mupen64plus-core/data/* $install_dir
-@@ -66,9 +66,9 @@ make
+@@ -79,9 +79,9 @@ make
cd $base_dir/GLideN64/projects/cmake
if [[ $UNAME == *"MINGW"* ]]; then
diff --git a/PKGBUILD b/PKGBUILD
index 15f4df737689..14cc453ec8e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=m64p-git
-pkgver=r116.ge3d55a6
+pkgver=r136.ga89a751
pkgrel=1
pkgdesc='Mupen64Plus with custom plugins and Qt5 GUI (git version)'
arch=('x86_64')
@@ -11,8 +11,8 @@ depends=('freetype2' 'glu' 'hidapi' 'libgl' 'libpng' 'libsamplerate'
'minizip' 'p7zip' 'qt5-base' 'qt5-websockets' 'sdl2' 'sdl2_net'
'zlib' 'hicolor-icon-theme')
makedepends=('git' 'cmake' 'nasm' 'icoutils')
-provides=('m64p' 'mupen64plus' 'mupen64plus-gui' 'mupenplus-video-gliden64')
-conflicts=('m64p' 'mupen64plus' 'mupen64plus-gui' 'mupenplus-video-gliden64')
+provides=('m64p' 'mupen64plus-gui' 'mupenplus-video-gliden64')
+conflicts=('m64p' 'mupen64plus-gui' 'mupenplus-video-gliden64' 'mupen64plus')
source=('git+https://github.com/loganmc10/m64p.git'
'git+https://github.com/m64p/mupen64plus-gui.git'
'git+https://github.com/m64p/mupen64plus-audio-sdl2.git'
@@ -32,8 +32,8 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '6871b495ace8a9005d93ce3e9103a15111a67793812dd5158072c981c4c3a5a8'
- 'a999739626fc3e9d0102b65014c436bf4e9039587ccac174334672f3925f4495'
+ '9241207664cd3338ae38d02f30f7ae0f3e06c3593a50548d46bca6505181b5c2'
+ 'bfd5ba0be1090bdf3460ff9e3794f79e88320e4417359f06380f7c48da241985'
'8df4e8076d28a1bc44f41b0129a9935da9839e8a8cb9944206757e47da561808')
prepare() {