summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPGPereira2015-06-08 10:57:58 -0300
committerPGPereira2015-06-08 10:57:58 -0300
commit23f81286feb880025b464759e7557260ca782334 (patch)
treeecb5f68a50a4e245f8686b59e2e499e7b8b22cbe
downloadaur-23f81286feb880025b464759e7557260ca782334.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD18
-rw-r--r--m64py.install11
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da9a75019c16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = m64py
+ pkgdesc = QT5 front-end for Mupen64Plus in Python
+ pkgver = 0.2.3
+ pkgrel = 4
+ url = http://m64py.sourceforge.net
+ install = m64py.install
+ arch = any
+ license = GPL
+ makedepends = python-distribute
+ depends = mupen64plus
+ depends = sdl2
+ depends = python-pyqt5
+ depends = desktop-file-utils
+ source = http://downloads.sourceforge.net/m64py/m64py-0.2.3.tar.gz
+ md5sums = 170c980bb4266162cb61a931f529a8b2
+
+pkgname = m64py
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ace104fdaa63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Pedro Gabriel (pedrogabriel@dcc.ufmg.br)
+pkgname=m64py
+pkgver=0.2.3
+pkgrel=4
+pkgdesc="QT5 front-end for Mupen64Plus in Python"
+arch=("any")
+url="http://m64py.sourceforge.net"
+license=("GPL")
+depends=(mupen64plus sdl2 python-pyqt5 desktop-file-utils)
+makedepends=(python-distribute)
+install='m64py.install'
+source=("http://downloads.sourceforge.net/m64py/m64py-${pkgver}.tar.gz")
+md5sums=('170c980bb4266162cb61a931f529a8b2')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --optimize=1 --prefix=/usr --root="${pkgdir}/"
+}
diff --git a/m64py.install b/m64py.install
new file mode 100644
index 000000000000..547006ec14ec
--- /dev/null
+++ b/m64py.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ update-desktop-database -q
+}
+
+post_remove() {
+ update-desktop-database -q
+}