summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2018-03-20 11:33:33 -0500
committerfrealgagu2018-03-20 11:33:33 -0500
commitfda7fd524da35ac36e94f51facecc93c66cdb1aa (patch)
treeb881aee531169e6544aef1f98016b03b4897d6ba
parent0ec8aa268bd3af67bc36bcc553afea8bb3a9fc72 (diff)
downloadaur-fda7fd524da35ac36e94f51facecc93c66cdb1aa.tar.gz
Using github url and using sha256sum instead of md5sum
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
-rw-r--r--m64py.install6
3 files changed, 20 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61a07c443c8c..628a72293fda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = m64py
- pkgdesc = QT5 front-end for Mupen64Plus in Python
+ pkgdesc = M64Py is a Qt5 front-end (GUI) for Mupen64Plus, a cross-platform plugin-based Nintendo 64 emulator
pkgver = 0.2.4
- pkgrel = 2
- url = http://m64py.sourceforge.net
+ pkgrel = 3
+ url = https://github.com/mupen64plus/mupen64plus-ui-python
install = m64py.install
arch = any
license = GPL
makedepends = python-distribute
+ depends = desktop-file-utils
+ depends = libxkbcommon-x11
depends = mupen64plus
- depends = sdl2
depends = python-pyqt5
depends = python-pysdl2
- depends = desktop-file-utils
- depends = libxkbcommon-x11
+ depends = sdl2
source = https://github.com/mupen64plus/mupen64plus-ui-python/releases/download/0.2.4/m64py-0.2.4.tar.gz
- md5sums = 5710db43f238ec4527634d69d9bacf0b
+ sha256sums = 38c175587f6bb1984586584f27faad72ac3db7fed4bbbbdf26b3c75bfd0a6ce4
pkgname = m64py
diff --git a/PKGBUILD b/PKGBUILD
index 754662cf839d..2878403a0824 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: Fredy GarcĂ­a (frealgagu@gmail.com)
# Contributor: Pedro Gabriel (pedrogabriel@dcc.ufmg.br)
# Contributor: cookiengineer
+
pkgname=m64py
pkgver=0.2.4
-pkgrel=2
-pkgdesc="QT5 front-end for Mupen64Plus in Python"
+pkgrel=3
+pkgdesc="M64Py is a Qt5 front-end (GUI) for Mupen64Plus, a cross-platform plugin-based Nintendo 64 emulator"
arch=("any")
-url="http://m64py.sourceforge.net"
+url="https://github.com/mupen64plus/mupen64plus-ui-python"
license=("GPL")
-depends=(mupen64plus sdl2 python-pyqt5 python-pysdl2 desktop-file-utils libxkbcommon-x11)
-makedepends=(python-distribute)
-install='m64py.install'
-source=("https://github.com/mupen64plus/mupen64plus-ui-python/releases/download/${pkgver}/m64py-${pkgver}.tar.gz")
-md5sums=('5710db43f238ec4527634d69d9bacf0b')
+depends=("desktop-file-utils" "libxkbcommon-x11" "mupen64plus" "python-pyqt5" "python-pysdl2" "sdl2")
+makedepends=("python-distribute")
+install="${pkgname}.install"
+source=("https://github.com/mupen64plus/mupen64plus-ui-python/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=("38c175587f6bb1984586584f27faad72ac3db7fed4bbbbdf26b3c75bfd0a6ce4")
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py install --optimize=1 --prefix=/usr --root="${pkgdir}/"
}
diff --git a/m64py.install b/m64py.install
index 547006ec14ec..80312d4a6041 100644
--- a/m64py.install
+++ b/m64py.install
@@ -1,11 +1,11 @@
post_install() {
- update-desktop-database -q
+ update-desktop-database -q
}
post_upgrade() {
- update-desktop-database -q
+ update-desktop-database -q
}
post_remove() {
- update-desktop-database -q
+ update-desktop-database -q
}