summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebRmv2019-11-04 16:53:35 +0100
committerSebRmv2019-11-04 16:53:38 +0100
commit1f43541821a6d05b7c860ca6925c2b5bc23d4a08 (patch)
treeb2b9d53bb73008d8586bd8d495b7c595ee93dfda
parentc688bc3405e5e0350aaf9dc5f5a3b10db69eedee (diff)
downloadaur-1f43541821a6d05b7c860ca6925c2b5bc23d4a08.tar.gz
Fix build.
Apply workaround found there: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=90677
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--pretty-print.h.patch12
3 files changed, 19 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7f1e935f98a..e9e1ada72e1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = m68k-atari-mint-gcc
pkgdesc = The GNU Compiler Collection for the Motorola M68000 architecture
pkgver = 4.6.4
- pkgrel = 10
+ pkgrel = 11
url = http://www.gnu.org/software/gcc/
arch = i686
arch = x86_64
@@ -25,9 +25,11 @@ pkgbase = m68k-atari-mint-gcc
source = ftp://ftp.gnu.org/gnu/gcc/gcc-4.6.4/gcc-4.6.4.tar.bz2
source = gcc-4.6.4-mint-20130415.patch.bz2
source = cfns.h.patch
+ source = pretty-print.h.patch
sha1sums = 63933a8a5cf725626585dbba993c8b0f6db1335d
sha1sums = bd2e88f2b862cc404f47144fb67375b1fe17291b
sha1sums = 0c9f81040e112c27434fbb11c7214fb799e3507d
+ sha1sums = 206ea7130b2608b77c3c2c1ea655d557fcd21026
pkgname = m68k-atari-mint-gcc
diff --git a/PKGBUILD b/PKGBUILD
index e1714bc698b9..a3dd009d957c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=m68k-atari-mint-gcc
_pkgname=gcc
_target="m68k-atari-mint"
pkgver=4.6.4
-pkgrel=10
+pkgrel=11
pkgdesc="The GNU Compiler Collection for the Motorola M68000 architecture"
url="http://www.gnu.org/software/gcc/"
arch=('i686' 'x86_64')
@@ -15,8 +15,8 @@ replaces=('cross-m68k-atari-mint-gcc')
provides=('m68k-atari-mint-gcc-core')
conflicts=('cross-m68k-atari-mint-gcc' 'cross-m68k-atari-mint-gcc-core' 'm68k-atari-mint-gcc-core')
options=('!ccache' '!distcc' '!emptydirs' '!libtool' '!strip' 'staticlibs')
-source=("ftp://ftp.gnu.org/gnu/gcc/gcc-${pkgver}/${_pkgname}-${pkgver}.tar.bz2" "gcc-4.6.4-mint-20130415.patch.bz2" "cfns.h.patch")
-sha1sums=('63933a8a5cf725626585dbba993c8b0f6db1335d' 'bd2e88f2b862cc404f47144fb67375b1fe17291b' '0c9f81040e112c27434fbb11c7214fb799e3507d')
+source=("ftp://ftp.gnu.org/gnu/gcc/gcc-${pkgver}/${_pkgname}-${pkgver}.tar.bz2" "gcc-4.6.4-mint-20130415.patch.bz2" "cfns.h.patch" "pretty-print.h.patch")
+sha1sums=('63933a8a5cf725626585dbba993c8b0f6db1335d' 'bd2e88f2b862cc404f47144fb67375b1fe17291b' '0c9f81040e112c27434fbb11c7214fb799e3507d' '206ea7130b2608b77c3c2c1ea655d557fcd21026')
_sysroot="/usr/lib/${_target}"
@@ -25,7 +25,7 @@ prepare() {
patch -Np1 < ../gcc-4.6.4-mint-20130415.patch
patch -p0 < ../cfns.h.patch
-
+ patch -p0 < ../pretty-print.h.patch
# alternatively, we could download mpfr/mpc/gmp with this command
# ./contrib/download_prerequisites || return 1
}
diff --git a/pretty-print.h.patch b/pretty-print.h.patch
new file mode 100644
index 000000000000..29c2cd12c403
--- /dev/null
+++ b/pretty-print.h.patch
@@ -0,0 +1,12 @@
+--- gcc/pretty-print.h
++++ gcc/pretty-print.h
+@@ -305,8 +305,8 @@ extern void pp_base_append_text (pretty_printer *, const char *, const char *);
+
+ /* This header may be included before diagnostics-core.h, hence the duplicate
+ definitions to allow for GCC-specific formats. */
+-#if GCC_VERSION >= 3005
++#if (GCC_VERSION >= 3005) && (GCC_VERSION != 9001) && (GCC_VERSION != 9002) /* 9.1.0 is buggy: https://gcc.gnu.org/PR90677 */
+ #define ATTRIBUTE_GCC_PPDIAG(m, n) __attribute__ ((__format__ (__gcc_diag__, m ,n))) ATTRIBUTE_NONNULL(m)
+ #else
+ #define ATTRIBUTE_GCC_PPDIAG(m, n) ATTRIBUTE_NONNULL(m)
+