summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesus Alonso2019-02-18 15:29:25 +0100
committerJesus Alonso2019-02-18 15:29:59 +0100
commit24413efd0b96681450a5ee7e0334039f300a54e1 (patch)
tree175f83085ae2b9c9d3490e9afd92fa57aa182220
parent1b928399487c0045fadb16bf86bc6a6210f7dd2f (diff)
downloadaur-24413efd0b96681450a5ee7e0334039f300a54e1.tar.gz
Worked around compilation bug with isl 0.20
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--isl_includes.patch10
3 files changed, 19 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc04f75ba592..4462201b2c26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = m68k-elf-gcc-bootstrap
pkgdesc = The GNU Compiler Collection. Bootstrap for toolchain building (m68k-elf)
pkgver = 8.2.0
- pkgrel = 2
+ pkgrel = 3
url = http://gcc.gnu.org
arch = i686
arch = x86_64
@@ -22,6 +22,7 @@ pkgbase = m68k-elf-gcc-bootstrap
source = http://ftp.gnu.org/gnu/mpc/mpc-1.1.0.tar.gz.sig
source = http://ftp.gnu.org/gnu/gmp/gmp-6.1.2.tar.xz
source = http://ftp.gnu.org/gnu/gmp/gmp-6.1.2.tar.xz.sig
+ source = isl_includes.patch
validpgpkeys = 33C235A34C46AA3FFB293709A328C3A2C3C45C06
validpgpkeys = 07F3DBBECC1A39605078094D980C197698C3739D
validpgpkeys = AD17A21EF8AED8F1CC02DBD9F7D5C9BF765C61E3
@@ -34,6 +35,7 @@ pkgbase = m68k-elf-gcc-bootstrap
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 395891a9c064908a3d08b312f59dc7244f8a36134de30abad81a707541c173e3
pkgname = m68k-elf-gcc-bootstrap
diff --git a/PKGBUILD b/PKGBUILD
index a3cbbdcf91ca..4e39ddf1a42b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ pkgver=8.2.0
_mpfrver=4.0.1
_mpcver=1.1.0
_gmpver=6.1.2
-pkgrel=2
+pkgrel=3
pkgdesc="The GNU Compiler Collection. Bootstrap for toolchain building (${_target})"
arch=('i686' 'x86_64')
license=('GPL' 'LGPL' 'FDL' 'custom')
@@ -27,10 +27,12 @@ source=("http://ftp.gnu.org/gnu/gcc/gcc-${pkgver}/gcc-${pkgver}.tar.xz"
"http://ftp.gnu.org/gnu/mpc/mpc-${_mpcver}.tar.gz"
"http://ftp.gnu.org/gnu/mpc/mpc-${_mpcver}.tar.gz.sig"
"http://ftp.gnu.org/gnu/gmp/gmp-${_gmpver}.tar.xz"
- "http://ftp.gnu.org/gnu/gmp/gmp-${_gmpver}.tar.xz.sig")
+ "http://ftp.gnu.org/gnu/gmp/gmp-${_gmpver}.tar.xz.sig"
+ "isl_includes.patch")
-sha256sums=(SKIP SKIP SKIP SKIP SKIP SKIP SKIP SKIP)
+sha256sums=(SKIP SKIP SKIP SKIP SKIP SKIP SKIP SKIP
+ 395891a9c064908a3d08b312f59dc7244f8a36134de30abad81a707541c173e3)
validpgpkeys=(33C235A34C46AA3FFB293709A328C3A2C3C45C06
07F3DBBECC1A39605078094D980C197698C3739D
AD17A21EF8AED8F1CC02DBD9F7D5C9BF765C61E3
@@ -38,6 +40,7 @@ validpgpkeys=(33C235A34C46AA3FFB293709A328C3A2C3C45C06
prepare() {
cd ${srcdir}/gcc-${pkgver}
+ patch -p1 < ${srcdir}/isl_includes.patch
# symlinks for in-tree build
ln -s ../mpfr-${_mpfrver}
diff --git a/isl_includes.patch b/isl_includes.patch
new file mode 100644
index 000000000000..c1bd0a2a15ee
--- /dev/null
+++ b/isl_includes.patch
@@ -0,0 +1,10 @@
+--- .../gcc/graphite.h 2018-01-03 11:03:58.000000000 +0000
++++ .../gcc/graphite.h 2018-07-29 17:42:55.836121000 +0000
+@@ -37,6 +37,8 @@
+ #include <isl/schedule.h>
+ #include <isl/ast_build.h>
+ #include <isl/schedule_node.h>
++#include <isl/id.h>
++#include <isl/space.h>
+
+ typedef struct poly_dr *poly_dr_p;