summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordoragasu2021-10-09 17:02:40 +0200
committerdoragasu2021-10-09 17:02:40 +0200
commit4166fe732d25026dee25707a575cb396044fe1db (patch)
tree25bf8060b2c8de64f85ac96cb0f5f52963794a6e
parentb0ee1d848f53b157238e59cd48227b27bebdc02b (diff)
downloadaur-4166fe732d25026dee25707a575cb396044fe1db.tar.gz
Update to version 11.2.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 670263701928..854135cb7ac5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = m68k-elf-gcc-bootstrap
pkgdesc = The GNU Compiler Collection. Bootstrap for toolchain building (m68k-elf)
- pkgver = 10.2.0
+ pkgver = 11.2.0
pkgrel = 1
url = http://gcc.gnu.org
arch = i686
@@ -15,8 +15,8 @@ pkgbase = m68k-elf-gcc-bootstrap
options = !emptydirs
options = !distcc
options = !strip
- source = http://ftp.gnu.org/gnu/gcc/gcc-10.2.0/gcc-10.2.0.tar.xz
- source = http://ftp.gnu.org/gnu/gcc/gcc-10.2.0/gcc-10.2.0.tar.xz.sig
+ source = http://ftp.gnu.org/gnu/gcc/gcc-11.2.0/gcc-11.2.0.tar.xz
+ source = http://ftp.gnu.org/gnu/gcc/gcc-11.2.0/gcc-11.2.0.tar.xz.sig
source = http://ftp.gnu.org/gnu/mpfr/mpfr-4.1.0.tar.xz
source = http://ftp.gnu.org/gnu/mpfr/mpfr-4.1.0.tar.xz.sig
source = http://ftp.gnu.org/gnu/mpc/mpc-1.2.1.tar.gz
@@ -37,4 +37,3 @@ pkgbase = m68k-elf-gcc-bootstrap
sha256sums = SKIP
pkgname = m68k-elf-gcc-bootstrap
-
diff --git a/PKGBUILD b/PKGBUILD
index c5519a25bccd..f8ef2edd370f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_target=m68k-elf
_target_cpu=m68000
pkgname=${_target}-gcc-bootstrap
-pkgver=10.2.0
+pkgver=11.2.0
_mpfrver=4.1.0
_mpcver=1.2.1
_gmpver=6.2.1
@@ -52,6 +52,10 @@ prepare() {
}
build() {
+ # GCC cannot be built with -Werror=format-security
+ export CFLAGS=${CFLAGS//-Werror=format-security/}
+ export CXXFLAGS=${CXXFLAGS//-Werror=format-security/}
+
cd ${srcdir}/gcc-build
../gcc-${pkgver}/configure --prefix=/usr \