summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoe2016-01-31 23:27:22 +0100
committerzoe2016-01-31 23:27:22 +0100
commitddf93130310c78bc188167c6c53563ef89546603 (patch)
treee16b3e440138c992cf118f342591206fab24933f
downloadaur-ddf93130310c78bc188167c6c53563ef89546603.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD30
-rw-r--r--mac-port.install13
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f288396b5f2f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Sun Jan 31 22:26:16 UTC 2016
+pkgbase = mac-port
+ pkgdesc = Monkey's Audio lossless audio codec - shntool patched
+ pkgver = 3.99.u4.b5.s7
+ pkgrel = 2
+ url = http://etree.org/shnutils/shntool/support/formats/ape/unix/
+ install = mac-port.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = gcc
+ makedepends = yasm
+ depends = gcc-libs
+ provides = mac
+ conflicts = mac
+ source = http://www.etree.org/shnutils/shntool/support/formats/ape/unix/3.99-u4-b5-s7/mac-3.99-u4-b5-s7.tar.gz
+ source = mac-port.install
+ md5sums = 74df3c96476636387ddd12255b03bebe
+ md5sums = 5a3e002cb925128f8c49738724c6233a
+
+pkgname = mac-port
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..692b7277a929
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: zoe <chp321 AT gmail DOT com>
+pkgname=mac-port
+_shnver="s7"
+pkgver=3.99.u4.b5.s7
+pkgrel=2
+pkgdesc="Monkey's Audio lossless audio codec - shntool patched"
+arch=('i686' 'x86_64')
+url="http://etree.org/shnutils/shntool/support/formats/ape/unix/"
+license="unknown"
+depends=('gcc-libs')
+makedepends=('gcc' 'yasm')
+optdepends=()
+provides=('mac')
+conflicts=('mac')
+install=('mac-port.install')
+source=("http://www.etree.org/shnutils/shntool/support/formats/ape/unix/3.99-u4-b5-${_shnver}/mac-3.99-u4-b5-${_shnver}.tar.gz"
+ 'mac-port.install')
+md5sums=('74df3c96476636387ddd12255b03bebe'
+ '5a3e002cb925128f8c49738724c6233a')
+
+build() {
+ cd ${srcdir}/mac-3.99-u4-b5-${_shnver}/
+ CXXFLAGS="-DSHNTOOL" ./configure --prefix="/usr" --enable-assembly="yes" || return 1
+ make || return 1
+}
+
+package() {
+ cd ${srcdir}/mac-3.99-u4-b5-${_shnver}/
+ make DESTDIR=${pkgdir} install || return 1
+}
diff --git a/mac-port.install b/mac-port.install
new file mode 100644
index 000000000000..e6dded1f7234
--- /dev/null
+++ b/mac-port.install
@@ -0,0 +1,13 @@
+post_install() {
+ cat <<-EndOfMessage
+ This software has a very strange license which is incompatible
+ with GPL. You should carefully consider if you want to use this.
+ The license can be read here:
+ http://www.monkeysaudio.com/license.html
+ EndOfMessage
+ /bin/true
+}
+
+post_upgrade() {
+ post_install
+} \ No newline at end of file