summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoricepie2022-03-17 02:26:05 +0800
committericepie2022-03-17 02:26:05 +0800
commita66a404c722df109b9e442357bd991ab65ba6d1d (patch)
tree6d832cf2f3430cb025de70f538867d6f411bf9f1
parentbd1f7e1182229d5f8695b59bc1ce73f2a6dd87ec (diff)
downloadaur-macast-git.tar.gz
0.7.r21.g8f9d99d
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD32
-rw-r--r--macast.desktop4
3 files changed, 28 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index febb81f92361..a8e68153e33e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,12 @@
pkgbase = macast-git
pkgdesc = DLNA Media Renderer
- pkgver = 0.7
- pkgrel = 2
+ pkgver = 0.7.r21.g8f9d99d
+ pkgrel = 1
url = https://github.com/xfangfang/Macast
arch = any
license = GPL3
+ makedepends = git
+ makedepends = python-pip
makedepends = python-setuptools
depends = python
depends = python-appdirs
@@ -15,11 +17,13 @@ pkgbase = macast-git
depends = python-pyperclip
depends = python-cherrypy
depends = python-netifaces
+ depends = python-urllib3
depends = mpv
+ provides = macast
conflicts = macast
source = git+https://github.com/xfangfang/Macast.git#branch=dev
source = macast.desktop
sha256sums = SKIP
- sha256sums = 3191dfa7386d63a24be335cf4d61c7c0229237160b94183f324d9e852617cfc5
+ sha256sums = c63974af877e5d22a80d1d473dc155f403069d35a3793f6e2cb61f9be0a3d481
pkgname = macast-git
diff --git a/PKGBUILD b/PKGBUILD
index 6c47551c4318..8e5c088c47b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,15 @@
_pkgname=macast
_gitname=Macast
pkgname=${_pkgname}-git
-pkgver=0.7
-pkgrel=2
+pkgver=0.7.r21.g8f9d99d
+pkgrel=1
pkgdesc="DLNA Media Renderer"
arch=('any')
url="https://github.com/xfangfang/Macast"
license=('GPL3')
+provides=('macast')
conflicts=('macast')
-makedepends=('python-setuptools')
+makedepends=('git' 'python-pip' 'python-setuptools')
depends=(
'python'
'python-appdirs'
@@ -21,24 +22,29 @@ depends=(
'python-pyperclip'
'python-cherrypy'
'python-netifaces'
+ 'python-urllib3'
'mpv'
)
source=(
"git+${url}.git#branch=dev"
"${_pkgname}.desktop"
)
-sha256sums=(
- 'SKIP'
- '3191dfa7386d63a24be335cf4d61c7c0229237160b94183f324d9e852617cfc5'
-)
+sha256sums=('SKIP'
+ 'c63974af877e5d22a80d1d473dc155f403069d35a3793f6e2cb61f9be0a3d481')
+
+pkgver() {
+ cd "${_gitname}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${_gitname}"
+ python setup.py build
+}
package() {
cd "${_gitname}"
- install -d "${pkgdir}/usr/share/icons"
- cp "${_pkgname}/assets/icon.png" "${pkgdir}/usr/share/icons/Macast.png"
- install -d "${pkgdir}/usr/share/applications"
- # Install desktop file
- mkdir -p "${pkgdir}/usr/share/applications"
+ install -D "${_pkgname}/assets/icon.png" "${pkgdir}/usr/share/icons/macast.png"
install -Dm644 "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
- python setup.py install --root="${pkgdir}" --optimize=1
+ python setup.py install --optimize=1 --prefix=/usr --root="${pkgdir}"
}
diff --git a/macast.desktop b/macast.desktop
index fcba48802622..dea0d4a17bbe 100644
--- a/macast.desktop
+++ b/macast.desktop
@@ -2,7 +2,7 @@
Name=Macast
Comment=DLNA Media Renderer
Exec=/usr/bin/macast-gui
-Icon=/usr/share/icons/Macast.png
+Icon=macast
Terminal=false
Type=Application
-Categories=Video;AudioVideo; \ No newline at end of file
+Categories=Video;AudioVideo;