summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTea2021-08-23 01:44:02 +0800
committerTea2021-08-23 01:44:02 +0800
commit63e1eee0a5fc2d623ca2c1e59a38dcb4ea686dbb (patch)
treedfcc70a0e003bd2834d94845f5d8f86059c2b4d5
downloadaur-63e1eee0a5fc2d623ca2c1e59a38dcb4ea686dbb.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD47
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f153f864693f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = macast-git
+ pkgdesc = DLNA Media Renderer
+ pkgver = r105.4815a2c
+ pkgrel = 1
+ url = https://github.com/xfangfang/Macast
+ arch = any
+ license = GPL3
+ depends = python
+ depends = python-pillow
+ depends = python-pystray
+ depends = python-lxml
+ depends = python-pyperclip
+ depends = python-cherrypy
+ depends = mpv
+ conflicts = macast
+ source = git+https://github.com/xfangfang/Macast.git
+ sha256sums = SKIP
+
+pkgname = macast-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ed93cf61095
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: icepie, icepie.dev@gmail.com
+
+_pkgname=macast
+__pkgname=Macast
+pkgname=${_pkgname}-git
+pkgver=r105.4815a2c
+pkgrel=1
+pkgdesc="DLNA Media Renderer"
+arch=('any')
+url="https://github.com/xfangfang/Macast"
+license=('GPL3')
+conflicts=('macast')
+depends=(
+ 'python'
+ 'python-pillow'
+ 'python-pystray'
+ 'python-lxml'
+ 'python-pyperclip'
+ 'python-cherrypy'
+ 'mpv'
+ )
+source=(git+"${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$__pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${__pkgname}"
+ echo '{}' > macast_setting.json
+ echo -e '#! /bin/bash\ncd "/opt/Macast/" && python Macast.py || exit 1' > macast.sh
+ #python setup.py build
+}
+
+package() {
+ install -d "${pkgdir}/opt/${__pkgname}"
+ cp -r "${__pkgname}" "${pkgdir}/opt/"
+ install -d "${pkgdir}/usr/share/icons"
+ cp "${__pkgname}"/assets/icon.png "${pkgdir}/usr/share/icons/Macast.png"
+ install -d "${pkgdir}/usr/share/applications"
+ echo -e "[Desktop Entry]\nName=Macast\nComment=DLNA Media Renderer\nExec=/usr/bin/macast\nIcon=/usr/share/icons/Macast.png\nTerminal=false\nType=Application\nCategories=Video" > "${pkgdir}/usr/share/applications/macast.desktop"
+ install -m 777 "${__pkgname}"/macast_setting.json "${pkgdir}/opt/${__pkgname}/macast_setting.json"
+ install -d "${pkgdir}/usr/bin"
+ install -m 755 "${__pkgname}"/macast.sh "${pkgdir}/usr/bin/macast"
+} \ No newline at end of file