summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoost Bremmer2016-09-05 19:37:24 +0200
committerJoost Bremmer2016-09-05 19:37:24 +0200
commitfdcb03c2dc6bd6eda709388953e0587d7428f428 (patch)
tree099e0ce02542cad1527a0d365f5fe1cb20c00596
parent2d072ec7ed8a68836dee709904316475fa79f34b (diff)
downloadaur-fdcb03c2dc6bd6eda709388953e0587d7428f428.tar.gz
update pkg: mackup 0.8.14-4
Add Python3 string patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--mackup.patch2
3 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d90403a4708..d1c309fb8c2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,7 @@ pkgbase = mackup
source = https://github.com/lra/mackup/archive/0.8.14.tar.gz
source = mackup.patch
sha256sums = d8b7c2f2d1650b132ca31035e625ee436a7b4ff9a9948119cf3f370fc3b17d22
- sha256sums = 63c8066854f138a73eef8b2e43b13d83f729b5f6428bdf3c9d19c98206c0676c
+ sha256sums = 752a2dbd06fb212f8632cc2ddbcc7e3d90c733093ad8a0f4c9615dc9b3926650
pkgname = mackup
diff --git a/PKGBUILD b/PKGBUILD
index 44f37f8e3789..c43f781061b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ makedepends=(
source=("https://github.com/lra/${pkgname}/archive/${pkgver}.tar.gz"
"${pkgname}.patch")
sha256sums=('d8b7c2f2d1650b132ca31035e625ee436a7b4ff9a9948119cf3f370fc3b17d22'
- '63c8066854f138a73eef8b2e43b13d83f729b5f6428bdf3c9d19c98206c0676c')
+ '752a2dbd06fb212f8632cc2ddbcc7e3d90c733093ad8a0f4c9615dc9b3926650')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/mackup.patch b/mackup.patch
index 15c01994f383..c1751ce5f743 100644
--- a/mackup.patch
+++ b/mackup.patch
@@ -3,7 +3,7 @@ index 97f140e..81a6044 100644
--- a/mackup/config.py
+++ b/mackup/config.py
@@ -220,7 +220,7 @@ class Config(object):
-
+
# Python 2 and python 3 byte strings are different.
if sys.version_info[0] < 3:
- path = str(path)