summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Neumann2018-09-17 09:44:36 +0200
committerRichard Neumann2018-09-17 09:44:36 +0200
commit7fcefd642505a7844f9c7ec7b73665d6c589c335 (patch)
tree5dbe55a4b59634711a3c144128aa28dd6da5a54e
downloadaur-7fcefd642505a7844f9c7ec7b73665d6c589c335.tar.gz
init
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD53
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d9abb0fd16a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = macreg-git
+ pkgdesc = Python 3 library and scripts for the RCON and Query protocol
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/coNQP/macreg
+ arch = any
+ license = GPLv3
+ makedepends = git
+ makedepends = python
+ depends = python
+ depends = python-peewee
+ depends = python-peeweeplus
+ depends = python-flask
+ depends = python-httpam
+ depends = uwsgi-plugin-python
+ depends = python-pymysql
+ provides = python-macreg
+ conflicts = python-macreg
+ source = macreg::git+https://github.com/coNQP/macreg.git
+ md5sums = SKIP
+
+pkgname = macreg-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c1d3ea405e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Richard Neumann aka. schard <mail at richard dash neumann period de>
+
+_pkgbase='macreg'
+pkgname="${_pkgbase}-git"
+pkgver=latest
+pkgrel=1
+pkgdesc='Python 3 library and scripts for the RCON and Query protocol'
+arch=('any')
+url="https://github.com/coNQP/${_pkgbase}"
+license=('GPLv3')
+depends=(
+ 'python'
+ 'python-peewee'
+ 'python-peeweeplus'
+ 'python-flask'
+ 'python-httpam'
+ 'uwsgi-plugin-python'
+ 'python-pymysql')
+makedepends=('git' 'python')
+provides=("python-${_pkgbase}")
+conflicts=("python-${_pkgbase}")
+source=("${_pkgbase}::git+${url}.git")
+md5sums=('SKIP')
+pkgdir='pkg'
+srcdir='src'
+
+
+pkgver() {
+ cd "${_pkgbase}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "${srcdir}/${_pkgbase}"
+
+ # Install python back end.
+ pushd "backend" || exit 1
+ python setup.py install --root "${pkgdir}" --optimize=1
+ local SYSUSERS="${pkgdir}/usr/lib/sysusers.d"
+ install -m 755 -d "${SYSUSERS}"
+ install -m 644 -t "${SYSUSERS}" macreg.conf
+ local UWSGI="${pkgdir}/etc/uwsgi"
+ install -m 755 -d "${UWSGI}"
+ install -m 644 -t "${UWSGI}" macreg.ini
+ popd || exit 1
+
+ # Install HML front end.
+ local FRONTEND="${pkgdir}/usr/share/webapps/macreg"
+ install -m 755 -d "${FRONTEND}"
+ pushd "frontend" || exit 1
+ install -m 644 -t "${FRONTEND}" ./*
+}