summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorqothr2016-10-22 04:19:38 +0900
committerqothr2016-10-22 04:19:38 +0900
commit1bc963bbb275f78cf530e68d96ac63189353bb49 (patch)
tree8b779c113d46e6acc441340668c603a541645883
downloadaur-1bc963bbb275f78cf530e68d96ac63189353bb49.tar.gz
initial
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d45c0861357
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Oct 21 19:18:49 UTC 2016
+pkgbase = macrodown-git
+ pkgdesc = The translator for Macrodown, a markup language wrapping other markup languages such as TeX/LaTeX or HTML.
+ pkgver = 1.0g.r87.g1e904b1
+ pkgrel = 1
+ url = https://github.com/gfngfn/Macrodown
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = make
+ depends = ocaml
+ provides = macrodown
+ conflicts = macrodown
+ source = git+https://github.com/gfngfn/Macrodown.git
+ md5sums = SKIP
+
+pkgname = macrodown-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c383dfa0687
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: yuhr <sdn.pate(at)gmail.com>
+
+pkgname=macrodown-git
+pkgver=1.0g.r87.g1e904b1
+pkgrel=1
+pkgdesc="The translator for Macrodown, a markup language wrapping other markup languages such as TeX/LaTeX or HTML."
+url="https://github.com/gfngfn/Macrodown"
+license=('MIT')
+arch=('i686' 'x86_64')
+conflicts=('macrodown')
+provides=('macrodown')
+makedepends=('git')
+depends=('make' 'ocaml')
+source=('git+https://github.com/gfngfn/Macrodown.git')
+md5sums=(SKIP)
+
+pkgver() {
+ cd ${srcdir}/Macrodown
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/^v//'
+}
+
+package() {
+ cd ${srcdir}/Macrodown
+ make
+ install -dm755 "${pkgdir}"/usr/bin
+ install -m644 ./bin/macrodown "${pkgdir}"/usr/bin/
+
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
+}