summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lass2015-06-08 20:52:22 +0200
committerMichael Lass2015-06-08 20:52:22 +0200
commitf99af289c3c90f5bf0fe6eab804572ead27e8b15 (patch)
treee4a22be0580158e0d436818489c79530afbfe855
downloadaur-f99af289c3c90f5bf0fe6eab804572ead27e8b15.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
-rw-r--r--macrofusion.install11
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abaded1ccdde
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = macrofusion
+ pkgdesc = GUI to combine photos to get deeper DOF or HDR
+ pkgver = 0.7.4
+ pkgrel = 4
+ url = http://sourceforge.net/projects/macrofusion/
+ install = macrofusion.install
+ arch = any
+ license = GPL
+ depends = python-cairo
+ depends = python-gobject
+ depends = python-pillow
+ depends = perl-image-exiftool
+ depends = enblend-enfuse
+ depends = hugin
+ depends = libgexiv2
+ source = http://downloads.sourceforge.net/project/macrofusion/macrofusion-0.7.4/macrofusion_0.7.4.orig.tar.gz
+ sha256sums = 2d061f0a2e858c86ae700351cf9785bc7058938e02ce6fcf40b192fbb0b60b11
+
+pkgname = macrofusion
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc544b298a7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Michael Lass <bevan@bi-co.net>
+# Contributor: graysky <graysky AT archlinux DOT us>
+# Contributor: Zuf <kontakt.zuf(at)gmail.com>
+
+# This PKGBUILD is maintained on github:
+# https://github.com/michaellass/AUR
+
+pkgname=macrofusion
+pkgver=0.7.4
+pkgrel=4
+pkgdesc="GUI to combine photos to get deeper DOF or HDR"
+url="http://sourceforge.net/projects/macrofusion/"
+depends=('python-cairo' 'python-gobject' 'python-pillow' 'perl-image-exiftool' 'enblend-enfuse' 'hugin' 'libgexiv2')
+arch=('any')
+source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}-${pkgver}/${pkgname}_${pkgver}.orig.tar.gz")
+license=('GPL')
+install=$pkgname.install
+sha256sums=('2d061f0a2e858c86ae700351cf9785bc7058938e02ce6fcf40b192fbb0b60b11')
+
+package() {
+ # Installation is a bit tricky. See README and parts of the python script to see
+ # where everything should go to. A makefile would have been nice.
+
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ # install ui descriptions
+ install -dm755 $pkgdir/usr/share/mfusion/ui
+ install -Dm644 ui/* $pkgdir/usr/share/mfusion/ui/
+
+ # images have to be split up manually. Irghs...
+ install -Dm644 images/logoSplash.png $pkgdir/usr/share/mfusion/images/logoSplash.png
+ install -Dm644 images/$pkgname.png $pkgdir/usr/share/pixmaps/$pkgname.png
+
+ # actual python script and desktop file
+ install -Dm755 $pkgname.py $pkgdir/usr/bin/$pkgname
+ install -Dm644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+
+ # for some languages there is localization available
+ for locale in locale/*; do
+ install -dm755 $pkgdir/usr/share/$locale/LC_MESSAGES
+ install -Dm644 $locale/LC_MESSAGES/* $pkgdir/usr/share/$locale/LC_MESSAGES/
+ done
+}
diff --git a/macrofusion.install b/macrofusion.install
new file mode 100644
index 000000000000..b8ce831574df
--- /dev/null
+++ b/macrofusion.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_remove() {
+ post_install
+}
+
+post_upgrade() {
+ post_install
+}