summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2019-02-17 23:22:03 -0500
committerTony Lambiris2019-02-17 23:22:03 -0500
commit123d2b805b3f390caa7a985dca3647946ff7ca00 (patch)
tree47ecb0c8cb0539ff786fd1e2ea7bf1754395281e
downloadaur-123d2b805b3f390caa7a985dca3647946ff7ca00.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD51
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..174306db5e89
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = macterial-theme-git
+ pkgdesc = A mac inspired Gtk+ theme based on Material design
+ pkgver = 26.4311b24
+ pkgrel = 1
+ url = https://github.com/mythio/macterial
+ arch = any
+ license = GPL
+ source = macterial::git+https://github.com/mythio/macterial.git
+ sha256sums = SKIP
+
+pkgname = macterial-theme-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6281bceda836
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src
+pkg
+tags
+macterial
+*pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..becc01b6eb7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Tony Lambiris <tony@criticalstack.com>
+
+pkgname=macterial-theme-git
+_pkgname=macterial
+pkgver=26.4311b24
+pkgrel=1
+pkgdesc="A mac inspired Gtk+ theme based on Material design"
+arch=("any")
+url="https://github.com/mythio/${_pkgname}"
+license=('GPL')
+source=("${_pkgname}::git+https://github.com/mythio/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ export THEME_FONT_FACE="${THEME_FONT_FACE:-Sans-Serif}"
+ export THEME_FONT_SIZE="${THEME_FONT_SIZE:-9}"
+
+ msg2 "To customize the font and size for gnome-shell, build this package"
+ msg2 "with the variables below set to the desired font family and size"
+ msg2 "- THEME_FONT_FACE (default font family is Sans-Serif)"
+ msg2 "- THEME_FONT_SIZE (default font point size is 9)"
+ msg2 ""
+ msg2 "Continuing build in 5 seconds..."; sleep 5
+ msg2 "Setting gnome-shell font face to ${THEME_FONT_FACE}"
+ msg2 "Setting gnome-shell font size to ${THEME_FONT_SIZE}"
+
+ if [ "${THEME_FONT_FACE}" != "Sans-Serif" ]; then
+ sed -i -re "s/font-family: (.*);/font-family: ${THEME_FONT_FACE}, \1;/" \
+ "${srcdir}/${_pkgname}/gnome-shell/gnome-shell.css"
+ fi
+
+ if [ "${THEME_FONT_SIZE}" != "9" ]; then
+ sed -i -re "s/font-size: (.*);/font-size: ${THEME_FONT_SIZE}pt;/" \
+ "${srcdir}/${_pkgname}/gnome-shell/gnome-shell.css"
+ fi
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ mkdir -p "${pkgdir}/usr/share/themes/${_pkgname}"
+ cp -a "${srcdir}/${_pkgname}/"* "${pkgdir}/usr/share/themes/${_pkgname}/"
+}