summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2021-06-10 03:00:13 -0400
committerTony Lambiris2021-06-10 03:00:13 -0400
commit9902b007acfde4b6612e36cc5081e75b48dc3e62 (patch)
treebb92c6dc88c32581b38837cdc7b12e1fe668bd26
parentd16fa078aad5209da5ebf1c014d9a2a490b363c1 (diff)
downloadaur-9902b007acfde4b6612e36cc5081e75b48dc3e62.tar.gz
Version bump and updates
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fd45a408c8e..938ef5e5f712 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = macterial-theme-git
pkgdesc = A mac inspired Gtk+ theme based on Material design
- pkgver = r47.95c184c
+ pkgver = v2.3.1.r15.g95c184c
pkgrel = 1
url = https://github.com/mythio/macterial
arch = any
license = GPL
+ makedepends = git
source = macterial::git+https://github.com/mythio/macterial.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 48a6b5086d29..83df3ca07b5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,20 @@
pkgname=macterial-theme-git
_pkgname=macterial
-pkgver=r47.95c184c
+pkgver=v2.3.1.r15.g95c184c
pkgrel=1
pkgdesc="A mac inspired Gtk+ theme based on Material design"
arch=("any")
url="https://github.com/mythio/${_pkgname}"
license=('GPL')
+makedepends=('git')
source=("${_pkgname}::git+https://github.com/mythio/${_pkgname}.git")
sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {