summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2020-02-16 15:18:59 -0500
committerGI_Jack2020-02-16 15:18:59 -0500
commitfb1519a7b71bb03ed248d724bc6fe3042b34f8e5 (patch)
tree4274037eec421c907e43efeb63ec9dff0649e8c8
parent27fc63b611a350b9b37d9301303e0c5983a0fa51 (diff)
downloadaur-fb1519a7b71bb03ed248d724bc6fe3042b34f8e5.tar.gz
exploitdb added upstream, bumped version
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 249dd06d96a6..0f6dcd8bdbbb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = mad-metasploit-git
pkgdesc = A Collection of Metasploit Plugins, Modules and Scripts
- pkgver = r125.61eed15
- pkgrel = 2
+ pkgver = r178.0ebe2c0
+ pkgrel = 1
url = https://www.hahwul.com/p/mad-metasploit.html
arch = any
license = MIT
makedepends = git
depends = ruby
depends = metasploit
+ optdepends = exploitdb: db_exploit plugin
provides = mad-metasploit
conflicts = mad-metasploit
source = mad-metasploit::git+https://github.com/hahwul/mad-metasploit.git
diff --git a/PKGBUILD b/PKGBUILD
index 93a6a0881609..f16930ccf84e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,25 @@
pkgbase=mad-metasploit-git
pkgname=(mad-metasploit-git mad-metasploit-archive-git)
_pkgname=mad-metasploit
-pkgver=r125.61eed15
-pkgrel=2
+pkgver=r178.0ebe2c0
+pkgrel=1
pkgdesc="A Collection of Metasploit Plugins, Modules and Scripts"
arch=('any')
url="https://www.hahwul.com/p/mad-metasploit.html"
license=('MIT')
depends=('ruby' 'metasploit')
makedepends=('git')
-#optdepends=(
+optdepends=(
# "arachni-scanner: arachni web scanner plugin" # This used to have a seriously broken PKGBUILD
-# "searchsploit: db_exploit plugin" # Broken Link
-#)
+ "exploitdb: db_exploit plugin"
+)
provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("${_pkgname}::git+https://github.com/hahwul/mad-metasploit.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_pkgname}"
# Git, no tags available
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}