summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryingchangliu2023-11-13 20:17:18 +0800
committeryingchangliu2023-11-13 20:17:18 +0800
commit62fa844692a079e2bb5b95876a3dcaa5f45cae72 (patch)
treeb37f2df08cab76beaabc4774811a77987711874e
parentd737c4427c8a8582fec3abaefae9fae9051654b8 (diff)
downloadaur-62fa844692a079e2bb5b95876a3dcaa5f45cae72.tar.gz
add c++ and fortran api, and give users write permission to share/madagascar for repeatable test
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a131773243a..ef51da2088a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = madagascar-git
pkgdesc = Multidimensional data analysis and reproducible computational experiments.
pkgver = r15659.d72996857
- pkgrel = 1
+ pkgrel = 2
url = https://www.reproducibility.org/wiki/Main_Page
arch = i686
arch = x86_64
@@ -21,8 +21,8 @@ pkgbase = madagascar-git
depends = suitesparse
depends = cblas
depends = scons
+ depends = plplot
optdepends = cuda: for nvcc, but not compatible with cuda12
- optdepends = plplot: scientific plot
options = strip
source = madagascar-git::git+https://github.com/ahay/src
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d349a002e707..5e33acd2602d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: Yingchang Liu
pkgname=madagascar-git
pkgver=r15659.d72996857
-pkgrel=1
+pkgrel=2
pkgdesc="Multidimensional data analysis and reproducible computational experiments."
url="https://www.reproducibility.org/wiki/Main_Page"
license=('GPL2')
arch=('i686' 'x86_64')
depends=('libtirpc' 'ffmpeg' 'libxaw' 'cairo' 'fftw' 'netpbm' 'gd' 'swig' 'python-numpy'
- 'openmpi' 'glu' 'freeglut' 'suitesparse' 'cblas' 'scons')
-optdepends=('cuda: for nvcc, but not compatible with cuda12' 'plplot: scientific plot')
+ 'openmpi' 'glu' 'freeglut' 'suitesparse' 'cblas' 'scons' 'plplot')
+optdepends=('cuda: for nvcc, but not compatible with cuda12')
options=('strip')
source=($pkgname::git+https://github.com/ahay/src)
md5sums=('SKIP')
@@ -23,7 +23,8 @@ build() {
mkdir -p ${srcdir}/${pkgname}
cd ${srcdir}/${pkgname}
export RSFROOT=${pkgdir}/opt/${pkgname}
-
+ # hide hwang's src which can not be compiled.
+ mv ./user/hwang ./user/.hwang
# fix paths for tirpc in framework/configure.py
sed -i '430,433c\
(plat['\''distro'\''\] == '\''centos'\'' and int(plat['\''version'\''\][0]) >= 8) or \\\
@@ -31,7 +32,7 @@ build() {
plat['\''distro'\''\] == '\''arch'\'' or \\\
(plat['\''distro'\''\] == '\''ubuntu'\'' and int(plat['\''version'\''\][:2]) >= 20): \ \
context.env['\''CPPPATH'\''\] = path_get(context,'\''CPPPATH'\'','\''/usr/include/tirpc'\'')' framework/configure.py
- ./configure
+ ./configure API=c++,f90
make
}
@@ -41,12 +42,14 @@ package() {
export PATH=${RSFROOT}/bin:$PATH
cd ${srcdir}/${pkgname}
make install
-
- cp -r ${srcdir}/${pkgname} ${pkgdir}/opt/${pkgname}/src
-
+
+ cp -r ${srcdir}/${pkgname} ${RSFROOT}/src
+ rm -r ${RSFROOT}/src/.git
+
+ chmod a+w ${RSFROOT}/share/madagascar
# add a symlink to rsfcodes in /opt, so that it can be compiled by user
- ln -s ${srcdir}/${pkgname} ${pkgdir}/opt/${pkgname}/rsfcodes
- chmod 755 ${pkgdir}/opt/${pkgname}/rsfcodes
+ # ln -s ${srcdir}/${pkgname} ${RSFROOT}/rsfcodes
+ # chmod -R 755 ${RSFROOT}/rsfcodes
# fix paths in in files
arr[0]="/share/madagascar/etc/config.py"