aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSoc Virnyl S. Estela2021-04-05 20:19:32 +0800
committerSoc Virnyl S. Estela2021-04-05 20:19:32 +0800
commita0e08b60143ecf5a7243303404c8380273cb8100 (patch)
tree6048b78697917060ce3ef5ee49d65259d53e5b47
parent7c0eed14cab80760f32b5f54a3f179ce1e46b112 (diff)
downloadaur-a0e08b60143ecf5a7243303404c8380273cb8100.tar.gz
Update PKGBUILD and patches
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--mg5_configuration.patch24
3 files changed, 22 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5cd8ac5b4ed0..58e40df02ca5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = madgraph
pkgdesc = MadGraph5_aMC@NLO is a framework that aims at providing all the elements necessary for SM and BSM phenomenology
- pkgver = 2.7.0
+ pkgver = 3.1.0
pkgrel = 1
url = https://launchpad.net/mg5amcnlo
arch = i686
@@ -19,11 +19,9 @@ pkgbase = madgraph
optdepends = madgraph-pythia-pgs
optdepends = madgraph-pythia8-interface
options = !strip
- source = https://launchpad.net/mg5amcnlo/2.0/2.7.x/+download/MG5_aMC_v2.7.0.tar.gz
- source = python2.patch
+ source = https://launchpad.net/mg5amcnlo/3.0/3.1.x/+download/MG5_aMC_v3.1.0.tar.gz
source = mg5_configuration.patch
- sha256sums = 67001eecb5e8fc712eea5e1c1d016cd407db7d0c06f48c80610d4ae664341e4e
- sha256sums = 7f698c8c8ae934098fb3a736a93175d0428473090e01517a68e9e6231742d24d
+ sha256sums = ea14cf6daa5b6c53dba1455c086e762cb8042d342451c9b88b2bde81098bf264
sha256sums = a251d1bc6be29032c051cde8b0d050330b4777ff94fea6df5a495a9506c4eadc
pkgname = madgraph
diff --git a/PKGBUILD b/PKGBUILD
index 11b055125702..1b83f736e08b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: JP-Ellis <josh@jpellis.me>
pkgname=madgraph
-pkgver=2.7.0
+pkgver=3.1.0
_major=${pkgver%%.*}
_minor=${pkgver#2.}
_minor=${_minor%%.*}
@@ -27,18 +27,14 @@ optdepends=(
'madgraph-pythia-pgs'
'madgraph-pythia8-interface'
)
-source=("https://launchpad.net/mg5amcnlo/${_major}.0/${_major}.${_minor}.x/+download/MG5_aMC_v${pkgver}.tar.gz"
- "python2.patch"
- "mg5_configuration.patch")
-sha256sums=('67001eecb5e8fc712eea5e1c1d016cd407db7d0c06f48c80610d4ae664341e4e'
- '7f698c8c8ae934098fb3a736a93175d0428473090e01517a68e9e6231742d24d'
+source=("https://launchpad.net/mg5amcnlo/${_major}.0/${_major}.1.x/+download/MG5_aMC_v${pkgver}.tar.gz"
+"mg5_configuration.patch"
+ )
+sha256sums=('ea14cf6daa5b6c53dba1455c086e762cb8042d342451c9b88b2bde81098bf264'
'a251d1bc6be29032c051cde8b0d050330b4777ff94fea6df5a495a9506c4eadc')
options=("!strip")
prepare() {
- msg2 "Fixing python references for python2"
- patch -p 1 -d $_dirname < python2.patch
-
msg2 "Extracting documentation"
cd "${srcdir}/${_dirname}"
tar xf doc.tgz
@@ -54,7 +50,7 @@ prepare() {
build() {
msg2 "Compiling python source files"
- python2 -O -m compileall -qf "${srcdir}/${_dirname}" 2>&1 1>/dev/null || true
+ python3 -O -m compileall -qf "${srcdir}/${_dirname}" 2>&1 1>/dev/null || true
msg2 "Initialize MG5 first run"
# MadGraph needs to generate `Template/LO/Source/make_opts` which is done
@@ -67,6 +63,7 @@ build() {
msg2 "Updating configuration file"
patch -p 1 -d $_dirname < mg5_configuration.patch
+
}
package() {
diff --git a/mg5_configuration.patch b/mg5_configuration.patch
index 7e0f21016ee6..ee70ae7d56fc 100644
--- a/mg5_configuration.patch
+++ b/mg5_configuration.patch
@@ -1,7 +1,6 @@
-diff --git a/input/mg5_configuration.txt b/input/mg5_configuration.txt
---- a/input/mg5_configuration.txt
-+++ b/input/mg5_configuration.txt
-@@ -45,11 +45,11 @@
+--- mg5_configuration.txt.orig 2021-03-30 05:50:51.000000000 +0800
++++ mg5_configuration.txt 2021-04-05 20:13:07.400120146 +0800
+@@ -46,11 +46,11 @@
#! Prefered WebBrower
#! If None: try to find one available on the system
@@ -15,7 +14,7 @@ diff --git a/input/mg5_configuration.txt b/input/mg5_configuration.txt
#! Time allowed to answer question (if no answer takes default value)
#! 0: No time limit
-@@ -59,14 +59,14 @@
+@@ -60,14 +60,14 @@
#! Defines the path to the pythia8 installation directory (i.e. the
#! on containing the lib, bin and include directories) .
#! If using a relative path, that starts from the mg5 directory
@@ -32,7 +31,7 @@ diff --git a/input/mg5_configuration.txt b/input/mg5_configuration.txt
#! Herwig++/Herwig7 paths
#! specify here the paths also to HepMC ant ThePEG
-@@ -75,14 +75,14 @@
+@@ -76,14 +76,14 @@
#! WARNING: if Herwig7 has been installed with the bootstrap script,
#! then please set thepeg_path and hepmc_path to the same value as
#! hwpp_path
@@ -51,7 +50,7 @@ diff --git a/input/mg5_configuration.txt b/input/mg5_configuration.txt
################################################################################
# INFO FOR MADEVENT / aMC@NLO
-@@ -136,19 +136,19 @@
+@@ -137,19 +137,19 @@
#! Pythia-PGS Package
#! relative path start from main directory
@@ -75,17 +74,18 @@ diff --git a/input/mg5_configuration.txt b/input/mg5_configuration.txt
#! ExRootAnalysis Package
#! relative path start from main directory
-@@ -157,15 +157,15 @@
+@@ -158,16 +158,16 @@
#! TOPDRAWER PATH
#! Path to the directory containing td executables
#! relative path start from main directory
-# td_path = ./td
+td_path = td
- #! lhapdf-config
+ #! lhapdf-config --can be specify differently depending of your python version
#! If None: try to find one available on the system
--# lhapdf = lhapdf-config
-+lhapdf = lhapdf-config
+ # lhapdf_py2 = lhapdf-config
+-# lhapdf_py3 = lhapdf-config
++lhapdf_py3 = lhapdf-config
#! fastjet-config
#! If None: try to find one available on the system
@@ -94,7 +94,7 @@ diff --git a/input/mg5_configuration.txt b/input/mg5_configuration.txt
#! MCatNLO-utilities
#! relative path starting from main directory
-@@ -185,7 +185,7 @@
+@@ -187,7 +187,7 @@
#! if auto: try to find it automatically on the system (default)
#! if '' or None: disabling Golem95
#! if golem=/PATH/TO/golem/lib: use that speficif installation path for Golem95