aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2016-05-30 00:29:05 +1000
committerJP-Ellis2016-05-30 00:29:05 +1000
commitdd7cdd3b9471a54162f04489759ceee6b70b2654 (patch)
treebf32e9cedbd4b17af90a508925d600f66e3c81c1
downloadaur-dd7cdd3b9471a54162f04489759ceee6b70b2654.tar.gz
Initial commit.
Signed-off-by: JP-Ellis <josh@jpellis.me>
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD38
-rw-r--r--README.org3
4 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2610664a699
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun May 29 14:28:31 UTC 2016
+pkgbase = madgraph-madanalysis
+ pkgdesc = Parton showering, hadronization and detector simulation.
+ pkgver = 1.1.8
+ pkgrel = 20160521
+ url = http://madgraph.hep.uiuc.edu/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = gcc-fortran
+ depends = madgraph
+ depends = tcsh
+ depends = perl
+ optdepends = topdrawer
+ source = http://madgraph.hep.uiuc.edu/Downloads/MadAnalysis_V1.1.8.tar.gz
+ sha256sums = bdf26c4605927007b08f41eae12f218e2053297cfda518eb0e865af289e54ffc
+
+pkgname = madgraph-madanalysis
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5a0b20dfca92
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/MadAnalysis*.tar.gz
+/madgraph*.tar.xz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4af726531599
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: JP-Ellis <josh@jpellis.me>
+
+pkgname=madgraph-madanalysis
+pkgver=1.1.8
+pkgrel=20160521
+pkgdesc="Parton showering, hadronization and detector simulation."
+url="http://madgraph.hep.uiuc.edu/"
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=('madgraph' 'tcsh' 'perl')
+optdepends=('topdrawer')
+makedepends=('gcc-fortran')
+source=("http://madgraph.hep.uiuc.edu/Downloads/MadAnalysis_V${pkgver}.tar.gz")
+sha256sums=('bdf26c4605927007b08f41eae12f218e2053297cfda518eb0e865af289e54ffc')
+
+build () {
+ cd "${srcdir}/MadAnalysis"
+ make
+ find . -type f -name "*.o" | xargs rm -f
+}
+
+package() {
+ install -Dm755 "${srcdir}/MadAnalysis/combine-pl" "${pkgdir}/usr/bin/combine-pl"
+ rm "${srcdir}/MadAnalysis/combine-pl"
+ install -Dm755 "${srcdir}/MadAnalysis/epstosmth" "${pkgdir}/usr/bin/epstosmth"
+ rm "${srcdir}/MadAnalysis/epstosmth"
+ install -Dm755 "${srcdir}/MadAnalysis/plot_events" "${pkgdir}/usr/bin/plot_events"
+ rm "${srcdir}/MadAnalysis/plot_events"
+
+ mkdir -p "${pkgdir}/usr/share/madgraph/MadAnalysis"
+ cp -a "${srcdir}/MadAnalysis/." "${pkgdir}/usr/share/madgraph/MadAnalysis"
+
+ find "${pkgdir}/usr/share/" -type f -executable -print0 | xargs -0 chmod -x
+}
+
+# Local Variables:
+# mode: sh
+# End:
diff --git a/README.org b/README.org
new file mode 100644
index 000000000000..4d5b3f333acd
--- /dev/null
+++ b/README.org
@@ -0,0 +1,3 @@
+#+TITLE: madgraph-madanalysis [[https://aur.archlinux.org/packages/madgraph/][https://img.shields.io/aur/version/madgraph-madanalysis.svg]]
+
+MadGraph MadAnalysis bundled for installation on Arch Linux.