aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2016-09-29 13:12:50 +1000
committerJP-Ellis2016-09-29 13:14:33 +1000
commite53e5a0e19eff3e49d5280fcae1bbcc80cfa198f (patch)
tree307f2f143337ccdbc70ef7a53a499b2583528ce3
parenta52d6d436f5a67b156e970abfe20155253aceb5f (diff)
downloadaur-e53e5a0e19eff3e49d5280fcae1bbcc80cfa198f.tar.gz
Fix make clean
Make clean now removes `plot_events`, so we don't cleanup and instead just copy the desired files over. Also, `plot_events` needs to be under /usr/share/madgraph otherwise, MadGraph will think it is not installed. Signed-off-by: JP-Ellis <josh@jpellis.me>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 6 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f362a881169..6faa06682deb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Sep 28 02:49:07 UTC 2016
+# Thu Sep 29 03:14:28 UTC 2016
pkgbase = madgraph-madanalysis
pkgdesc = Parton showering, hadronization and detector simulation.
pkgver = 1.1.8
- pkgrel = 20160926
+ pkgrel = 20160929
url = http://madgraph.hep.uiuc.edu/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 178e3e859be4..efcb22f8010d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=madgraph-madanalysis
pkgver=1.1.8
-pkgrel=20160926
+pkgrel=20160929
pkgdesc="Parton showering, hadronization and detector simulation."
url="http://madgraph.hep.uiuc.edu/"
arch=('i686' 'x86_64')
@@ -16,21 +16,13 @@ sha256sums=('248bd3493f9dc4f566dd85c033754b3e7b631107ac2ad55f4793f0015bb31669')
build () {
cd "${srcdir}/MadAnalysis"
make
- make clean
}
package() {
- install -Dm755 "${srcdir}/MadAnalysis/combine-pl" "${pkgdir}/usr/bin/combine-pl"
- rm "${srcdir}/MadAnalysis/combine-pl"
- install -Dm755 "${srcdir}/MadAnalysis/epstosmth" "${pkgdir}/usr/bin/epstosmth"
- rm "${srcdir}/MadAnalysis/epstosmth"
- install -Dm755 "${srcdir}/MadAnalysis/plot_events" "${pkgdir}/usr/bin/plot_events"
- rm "${srcdir}/MadAnalysis/plot_events"
-
mkdir -p "${pkgdir}/usr/share/madgraph/MadAnalysis"
- cp -a "${srcdir}/MadAnalysis/." "${pkgdir}/usr/share/madgraph/MadAnalysis"
-
- find "${pkgdir}/usr/share/" -type f -executable -print0 | xargs -0 chmod -x
+ for f in "plot_events" "ma_card.dat" "MAVersion.txt" "README"; do
+ cp -a "${srcdir}/MadAnalysis/$f" "${pkgdir}/usr/share/madgraph/MadAnalysis/$f"
+ done
}
# Local Variables: