aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2017-03-17 17:00:47 +1100
committerJP-Ellis2017-03-17 17:09:09 +1100
commit0569789d1e94786e59636ccc682eef77bade3e51 (patch)
treec53a56a2219e96f0218a000e71bf33ce9bc1f6f4
downloadaur-0569789d1e94786e59636ccc682eef77bade3e51.tar.gz
Initial commit
Signed-off-by: JP-Ellis <josh@jpellis.me>
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD45
-rw-r--r--README.md10
-rw-r--r--python2.patch30
5 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05e81acebbbb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Mar 17 05:57:39 UTC 2017
+pkgbase = madgraph-pythia8-interface
+ pkgdesc = MadGraph5_aMC@NLO is a framework that aims at providing all the elements necessary for SM and BSM phenomenology
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://madgraph.hep.uiuc.edu/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = madgraph
+ depends = pythia8
+ depends = python2
+ options = !strip
+ source = http://madgraph.physics.illinois.edu/Downloads/MG5aMC_PY8_interface/MG5aMC_PY8_interface_V1.0.tar.gz
+ source = python2.patch
+ sha256sums = f99c4f0680dfc198533d8531659990f90ce3b18b82d2d219293f455b2777fb38
+ sha256sums = 632adc73e951df4341709adeafd3a7c72da1752f8af61037eae2b87a08ca9a64
+
+pkgname = madgraph-pythia8-interface
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6a2182ca82c4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+MG5aMC_PY8*.tar.gz
+*pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f371d6ffee8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: JP-Ellis <josh@jpellis.me>
+
+pkgname=madgraph-pythia8-interface
+pkgver=1.0
+pkgrel=1
+pkgdesc="MadGraph Pythia8 interface"
+url="http://madgraph.hep.uiuc.edu/"
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=(
+ 'hepmc'
+ 'madgraph'
+ 'pythia8'
+ 'python2'
+)
+source=("http://madgraph.physics.illinois.edu/Downloads/MG5aMC_PY8_interface/MG5aMC_PY8_interface_V${pkgver}.tar.gz"
+ "python2.patch")
+sha256sums=('f99c4f0680dfc198533d8531659990f90ce3b18b82d2d219293f455b2777fb38'
+ '632adc73e951df4341709adeafd3a7c72da1752f8af61037eae2b87a08ca9a64')
+
+prepare() {
+ msg2 "Fixing python references for python2"
+ patch -p 1 < python2.patch
+}
+
+build() {
+ ./compile.py --pythia8_makefile /usr /opt/madgraph
+}
+
+package() {
+ msg2 "Installing files"
+
+ destdir="${pkgdir}/opt/madgraph/pythia8-interface"
+ mkdir -p "${destdir}"
+ install -Dm755 "${srcdir}/MG5aMC_PY8_interface" "${destdir}/MG5aMC_PY8_interface"
+ install -Dm644 "${srcdir}/MG5AMC_VERSION_ON_INSTALL" "${destdir}/MG5AMC_VERSION_ON_INSTALL"
+ install -Dm644 "${srcdir}/PYTHIA8_VERSION_ON_INSTALL" "${destdir}/PYTHIA8_VERSION_ON_INSTALL"
+ install -Dm644 "${srcdir}/VERSION" "${destdir}/VERSION"
+ install -Dm644 "${srcdir}/MultiHist.h" "${destdir}/MultiHist.h"
+ install -Dm644 "${srcdir}/SyscalcVeto.h" "${destdir}/SyscalcVeto.h"
+}
+
+# Local Variables:
+# mode: sh
+# End:
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..bdd11c60f579
--- /dev/null
+++ b/README.md
@@ -0,0 +1,10 @@
+MadGraph Pythia8 Interface
+==========================
+
+[![AUR badge][AUR badge]][AUR]
+
+[MadGraph][homepage] Pythia8 Interface installer Arch Linux.
+
+[homepage]: https://launchpad.net/mg5amcnlo
+[AUR]: https://aur.archlinux.org/packages/madgraph-pythia8-interface/
+[AUR badge]: https://img.shields.io/aur/version/madgraph-pythia8-interface.svg
diff --git a/python2.patch b/python2.patch
new file mode 100644
index 000000000000..8e7c74acd929
--- /dev/null
+++ b/python2.patch
@@ -0,0 +1,30 @@
+diff --git a/compile.py b/compile.py
+index 43e92ff..c7c5db6 100755
+--- a/compile.py
++++ b/compile.py
+@@ -1,4 +1,4 @@
+-#! /usr/bin/env python
++#!/usr/bin/python2
+
+ import subprocess
+ import sys
+diff --git a/get_pythia8_version.py b/get_pythia8_version.py
+index ad71984..12774db 100755
+--- a/get_pythia8_version.py
++++ b/get_pythia8_version.py
+@@ -1,4 +1,4 @@
+-#! /usr/bin/env python
++#!/usr/bin/python2
+
+ import sys
+ import os
+diff --git a/make_tarball.py b/make_tarball.py
+index beae595..8f90224 100755
+--- a/make_tarball.py
++++ b/make_tarball.py
+@@ -1,4 +1,4 @@
+-#! /usr/bin/env python
++#!/usr/bin/python2
+
+ import tarfile
+ import os