summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault2018-06-13 23:00:49 -0400
committerDrew DeVault2018-06-13 23:00:49 -0400
commit0c3340eab0a522da50fd6bc510abf3d5fa13ea6d (patch)
treedad1888f24d1fda0a6f6bb9ea4d31fdf472285a5
downloadaur-0c3340eab0a522da50fd6bc510abf3d5fa13ea6d.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD26
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bee85ede5daf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = madonctl
+ pkgdesc = CLI client for the Mastodon social network API
+ pkgver = 2.3.1
+ pkgrel = 1
+ url = https://github.com/McKael/madonctl
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ makedepends = git
+ source = madonctl-2.3.1.tar.gz::https://github.com/McKael/madonctl/archive/v2.3.1.tar.gz
+ md5sums = c9c928b98b6d1a1ac27227ace0002edb
+
+pkgname = madonctl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9d440e8dc7fb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.tar.xz
+src/
+pkg/
+mako/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d697187c0b6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+_gopkgname='github.com/McKael/madonctl'
+
+pkgname=madonctl
+pkgver=2.3.1
+pkgrel=1
+pkgdesc='CLI client for the Mastodon social network API'
+arch=('x86_64')
+url='https://github.com/McKael/madonctl'
+license=('MIT')
+makedepends=('go' 'git')
+source=("$pkgname-$pkgver.tar.gz::https://$_gopkgname/archive/v$pkgver.tar.gz")
+md5sums=('c9c928b98b6d1a1ac27227ace0002edb')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ GOPATH=$(pwd) go get -d -v
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ GOPATH=$(pwd) go build -v -o "$srcdir"/madonctl
+}
+
+package() {
+ install -Dm755 "$srcdir"/madonctl "$pkgdir"/usr/bin/madonctl
+}