summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-26 13:27:22 +0800
committerzxp198210052024-02-26 13:27:22 +0800
commit6410438a9307f7463d6a168b8def12ccbd83340b (patch)
tree88dd2548f58b65381e20f15552272932d98e04c3
parent5b12890247a0405b656d7b8ff22e2d5149be1e4e (diff)
downloadaur-6410438a9307f7463d6a168b8def12ccbd83340b.tar.gz
fix errors
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
-rw-r--r--maduchat-frontend.sh9
3 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 004746a10862..0e6868916bda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = maduchat-frontend-bin
pkgdesc = A chat application which has a global chat, friend system, settings and lots of other features
pkgver = 1.2.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Madu-de/MaduChat
arch = aarch64
arch = armv7h
arch = x86_64
- license = AGPL3
+ license = AGPL-3.0-only
makedepends = gendesk
depends = electron26
+ depends = nodejs
provides = maduchat-frontend=1.2.1
conflicts = maduchat-frontend
source = maduchat-frontend.sh
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
source_aarch64 = maduchat-frontend-1.2.1-aarch64.zip::https://github.com/Madu-de/MaduChat/releases/download/v1.2.1/maduchat-frontend-1.2.1-linux-arm64.zip
sha256sums_aarch64 = 2325d628fc42a78a9ecd475b116c69a0c17b4d970ebe69dad83bc03c74797ffc
source_armv7h = maduchat-frontend-1.2.1-armv7h.zip::https://github.com/Madu-de/MaduChat/releases/download/v1.2.1/maduchat-frontend-1.2.1-linux-armv7l.zip
diff --git a/PKGBUILD b/PKGBUILD
index b1f31258de4a..aeddac9883f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=maduchat-frontend-bin
_pkgname=MaduChat
pkgver=1.2.1
_electronversion=26
-pkgrel=2
+pkgrel=3
pkgdesc="A chat application which has a global chat, friend system, settings and lots of other features"
url="https://github.com/Madu-de/MaduChat"
arch=(
@@ -11,11 +11,12 @@ arch=(
'armv7h'
'x86_64'
)
-license=('AGPL3')
+license=('AGPL-3.0-only')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
+ 'nodejs'
)
makedepends=(
'gendesk'
@@ -24,16 +25,16 @@ source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.zip::${url}/releases/download
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.zip::${url}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux-armv7l.zip")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.zip::${url}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux-x64.zip")
source=("${pkgname%-bin}.sh")
-sha256sums=('d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+sha256sums=('0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
sha256sums_aarch64=('2325d628fc42a78a9ecd475b116c69a0c17b4d970ebe69dad83bc03c74797ffc')
sha256sums_armv7h=('9820879bc6f104683b8a447f3b799260a7740144de219040cc4406c33b9793f5')
sha256sums_x86_64=('aa15825954e758f3e41e3cd2bc806cb7bf550c9c3f35eaff69820f6356ee163b')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app|g" \
+ -e "s|@runname@|app|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- gendesk -q -f -n --categories "Network" --name "${_pkgname}" --exec "${pkgname} %U"
+ gendesk -q -f -n --categories="Network" --name="${_pkgname}" --exec="${pkgname} %U"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/maduchat-frontend.sh b/maduchat-frontend.sh
index aacd8f895847..f9ced1432cfc 100644
--- a/maduchat-frontend.sh
+++ b/maduchat-frontend.sh
@@ -1,15 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file