summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-06-03 22:11:30 -0500
committerLuis Martinez2022-06-03 22:11:30 -0500
commitc223a27bbf7219bf5c95baf7711b800f3f8db065 (patch)
tree28add64c66200c2d0f7924b486c11d5c4bb2111b
parent9dca52335c5385a3e1ded7311ab5ea45942c9770 (diff)
downloadaur-c223a27bbf7219bf5c95baf7711b800f3f8db065.tar.gz
package update
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD55
2 files changed, 32 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 303a10086d35..3796210458d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,24 @@
pkgbase = maestral-qt-git
- pkgdesc = A Qt interface for the Maestral daemon
- pkgver = 1.4.4
+ pkgdesc = Qt interface for the Maestral daemon
+ pkgver = 1.6.3.r0.gf4f8030
pkgrel = 1
url = https://github.com/SamSchott/maestral-qt
arch = any
license = MIT
makedepends = git
- makedepends = python
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
makedepends = python-wheel
- depends = python-click>=7.1.1
- depends = python
- depends = maestral>=1.4.3
- depends = python-click>=7.1.1
+ depends = maestral>=1.6.3
+ depends = python-click
depends = python-markdown2
depends = python-packaging
- depends = python-pyqt5>=5.9
+ depends = python-pyqt6
optdepends = gnome-shell-extension-appindicator: Gnome integration
- provides = maestral-qt
+ provides = maestral-qt=1.6.3
conflicts = maestral-qt
- source = git+https://github.com/SamSchott/maestral-qt#branch=develop
- md5sums = SKIP
+ source = maestral-qt-git::git+https://github.com/SamSchott/maestral-qt
+ sha256sums = SKIP
pkgname = maestral-qt-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 1cb621c7ed75..df880a5b65b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,36 @@
-# Maintainer: Batuhan Baserdem <lastname dot firstname at gmail>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Batuhan Baserdem <lastname dot firstname at gmail>
-_name=maestral-qt
-
-pkgname="${_name}-git"
-provides=("${_name}")
-conflicts=("${_name}")
-pkgver=1.4.4
+pkgname=maestral-qt-git
+pkgver=1.6.3.r0.gf4f8030
pkgrel=1
-pkgdesc='A Qt interface for the Maestral daemon'
+pkgdesc='Qt interface for the Maestral daemon'
arch=('any')
-url="https://github.com/SamSchott/${_name}"
+url="https://github.com/SamSchott/maestral-qt"
license=('MIT')
-source=("git+${url}#branch=develop")
-makedepends=('git' 'python' 'python-setuptools' 'python-wheel')
-depends=(
- 'python-click>=7.1.1'
- 'python'
- 'maestral>=1.4.3'
- 'python-click>=7.1.1'
- 'python-markdown2'
- 'python-packaging'
- 'python-pyqt5>=5.9')
+depends=("maestral>=${pkgver%.r*}" 'python-click' 'python-markdown2' 'python-packaging' 'python-pyqt6')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
optdepends=('gnome-shell-extension-appindicator: Gnome integration')
-md5sums=('SKIP')
+provides=("${pkgname%-git}=${pkgver%.r*}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_name}"
- git describe --long --tags | sed 's|\([^-]*-g\)|r\1|;s|-|.|g;s|^v||g'
+ git -C "$pkgname" describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
}
build() {
- cd "${srcdir}/${_name}"
- python setup.py build
+ cd "$pkgname"
+ python -m build --wheel --no-isolation
}
package() {
- # Change into the source git directory
- cd "${srcdir}/${_name}"
-
- # Run python setup function
- python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
-
- # Install the licence
- install -Dm644 "${srcdir}/${_name}/LICENSE.txt" \
- "${pkgdir}/usr/share/licenses/${_name}/LICENSE"
+ cd "$pkgname"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s \
+ "$_site/maestral_qt-${pkgver%.r*}.dist-info/LICENSE.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}