summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteffen Weber2015-06-14 16:41:17 +0200
committerSteffen Weber2015-06-14 16:41:17 +0200
commitea62e57ff973a32d59689f721326220e49035c13 (patch)
treeb45d5af026479c3125fa90e4a6f5afedfdd9d10c
downloadaur-ea62e57ff973a32d59689f721326220e49035c13.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe67fde2de4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mafft
+ pkgdesc = Multiple alignment program for amino acid or nucleotide sequences
+ pkgver = 7.221
+ pkgrel = 1
+ url = http://mafft.cbrc.jp/alignment/software
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = ruby
+ source = http://mafft.cbrc.jp/alignment/software/mafft-7.221-with-extensions-src.tgz
+ md5sums = b1aad911e51024d631722a2e061ba215
+
+pkgname = mafft
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..189416488e0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Steffen Weber <-boenki-gmx-de->
+# Contributor: Mick Elliot <micke at sfu dot ca>
+
+pkgname=mafft
+pkgver=7.221
+pkgrel=1
+pkgdesc="Multiple alignment program for amino acid or nucleotide sequences"
+arch=('i686' 'x86_64')
+url="http://mafft.cbrc.jp/alignment/software"
+license=('custom')
+depends=('ruby')
+source=($url/$pkgname-$pkgver-with-extensions-src.tgz)
+md5sums=('b1aad911e51024d631722a2e061ba215')
+
+build() {
+ cd $pkgname-$pkgver-with-extensions/core
+ make clean
+ make -e PREFIX=/usr LIBDIR=/usr/lib/mafft
+
+ cd ../extensions
+ make clean
+ make -e PREFIX=/usr LIBDIR=/usr/lib/mafft
+}
+
+package() {
+ cd $pkgname-$pkgver-with-extensions/core
+ make PREFIX=$pkgdir/usr LIBDIR=$pkgdir/usr/lib/mafft install
+
+ cd ../extensions
+ make PREFIX=$pkgdir/usr LIBDIR=$pkgdir/usr/lib/mafft install
+
+ install -d $pkgdir/usr/share/licenses/mafft/
+ install -m644 ../license* $pkgdir/usr/share/licenses/mafft/
+
+ rm $pkgdir/usr/lib/mafft/*.1
+
+ ln -sf /usr/lib/mafft/mafft-profile $pkgdir/usr/bin
+ ln -sf /usr/lib/mafft/mafft-distance $pkgdir/usr/bin
+}