summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Greb2022-04-04 09:33:34 +0200
committerSven Greb2022-04-04 09:42:29 +0200
commit5d5b3e7d1641c457f45b1023d5a3dba95e32172b (patch)
treebf55cbc00f5853f5599677448471232171351214
parentc7c2d9079720b77290b2f72c70f7905c64e983ac (diff)
downloadaur-5d5b3e7d1641c457f45b1023d5a3dba95e32172b.tar.gz
Use the advanced syntax for the `source` field for the package file name
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1500a877b626..cfed0e057a3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,7 @@ pkgbase = mage
license = Apache
makedepends = git
makedepends = go-pie
- source = git+https://github.com/magefile/mage.git
+ source = mage::git+https://github.com/magefile/mage#tag=v1.13.0
sha256sums = SKIP
pkgname = mage
diff --git a/PKGBUILD b/PKGBUILD
index a247e1dc9030..5fe51a6e08b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,16 +11,15 @@ arch=("x86_64" "arm" "aarch64")
url="https://magefile.org"
license=("Apache")
makedepends=("git" "go-pie")
-source=("git+https://github.com/magefile/${pkgname}.git")
+# We're building from source to get metadata information for the binary, but using a stable version tag instead of
+# the latest commit since this is not a `-git` package.
+# See https://man.archlinux.org/man/PKGBUILD.5#USING_VCS_SOURCES for more information.
+source=("$pkgname::git+https://github.com/magefile/mage#tag=v$pkgver")
sha256sums=("SKIP")
build() {
cd "$pkgname"
- # We're building from source to get metadata information for the binary, but using a stable version tag instead of
- # the latest commit since this is not a `-git` package.
- git checkout "v$pkgver"
-
# mage is build with mage itself, therefore we simluate the execution of the provided `bootstrap.go` installation
# file that is recommended by the author.
# The file builds mage when mage itself is not installed on the target system yet and included metadata information