summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Greb2022-04-04 09:42:48 +0200
committerSven Greb2022-04-04 09:42:48 +0200
commit703e2b3291db447080c6209989060cc144da1dc6 (patch)
treef34296b1b3d610e93b2db2309ad6be414a82160e
parent469f93c9524cf49e5637ed01c05c83e4b54ac789 (diff)
downloadaur-703e2b3291db447080c6209989060cc144da1dc6.tar.gz
Release version 1.13.0-1
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cfed0e057a3c..0681b8cdae63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mage
pkgdesc = A Make/rake-like build tool using Go
- pkgver = 1.11.0
+ pkgver = 1.13.0
pkgrel = 1
url = https://magefile.org
arch = x86_64
@@ -13,4 +13,3 @@ pkgbase = mage
sha256sums = SKIP
pkgname = mage
-
diff --git a/PKGBUILD b/PKGBUILD
index a97f63d3afcb..1f70cc6c2de1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# This package is built according to the AUR Go packaging guidelines:
# https://wiki.archlinux.org/index.php/Go_package_guidelines
pkgname=mage
-pkgver=1.11.0
+pkgver=1.13.0
pkgrel=1
pkgdesc="A Make/rake-like build tool using Go"
arch=("x86_64" "arm" "aarch64")
@@ -27,9 +27,8 @@ build() {
#
# References:
# 1. https://github.com/magefile/mage/blob/bf7f17a5/bootstrap.go
- # 1. https://github.com/magefile/mage/blob/07afc7d2/magefile.go#L65
- # 2. https://github.com/magefile/mage/blob/07afc7d2/magefile.go#L103
- # 3. https://github.com/magefile/mage/blob/5bc3a8ab/.goreleaser.yml#L28
+ # 2. https://github.com/magefile/mage/blob/fd5011e/magefile.go#L67
+ # 3. https://github.com/magefile/mage/blob/fd5011e/magefile.go#L108
local build_date git_commit_hash git_tag
build_date=$(command date --rfc-3339=seconds)
git_commit_hash=$(git rev-parse --short HEAD)
@@ -38,6 +37,9 @@ build() {
git_tag="dev"
fi
+ # References:
+ # 1. https://github.com/magefile/mage/blob/fe9f9420/.goreleaser.yml#L27
+ # 2. https://github.com/magefile/mage/blob/fe9f9420/.goreleaser.yml#L10
export CGO_ENABLED=0
go build \
-trimpath \