summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJat2020-06-10 12:26:33 +0800
committerJat2020-06-10 12:39:21 +0800
commita676473c7321da6c49bd18ea1996ceea045986ff (patch)
tree8a6852f41f34d43e43b2f1fcef70896d9d1474d8
downloadaur-a676473c7321da6c49bd18ea1996ceea045986ff.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..afec7ca1270e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = magewell-pro-capture-dkms
+ pkgdesc = Driver for Magewell Pro Capture Family
+ pkgver = 1.3.0.4177_1
+ pkgrel = 1
+ url = https://www.magewell.com/downloads/pro-capture#/driver/linux-x86
+ arch = x86_64
+ license = unknown
+ depends = dkms
+ depends = alsa-lib
+ conflicts = magewell-pro-capture
+ source = magewell-pro-capture-1.3.0.4177_1.tar.gz::https://github.com/jat001/magewell-pro-capture/archive/1.3.0.4177_1.tar.gz
+ sha256sums = cd9de1d4a69fb4716eb443c41501fe0a37349e7601f02c7c3a33d91adb359551
+
+pkgname = magewell-pro-capture-dkms
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9968be2ab4de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jat <chat@jat.email>
+
+_pkgname=magewell-pro-capture
+pkgname=${_pkgname}-dkms
+pkgver=1.3.0.4177_1
+pkgrel=1
+pkgdesc='Driver for Magewell Pro Capture Family'
+arch=('x86_64')
+url='https://www.magewell.com/downloads/pro-capture#/driver/linux-x86'
+license=('unknown')
+conflicts=("${_pkgname}")
+depends=('dkms' 'alsa-lib')
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/jat001/${_pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('cd9de1d4a69fb4716eb443c41501fe0a37349e7601f02c7c3a33d91adb359551')
+
+package() {
+ destdir=${pkgdir}/usr/src/${_pkgname}-${pkgver}
+ cd ${_pkgname}-${pkgver}
+
+ install -Dm644 scripts/dkms.conf src/Makefile src/ProCaptureLib_64.lib -t ${destdir}
+ cp -r src/public src/sources ${destdir}
+
+ install -Dm644 src/res/* -t ${pkgdir}/usr/share/ProCapture/res
+
+ sed -i 's#/usr/local/share/ProCapture/src/res#/usr/share/ProCapture/res#g' scripts/ProCapture.conf
+ install -Dm644 scripts/ProCapture.conf -t ${pkgdir}/usr/lib/modprobe.d
+ install -Dm644 scripts/10-procatpure-event-dev.rules -t ${pkgdir}/usr/lib/udev/rules.d
+
+ install -Dm755 bin/mwcap-control_64 ${pkgdir}/usr/bin/mwcap-control
+ install -Dm755 bin/mwcap-info_64 ${pkgdir}/usr/bin/mwcap-info
+}