summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0fflineuser2024-11-18 14:55:00 +0100
committer0fflineuser2024-11-18 14:55:05 +0100
commitc36eae5b7b584cac29bf8081ac6bb74ee408a54b (patch)
tree116a04db6aafcf2e476fd3f2a57772453212a967
parentc124ac798d4453c19b17840bd6aa49b7700ec795 (diff)
downloadaur-c36eae5b7b584cac29bf8081ac6bb74ee408a54b.tar.gz
Added post install steps.
-rw-r--r--PKGBUILD5
-rw-r--r--magic-tape.install9
2 files changed, 14 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 279c6ffe1499..a732cd0ac384 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,6 +7,7 @@ arch=('x86_64')
url="https://gitlab.com/christosangel/magic-tape.git"
license=('GPL')
depends=('yt-dlp' 'bash>=4.2' 'curl' 'fzf' 'mpv' 'jq' 'xclip' 'dmenu' 'rofi')
+install=magic-tape.install
makedepends=('git')
optdepends=('kitty: Image Support' 'chafa: Image Support' 'ueberzug: Image Support' 'ueberzugpp: Image Support')
source=("${pkgname}::git+https://gitlab.com/christosangel/magic-tape.git")
@@ -19,5 +20,9 @@ pkgver() {
package() {
cd "$pkgname"
+ mkdir -p "$pkgdir/usr/share/magic-tape/"
+ cp -r png/ "$pkgdir/usr/share/magic-tape/"
+ install -Dm755 "magic-tape.conf" "$pkgdir/etc/magic-tape.conf"
install -Dm755 "magic-tape.sh" "$pkgdir/usr/bin/magic-tape.sh"
}
+
diff --git a/magic-tape.install b/magic-tape.install
new file mode 100644
index 000000000000..93beef3c5020
--- /dev/null
+++ b/magic-tape.install
@@ -0,0 +1,9 @@
+post_install(){
+ ## copy in required files. The script does not copy these over.
+ echo "For magic-tape.sh to function properly, you need to run these commands:"
+ echo "mkdir -p ~/.cache/magic-tape/history/ ~/.cache/magic-tape/jpg/ ~/.cache/magic-tape/json/ ~/.cache/magic-tape/search/video/ ~/.cache/magic-tape/comments/"
+ echo "mkdir -p ~/.cache/magic-tape/search/channels/ ~/.cache/magic-tape/subscriptions/jpg/ ~/.config/magic-tape/ ~/.local/share/magic-tape/"
+ echo "touch ~/.cache/magic-tape/history/watch_history.txt ~/.cache/magic-tape/subscriptions/subscriptions.txt"
+ echo "cp -r /usr/share/magic-tape/png/ ~/.local/share/magic-tape/"
+ echo "cp /etc/magic-tape.conf ~/.config/magic-tape/magic-tape.conf"
+}