summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStorm Dragon2018-11-03 15:18:19 -0400
committerStorm Dragon2018-11-03 15:18:19 -0400
commit4c60ebad766aa7b5f8928b9a483be47f29b7f8d7 (patch)
tree3fff89f54fbba1cfe9cf65332509b9583168bd25
parentdf5b0629b8783241014f68e32a8f4596d5f00882 (diff)
downloadaur-4c60ebad766aa7b5f8928b9a483be47f29b7f8d7.tar.gz
Now a split package providing python2 and 3 packages.
-rw-r--r--.SRCINFO44
-rw-r--r--PKGBUILD32
2 files changed, 65 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88731fb5fc10..8fcb9e43ff6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Oct 28 18:41:05 UTC 2018
+# Sat Nov 3 19:17:58 UTC 2018
pkgbase = magic-wormhole
pkgdesc = Securely transfer data between computers
pkgver = 0.11.0
@@ -7,20 +7,31 @@ pkgbase = magic-wormhole
url = https://pypi.python.org/pypi/magic-wormhole/0.11.0
arch = any
license = MIT
+ makedepends = python2-setuptools
makedepends = python-setuptools
- depends = python
depends = python-click
+ depends = python2-click
depends = python-cffi
+ depends = python2-cffi
depends = python-autobahn
+ depends = python2-autobahn
depends = python-tqdm
+ depends = python2-tqdm
depends = python-hkdf
+ depends = python2-hkdf
depends = python-pynacl
+ depends = python2-pynacl
depends = python-spake2
+ depends = python2-spake2
depends = python-humanize
depends = python-idna
+ depends = python2-idna
depends = python-service-identity
+ depends = python2-service-identity
depends = python-ipaddress
+ depends = python2-ipaddress
depends = python-txtorcon
+ depends = python2-txtorcon
provides = wormhole
provides = wormhole-server
conflicts = wormhole
@@ -28,5 +39,32 @@ pkgbase = magic-wormhole
source = https://files.pythonhosted.org/packages/source/m/magic-wormhole/magic-wormhole-0.11.0.tar.gz
md5sums = 7895fbef34c24b954e1c4b0196bc39f7
-pkgname = magic-wormhole
+pkgname = python2-magic-wormhole
+ pkgdesc = Securely transfer data between computers
+ depends = python2-click
+ depends = python2-cffi
+ depends = python2-autobahn
+ depends = python2-tqdm
+ depends = python2-hkdf
+ depends = python2-pynacl
+ depends = python2-spake2
+ depends = python2-idna
+ depends = python2-service-identity
+ depends = python2-ipaddress
+ depends = python2-txtorcon
+
+pkgname = python-magic-wormhole
+ pkgdesc = Securely transfer data between computers
+ depends = python-click
+ depends = python-cffi
+ depends = python-autobahn
+ depends = python-tqdm
+ depends = python-hkdf
+ depends = python-pynacl
+ depends = python-spake2
+ depends = python-humanize
+ depends = python-idna
+ depends = python-service-identity
+ depends = python-ipaddress
+ depends = python-txtorcon
diff --git a/PKGBUILD b/PKGBUILD
index 623fd913f410..2da913db27e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,41 @@
# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
-pkgname=magic-wormhole
+pkgbase=magic-wormhole
+_pkgname='magic-wormhole'
+pkgname=('python2-magic-wormhole' 'python-magic-wormhole')
pkgver=0.11.0
pkgrel=1
pkgdesc="Securely transfer data between computers"
arch=('any')
-url="https://pypi.python.org/pypi/${pkgname}/${pkgver}"
+url="https://pypi.python.org/pypi/${_pkgname}/${pkgver}"
license=('MIT')
-depends=('python' 'python-click' 'python-cffi' 'python-autobahn' 'python-tqdm' 'python-hkdf' 'python-pynacl' 'python-spake2' 'python-humanize' 'python-idna' 'python-service-identity' 'python-ipaddress' 'python-txtorcon')
-makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+depends=('python-click' 'python2-click' 'python-cffi' 'python2-cffi' 'python-autobahn' 'python2-autobahn' 'python-tqdm' 'python2-tqdm' 'python-hkdf' 'python2-hkdf' 'python-pynacl' 'python2-pynacl' 'python-spake2' 'python2-spake2' 'python-humanize' 'python-idna' 'python2-idna' 'python-service-identity' 'python2-service-identity' 'python-ipaddress' 'python2-ipaddress' 'python-txtorcon' 'python2-txtorcon')
+makedepends=('python2-setuptools' 'python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
conflicts=("wormhole" "wormhole-server")
provides=("wormhole" "wormhole-server")
md5sums=('7895fbef34c24b954e1c4b0196bc39f7')
+prepare() {
+ cp -a ${_pkgname}-${pkgver}{,-py2}
+}
+
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py build
+ python2 setup.py build
+}
+
+package_python2-magic-wormhole() {
+ pkgdesc="Securely transfer data between computers"
+ depends=('python2-click' 'python2-cffi' 'python2-autobahn' 'python2-tqdm' 'python2-hkdf' 'python2-pynacl' 'python2-spake2' 'python2-idna' 'python2-service-identity' 'python2-ipaddress' 'python2-txtorcon')
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
}
-package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+package_python-magic-wormhole() {
+ pkgdesc="Securely transfer data between computers"
+ depends=('python-click' 'python-cffi' 'python-autobahn' 'python-tqdm' 'python-hkdf' 'python-pynacl' 'python-spake2' 'python-humanize' 'python-idna' 'python-service-identity' 'python-ipaddress' 'python-txtorcon')
+ cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
}