summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormirandir2015-06-08 12:29:59 +0200
committermirandir2015-06-08 12:29:59 +0200
commit54c977c737cc5d9eda7405217241e2d5aee9e831 (patch)
tree6212454e886d45280c86c34fc7323d6494d9a615
downloadaur-54c977c737cc5d9eda7405217241e2d5aee9e831.tar.gz
AUR4 import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a31f0b5d3a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = magiccollection
+ pkgdesc = Magic Collection is a small program to manage your collection of Magic: the Gathering cards (software in french only).
+ pkgver = 0.8.10
+ pkgrel = 1
+ url = http://mirandir.pagesperso-orange.fr/magiccollection/
+ arch = any
+ license = GPL3
+ depends = gtk3
+ depends = python
+ depends = python-gobject
+ depends = python-lxml
+ source = http://mirandir.pagesperso-orange.fr/files/magiccollection_0.8.10.tar.xz
+ sha256sums = 824002df04385619a28e4e194b621bde92a7bfe0ef08002056f4656bdfb57f67
+
+pkgname = magiccollection
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d9f73bacae3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: mirandir <mirandir@orange.fr>
+
+pkgname=magiccollection
+pkgver=0.8.10
+pkgrel=1
+pkgdesc="Magic Collection is a small program to manage your collection of Magic: the Gathering cards (software in french only)."
+arch=('any')
+license=('GPL3')
+depends=('gtk3' 'python' 'python-gobject' 'python-lxml')
+url="http://mirandir.pagesperso-orange.fr/magiccollection/"
+source=(http://mirandir.pagesperso-orange.fr/files/"$pkgname"_"$pkgver".tar.xz)
+sha256sums=('824002df04385619a28e4e194b621bde92a7bfe0ef08002056f4656bdfb57f67')
+
+package() {
+ cd "$srcdir"
+
+ install -d $pkgdir/usr/share/{applications,magiccollection}
+ install -d $pkgdir/usr/share/magiccollection/{images,functions,signals}
+ cp -r images/* $pkgdir/usr/share/magiccollection/images/
+ cp -r functions/* $pkgdir/usr/share/magiccollection/functions/
+ cp -r signals/* $pkgdir/usr/share/magiccollection/signals/
+
+ cp globals.py $pkgdir/usr/share/magiccollection
+ cp gpl3.txt $pkgdir/usr/share/magiccollection
+ cp magic_collection.glade $pkgdir/usr/share/magiccollection
+ cp magic_collection.py $pkgdir/usr/share/magiccollection
+ cp mclogo.png $pkgdir/usr/share/magiccollection
+ cp mclogo_min.png $pkgdir/usr/share/magiccollection
+ cp buttonlogomenu.css $pkgdir/usr/share/magiccollection
+ cp magiccollection.desktop $pkgdir/usr/share/applications
+}