summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormirandir2016-08-05 10:58:07 +0200
committermirandir2016-08-05 10:58:07 +0200
commit55e120dd2625091c4bad7127b651b02181b2a72f (patch)
tree29a20b3ed7af19f254e0899ae4ad3f033b47d91b
parentf4bfb7f1c06406d28050b356a229746bc9b3f672 (diff)
downloadaur-55e120dd2625091c4bad7127b651b02181b2a72f.tar.gz
Version 0.8.113
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD30
2 files changed, 21 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6678809b99bb..41a4ab600943 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = magiccollection
- pkgdesc = Magic Collection is a small program to manage your collection of Magic: the Gathering cards (software in french only).
- pkgver = 0.8.10
- pkgrel = 2
+ pkgdesc = Magic Collection is a small program to manage your collection of Magic: the Gathering cards.
+ pkgver = 0.8.113
+ pkgrel = 1
url = http://mirandir.pagesperso-orange.fr/magiccollection/
arch = any
license = GPL3
depends = gtk3
depends = python
depends = python-gobject
- depends = python-lxml
- source = http://mirandir.pagesperso-orange.fr/files/magiccollection_0.8.10.tar.xz
- sha256sums = f2e8d0941eb2f46473798310f0e676ca6b5a27f09354b0123b2300ecb238a035
+ source = http://mirandir.pagesperso-orange.fr/files/magiccollection_0.8.113.tar.xz
+ sha256sums = 4278e1751d9ff5fcd2bf0cd77831ba696fa5aa93e5e91f2bf01db36fa5eaf2be
pkgname = magiccollection
diff --git a/PKGBUILD b/PKGBUILD
index fb0c9ea153ee..850f241e94bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,33 @@
# Maintainer: mirandir <mirandir@orange.fr>
pkgname=magiccollection
-pkgver=0.8.10
-pkgrel=2
-pkgdesc="Magic Collection is a small program to manage your collection of Magic: the Gathering cards (software in french only)."
+pkgver=0.8.113
+pkgrel=1
+pkgdesc="Magic Collection is a small program to manage your collection of Magic: the Gathering cards."
arch=('any')
license=('GPL3')
-depends=('gtk3' 'python' 'python-gobject' 'python-lxml')
+depends=('gtk3' 'python' 'python-gobject')
url="http://mirandir.pagesperso-orange.fr/magiccollection/"
source=(http://mirandir.pagesperso-orange.fr/files/"$pkgname"_"$pkgver".tar.xz)
-sha256sums=('f2e8d0941eb2f46473798310f0e676ca6b5a27f09354b0123b2300ecb238a035')
+sha256sums=('4278e1751d9ff5fcd2bf0cd77831ba696fa5aa93e5e91f2bf01db36fa5eaf2be')
package() {
cd "$srcdir"
install -d $pkgdir/usr/share/{applications,magiccollection}
- install -d $pkgdir/usr/share/magiccollection/{images,functions,signals}
- cp -r images/* $pkgdir/usr/share/magiccollection/images/
+ install -d $pkgdir/usr/share/magiccollection/{functions,images,objects,translations}
+ install -d $pkgdir/usr/share/icons/hicolor
cp -r functions/* $pkgdir/usr/share/magiccollection/functions/
- cp -r signals/* $pkgdir/usr/share/magiccollection/signals/
+ cp -r images/* $pkgdir/usr/share/magiccollection/images/
+ cp -r objects/* $pkgdir/usr/share/magiccollection/objects/
+ cp -r translations/* $pkgdir/usr/share/magiccollection/translations/
+ cp -r icons_os/hicolor/* $pkgdir/usr/share/icons/hicolor/
- cp globals.py $pkgdir/usr/share/magiccollection
+ cp defs.py $pkgdir/usr/share/magiccollection
cp gpl3.txt $pkgdir/usr/share/magiccollection
- cp magic_collection.glade $pkgdir/usr/share/magiccollection
- cp magic_collection.py $pkgdir/usr/share/magiccollection
- cp mclogo.png $pkgdir/usr/share/magiccollection
- cp mclogo_min.png $pkgdir/usr/share/magiccollection
- cp buttonlogomenu.css $pkgdir/usr/share/magiccollection
+ cp magic_collection.py $pkgdir/usr/share/magiccollection/magic_collection
+ chmod +x $pkgdir/usr/share/magiccollection/magic_collection
+ cp README.md $pkgdir/usr/share/magiccollection/README
+
cp magiccollection.desktop $pkgdir/usr/share/applications
}