summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorajs1242015-06-09 21:39:20 +0200
committerajs1242015-06-09 21:39:20 +0200
commitd6e2ee96397101ee68a37d67b049ca9cae198cf9 (patch)
treeaaaa1711ebdcca696adf58a7e6aea701e7045ca6
downloadaur-d6e2ee96397101ee68a37d67b049ca9cae198cf9.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD51
-rw-r--r--magichexagon-git.desktop9
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..479e64d775e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = magichexagon-git
+ pkgdesc = Super Hexagon, ponified
+ pkgver = 89.3f4972a
+ pkgrel = 1
+ url = https://github.com/meh2481/magichexagon
+ arch = x86_64
+ arch = i686
+ license = custom:zlib
+ makedepends = git
+ makedepends = cmake
+ depends = sdl2
+ depends = freeimage
+ depends = box2d
+ depends = tinyxml
+ depends = openal
+ depends = libvorbis
+ depends = glu
+ depends = fmodex
+ source = magichexagon-git::git+https://github.com/meh2481/magichexagon.git
+ source = git+https://github.com/fgenesis/ttvfs.git
+ source = magichexagon-git.desktop
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 67f1b6e2ebaf1b6ff5de7991fde388b4efcea97e0c04b1cbd425e9079ead280b
+
+pkgname = magichexagon-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..143f4d6fa1fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: ajs124 < aur AT ajs124 DOT de >
+
+pkgname=magichexagon-git
+pkgver=89.3f4972a
+pkgrel=1
+pkgdesc="Super Hexagon, ponified"
+arch=('x86_64' 'i686')
+url="https://github.com/meh2481/magichexagon"
+license=('custom:zlib')
+depends=('sdl2' 'freeimage' 'box2d' 'tinyxml' 'openal' 'libvorbis' 'glu' 'fmodex')
+makedepends=('git' 'cmake')
+source=($pkgname::git+https://github.com/meh2481/magichexagon.git
+ git+https://github.com/fgenesis/ttvfs.git
+ $pkgname.desktop)
+sha256sums=(SKIP
+ SKIP
+ 67f1b6e2ebaf1b6ff5de7991fde388b4efcea97e0c04b1cbd425e9079ead280b)
+
+[[ $CARCH == x86_64 ]] && BITS=64
+[[ $CARCH == i686 ]] && BITS=32
+
+pkgver() {
+ cd ${pkgname}
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+build() {
+ install -d ttvfs/build
+ cd ttvfs/build
+ cmake ..
+ make
+ cp ttvfs/libttvfs.a ../../${pkgname}/lib/Linux_x$BITS
+ cd "${srcdir}/${pkgname}"
+ sed -i 's_<fmod.h>_<fmodex/fmod.h>_' Engine.h
+ sed -i 's/-ltinyxml2/-ltinyxml -lfmodex/;s/-lSDL2main//;s/-ltyrsound//' Makefile*.unix
+ make release
+
+ if [ -x /usr/bin/chrpath ] ; then
+ chrpath -d magichexagon_$BITS
+ fi
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -D magichexagon_$BITS "${pkgdir}/usr/lib/${pkgname}/${pkgname}"
+ install -d "${pkgdir}/usr/bin/"
+ printf "#!/bin/sh\ncd /usr/lib/${pkgname}\n./${pkgname}" > "${pkgdir}/usr/bin/${pkgname}"
+ chmod 755 "${pkgdir}/usr/bin/${pkgname}"
+ cp -a res "${pkgdir}/usr/lib/${pkgname}/"
+ install -D "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
diff --git a/magichexagon-git.desktop b/magichexagon-git.desktop
new file mode 100644
index 000000000000..ab1726bbc5d4
--- /dev/null
+++ b/magichexagon-git.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=magic hexagon
+Comment=super hexagon, ponified
+Exec=magichexagon-git
+Terminal=false
+Categories=Games;
+Icon=
+StartupNotify=false