summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohan Förberg2016-10-16 17:41:24 +0200
committerJohan Förberg2016-10-16 18:43:03 +0200
commit35fb5b5fd08792576c7829dad6e56aa200f70fcb (patch)
tree9a42cd766e8ca0cf2cc4455015c2d44bf5bf4763
downloadaur-35fb5b5fd08792576c7829dad6e56aa200f70fcb.tar.gz
A first attempt at packaging Chamsys Magicq.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD47
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c28344b5279
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Sun Oct 16 16:43:00 UTC 2016
+pkgbase = magicq
+ pkgdesc = Lighting control software from Chamsys
+ pkgver = 1.7.2.4
+ pkgrel = 1
+ url = https://secure.chamsys.co.uk/magicq
+ arch = x86_64
+ license = unknown
+ depends = ffmpeg-compat-55
+ depends = libcups
+ depends = glu
+ depends = qt5-multimedia
+ depends = libusb-compat
+ depends = qt5-webkit
+ depends = libarchive
+ options = !strip
+ source = local://magicq_1.7.2.4_amd64.deb
+ sha1sums = 39472db2c562f7ab8b8d3a9fa03fc4fa3a1a3436
+
+pkgname = magicq
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5352dc983616
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Johan Förberg <johan@forberg.se>
+pkgname=magicq
+pkgver=1.7.2.4
+pkgrel=1
+pkgdesc='Lighting control software from Chamsys'
+arch=(x86_64)
+url='https://secure.chamsys.co.uk/magicq'
+groups=()
+depends=(ffmpeg-compat-55 libcups glu qt5-multimedia libusb-compat qt5-webkit
+ libarchive)
+options=('!strip') # Binaries are already stripped.
+
+# You can obtain this file from https://secure.chamsys.co.uk/download
+source=("local://magicq_${pkgver}_amd64.deb")
+sha1sums=('39472db2c562f7ab8b8d3a9fa03fc4fa3a1a3436')
+
+# I've been unable to find any formal license for Magicq. The website only
+# states that it's available free of charge. There don't seem to be any
+# restrictions on use, except that some features are disabled unless Chamsys
+# hardware is detected.
+license=(unknown)
+
+package() {
+ cd "$pkgdir"
+
+ bsdtar xf "$srcdir/data.tar.gz"
+
+ # We use the system libraries instead of the bundled binaries.
+ rm -rf opt/magicq/lib*.so*
+
+ # Magicq expects to be able to write these directories.
+ # The directory list comes from the debian package postinst.
+ chmod 777 opt/magicq
+
+ for dir in log show web thumbs backuparchive convert audio; do
+ mkdir -p "opt/magicq/$dir"
+ chmod -R 777 "opt/magicq/$dir"
+ done
+
+ # Fix permissions from .deb file.
+ find usr etc -type f -exec chmod 644 {} + , -type d -exec chmod 755 {} +
+
+ mkdir -p usr/bin
+ ln -s /opt/magicq/runmagicq.sh usr/bin/magicq
+ ln -s /opt/magicq/runmagichd.sh usr/bin/magichd
+ ln -s /opt/magicq/runmagicvis.sh usr/bin/magicvis
+}