summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2015-06-08 07:47:58 -0700
committerShadowKyogre2015-06-08 07:47:58 -0700
commit0d4733ecf48b156d3695b6812579c97a50f7126c (patch)
treeb332390c913c6d1673ff92c245577a208f6cf7c4
downloadaur-0d4733ecf48b156d3695b6812579c97a50f7126c.tar.gz
Initial import
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD41
-rw-r--r--magicseteditor.install17
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8df7d9ae2e35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = magicseteditor
+ pkgdesc = A program to help create Magic: the Gathering cards and sets. Comes with no game support.
+ pkgver = 2.0.0
+ pkgrel = 11
+ url = http://magicseteditor.sourceforge.net
+ install = magicseteditor.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ makedepends = unzip
+ makedepends = pkg-config
+ makedepends = svn
+ depends = hunspell
+ depends = libjpeg
+ depends = wxgtk2.8
+ depends = boost-libs
+ provides = magicseteditor=2.0.0
+ conflicts = magicseteditor-bin
+ conflicts = magicseteditor-svn
+ conflicts = mse2
+ conflicts = magicseteditor-xyz-mod
+ options = !strip
+ source = mse-2.0.0::svn+https://magicseteditor.svn.sourceforge.net/svnroot/magicseteditor/tags/releases/mse-2.0.0#
+ md5sums = SKIP
+
+pkgname = magicseteditor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..babf52f9ec4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributor: Sapphira Armageddos <shadowkyogre.public+aur@gmail.com>
+pkgname=magicseteditor
+pkgver=2.0.0
+pkgrel=11
+pkgdesc="A program to help create Magic: the Gathering cards and sets. Comes with no game support."
+arch=('i686' 'x86_64')
+url="http://magicseteditor.sourceforge.net"
+license=('GPL')
+depends=('hunspell' 'libjpeg' 'wxgtk2.8' 'boost-libs')
+makedepends=('boost' 'unzip' 'pkg-config' 'svn')
+provides=("magicseteditor=${pkgver}")
+conflicts=('magicseteditor-bin' 'magicseteditor-svn' 'mse2' 'magicseteditor-xyz-mod')
+source=("mse-${pkgver}::svn+https://magicseteditor.svn.sourceforge.net/svnroot/magicseteditor/tags/releases/mse-${pkgver}#")
+install=$pkgname.install
+options=(!strip)
+md5sums=(SKIP)
+
+build() {
+ cd "$srcdir/mse-${pkgver}"
+ ./configure --prefix=/usr --with-wx-config=/usr/bin/wx-config-2.8
+ #sed -e 's|^\(AM_LDFLAGS = .*\),--as-needed|\1,-Bsymbolic-functions|' -i Makefile
+ make LIBS="-lboost_system $(pkg-config --libs hunspell) $(wx-config-2.8 --libs)" \
+ CPPFLAGS="-I/usr/include/hunspell -fpermissive" || return 1
+
+}
+
+package()
+{
+ cd "$srcdir/mse-${pkgver}"
+ make DESTDIR=$pkgdir install || return 1
+ mkdir -p $pkgdir/usr/share/magicseteditor/{resource,data}
+ cp -r ./data/*.mse-locale $pkgdir/usr/share/magicseteditor/data
+ cp -r ./src/resource/common/* $pkgdir/usr/share/magicseteditor/resource
+ cp -r ./src/resource/msw/other/* $pkgdir/usr/share/magicseteditor/resource
+ cp -r ./src/resource/msw/{cursor,icon,tool} $pkgdir/usr/share/magicseteditor/resource
+ rm -rf $pkgdir/usr/share/magicseteditor/resource/{cursor,icon,tool}/.svn
+ rm -rf $pkgdir/usr/share/magicseteditor/data/.svn
+ rm -rf $pkgdir/usr/share/magicseteditor/data/*/.svn
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/magicseteditor.install b/magicseteditor.install
new file mode 100644
index 000000000000..bd80c6245e13
--- /dev/null
+++ b/magicseteditor.install
@@ -0,0 +1,17 @@
+post_install()
+{
+cat <<-EndOfMessage
+The fonts required for this package can't be put on the AUR due to licensing issues.
+In order to get them, download the binary release here:
+http://downloads.sourceforge.net/magicseteditor/mse-linux32-2011-02-05-full.tar.gz
+Copy the fonts into your /usr/share/fonts/TTF folder or wrap them up
+with some fancy PKGBUILD of your own.
+
+You may also want to install one or more of the following packages:
+mse-ygo or mse-ygo-xyz for YuGiOh! support
+mse-mtg or mse-mtg-phyrexian for Magic: the Gathering support
+mse-vs for VS support
+
+Happy editing!
+EndOfMessage
+}